Samba: problems writing large files with windows 10

Everything works fine for small files except I can't write more than 6.9MB (17747637 bytes)

One day ?? It worked, now I don't understand anything!!!

Someone had a similar issue, I'm having a difficult time searching...

It's interesting; because they took screenshots also; and their native system language was French too...

Unfortunately the forum guy with the Ouija board + the crystal ball is still on sick leave.
Maybe you could post samba config, mount/fstab config, device name, samba version and OpenWRT version in the mean time :wink:

1 Like

Previously I used external USB drives and I could directly copy large files from a windows machine

Now I have a Cyberoam CR25Wing case. So I use the unused part of the disk formatted in NTFS and it's annoying to disassemble the box to write files to it externally

That's when I realized that with other OpenWrt boxes with USB disk it was the same when I used network transfer

I have tested with old WR1200JS with 18.06

I think it comes from Windows 10 / 11

I will see with windows 7 if I find an old laptop


OpenWrt 21.02.0-rc3, r16172-2aba3e9784


config samba
        option workgroup 'WORKGROUP'
        option charset 'UTF-8'
        option description 'Samba on OpenWRT'
        option interface 'lan'

config sambashare
        option name 'USB'
        option path '/mnt'
        option read_only 'no'
        option guest_ok 'yes'
        option create_mask '0666'
        option dir_mask '0777'
        option force_root '1'

samba template

	netbios name = |NAME| 
	display charset = |CHARSET|
	interfaces = |INTERFACES|
	server string = |DESCRIPTION|
	unix charset = |CHARSET|
	workgroup = |WORKGROUP|
	bind interfaces only = yes
	deadtime = 30
	enable core files = no
	invalid users = root
	local master = no
	map to guest = Bad User
	max protocol = SMB2
	min receivefile size = 16384
	null passwords = yes
	passdb backend = smbpasswd
	security = user
	smb passwd file = /etc/samba/smbpasswd
	use sendfile = yes


config global
        option anon_swap '0'
        option auto_swap '1'
        option auto_mount '1'
        option delay_root '5'
        option anon_mount '1'
        option check_fs '1'


root@XIAOMI-221:/etc/config# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelega                                                                                                                                                             te)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock6 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/up                                                                                                                                                             per,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,noatime,mode=700)
/dev/sda1 on /mnt/sda1 type fuseblk (rw,relatime,user_id=0,group_id=0,allow_othe                                                                                                                                                             r,blksize=4096)

for a test, try changing that to

so not sharing /mnt, but the external drive path itself

my guess:
/mnt is located on the routers local partition, maybe samba does not check free space on the tree node which is a link to sda1=another mount, but on the root path which points to the overlay partition of the router, maybe there is around 7MB free on your router?

-> Dear pico

My disk is sda3

yes , with config sambashare
option path '/mnt/sda3'

In this case i can copy large files


But i use automount and i have this page with all disks / partitions with

config sambashare
option path '/mnt/'

block detect

root@CR25-65:/# block detect
config 'global'
        option  anon_swap       '0'
        option  anon_mount      '0'
        option  auto_swap       '1'
        option  auto_mount      '1'
        option  delay_root      '5'
        option  check_fs        '0'

config 'mount'
        option  target  '/boot'
        option  uuid    '84173db5-fa99-e35a-95c6-28613cc79ea9'
        option  enabled '0'

config 'mount'
        option  target  '/'
        option  uuid    'ff313567-e9f1-5a5d-9895-3ba130b4a864'
        option  enabled '0'

config 'mount'
        option  target  '/mnt/sda3'
        option  uuid    'AC0C4FEA0C4FADE0'
        option  enabled '0'

config 'mount'
        option  target  '/mnt/sdb1'
        option  uuid    'A83A489D3A486B00'
        option  enabled '0'

config 'mount'
        option  target  '/mnt/sdb2'
        option  uuid    '6119-3B54'
        option  enabled '0'

config 'mount'
        option  target  '/mnt/sdc1'
        option  uuid    '0255-5785'
        option  enabled '0'

C'est quand même assez simple : "espace insuffisant". Votre disque est plein.
Quel périphérique ? Où copiez-vous les fichiers ? Quel est l'espace disque ?
Fournissez assez d'information pour obtenir une réponse vailde.

It's quite easy : "insufficient space". Your disk is full.
Which device ? Where are you copying these files ? What is the disk space ?
Provide enough information in order to have a valid response.

Si j' utilise /mnt sans le sda3 et que j' ai plusieurs disques avec eux mêmes plusieurs partitions je les vois tous automatiquement comme sur l' image.
Tout est monté automatiquement sans rien programmer mais dans ce cas je ne peux pas copier de gros fichiers alors qu'il y a largement assez de place car avec /mnt/sda3 cela fonctionne

If I use /mnt without the sda3 and I have several disks with themselves several partitions I see them all automatically as in the image.
Everything is shown automatically without programming anything but in this case i can't copy large files when there is plenty of space because with /mnt/sda3 it works

block info

/dev/sda1: UUID="84173db5-fa99-e35a-95c6-28613cc79ea9" LABEL="kernel" VERSION="1.0" MOUNT="/boot" TYPE="ext4"
/dev/sda2: UUID="ff313567-e9f1-5a5d-9895-3ba130b4a864" LABEL="rootfs" VERSION="1.0" MOUNT="/" TYPE="ext4"
/dev/sda3: UUID="AC0C4FEA0C4FADE0" LABEL="59-GB" MOUNT="/mnt/sda3" TYPE="ntfs"
/dev/sdb1: UUID="A83A489D3A486B00" LABEL="CCCOMA_X64FRE_FR-FR_DV9" MOUNT="/mnt/sdb1" TYPE="ntfs"
/dev/sdb2: UUID="6119-3B54" LABEL="UEFI_NTFS" VERSION="FAT12" MOUNT="/mnt/sdb2" TYPE="vfat"
/dev/sdc1: UUID="0255-5785" LABEL="DEBIAN" VERSION="FAT32" MOUNT="/mnt/sdc1" TYPE="vfat"


Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root               104788     92268     10392  90% /
tmpfs                   990156      4392    985764   0% /tmp
/dev/sda1                16084      5284     10476  34% /boot
/dev/sda1                16084      5284     10476  34% /boot
tmpfs                      512         0       512   0% /dev
/dev/sdb2                 1004       904       100  90% /mnt/sdb2
/dev/sda3             62395388   1477688  60917700   2% /mnt/sda3
/dev/sdb1             15159248   5845724   9313524  39% /mnt/sdb1
/dev/sdc1             15318016    470936  14847080   3% /mnt/sdc1

Cela me fait penser à autre chose:
Y aurait-il un moyen de voir dans l' explorateur non pas sd1,sd2 ... mais le LABEL de la partition des disques ?

This reminds me of something else:
Would there be a way to see in the explorer not sd1,sd2 ... but the LABEL of the partition of the disks ?

WinSCP fonctionne mais c'est lent

WinSCP works but is slow

Samba service needs large memory >1G and cpu >2ghz to works well.

What is the hardware on?

I use at this time a x86 Cyberoam CR25Wing

What's a bit silly is that automount works just fine. I can use a HUB with many disks in USB
The concern is that there is no possibility of autoconfiguration for samba

Note that I have an old Netgear WNR3500 box with Linux / Tomato firmware which has samba autoconfiguration which works very well
I pulled the Netgear router out of the attic...
I also have no problem with large files (videos) but it's old equipment and the transfers are very slow
I have this in explorer as OpenWrt automount