SAMBA logging and file shares aren't working

The issue is that samba isn‘t accepting any connections from linux as well as from windows 10.
But thats not the worst, the worst is that additionally samba isn‘t logging anything.
Neither in its own log-files (/var/log/samba.log.smbd, samba.log.samba24, samba.log. nor in Luci-syslog.
And this is hindering all my problem solving efforts.

Can anyone help?

How can I convice samba to be more communicative?
How can I convice samba to work?
Did anyone have had the same problems?

My configuration is:
Hostname: LEDE
Model: Linksys WRT1900ACS
Firmware Version: LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)
Kernel Version: 4.4.92

smbd –version: Version 3.6.25

_	netbios name = |NAME| _
_	workgroup = |WORKGROUP|_
_	server string = |DESCRIPTION|_
_	# set the debug level	_
_	syslog = 10_
_	syslog only = yes_
_	# log file size limitation_
_	max log size = 3000_
_	encrypt passwords = yes_
_	passdb backend = smbpasswd_
_	obey pam restrictions = yes_
_	unix charset = ISO-8859-1_
_	local master = yes_
_	preferred master = yes_
_	os level = 20_
_	security = share_
_	guest account = root_
_	# invalid users = root_
_	null passwords = yes_
_	smb passwd file = /etc/samba/smbpasswd_
_	name resolve order = lmhosts hosts bcast_
_	socket options = TCP_NODELAY IPTOS_LOWDELAY_

_ comment = /mnt/samba_
_ path = /mnt/samba_
_ browseable = yes_
_ public = yes_
_ writeable = yes_
_ invalid users = nobody_
_ valid users = name#1 name2_
_ inherit permissions = yes_

Here's my config, I don't know what's required, but I notice you don't have interfaces. If you don't get anything at all in the syslog then I my first guess would be that it's not running.

netbios name = |NAME| 
display charset = |CHARSET|
interfaces = |INTERFACES|
server string = |DESCRIPTION|
unix charset = |CHARSET|
workgroup = |WORKGROUP|
local master = no
browseable = yes
deadtime = 30
domain master = yes
encrypt passwords = yes
enable core files = no
invalid users = root
load printers = no
map to guest = Bad User
max protocol = SMB2
min receivefile size = 16384
null passwords = yes
passdb backend = smbpasswd
preferred master = yes
security = user
smb passwd file = /etc/samba/smbpasswd
syslog = 2
use sendfile = yes
writeable = yes
bind interfaces only = yes

Please disregard...

Thank you for your quick answers!

In the last few days I have worked on this topic and found some solutions.

  1. Regarding the logging issue: A post I found (can't find the link anymore) has been mentioned that in newer SAMBA versions the log function has been disabled at compile time, due to security reasons (!?).

  2. Regarding the samba-share issue: I tested nearly every smb.conf setting I found in any posts. Nothing worked.
    Than I started to set up the permissions.
    a) added system users "name#1" and "name#2" that shall be able to access the samba share.
    b) added the new system users to "smbpasswd".
    c) added a new group "sambashare" in "/etc/group" and added the new samba users to it ("sambashare:x:128:name#1,name#2").
    d) changed the owner of the shared files to "name#1:sambashare" and the permissions to "ug+rwx" for directories and "ug+rw" for files.

After that the access to the samba share worked, but only for windows clients!
My Ubuntu client is still not able to access it!
A Wireshark network trace (!!! Logging is not working !!!) showed that the connection has been rejected with a "STATUS_WRONG_PASSWORD" message.
Despite the fact that windows and linux are using the same password for the same user.

This issue is just left!!!!!