Samba force-user

Hi Forum,
I would like my SMB user allow to read ALL files in / and subdirs.
On Ubuntu I did this user "force user = root" in /etc/samba/smb.conf.
So I tried adding "option force user = root" to the share /, but it did not work.
Any ideas how i can allow my SMB user to read all files.
Must I use acl? I would prefer to edit /etc/config/samba.


This may be helpful...

This is how I set up my Samba share and it works fine ( scroll down a bit to Add a share if you've already added your user, change perms as needed ).

AFAIK, "force user" option cannot be used in "/etc/config/samba", you have to use "/etc/samba/smb.conf.template" instead.

Just played a little around...
There is /etc/samba/smb.conf and /etc/config/samba.
Why? The configfile /etc/samba/smb.conf was like a normal samba configfile. But I guess a played a little to much... My Windows notebook could no acess any share anymore smile
So for today I removed samba from the router and will do a clean setup tomorrow, using only /etc/samba/smb.conf.

OK installed only samba server.
When I edit /etc/samba/smb.conf and /etc/config/samba is default all my changes done to /etc/samba/smb.conf will be deleted. OK look like a OpenWRT thing... to get a smb.conf with the files from /etc/config/samba, right?

So I edit the template. And what a surprise the changed there will last! yeah
But I still cant access and files on "/", I only see them. If I want cd into /etc/ Windows tells me that I have no right to do so and I should ask my admin :frowning:

This is my config now, from /etc/samba/smb.conf.

        netbios name = Lede
        display charset = UTF-8
        interfaces = lo br-lan
        server string = Lede
        unix charset = UTF-8
        workgroup = WORKGROUP
        bind interfaces only = yes
        deadtime = 30
        enable core files = no
#       invalid users = root
        local master = no
        map to guest = Bad User
        max protocol = SMB2
        min receivefile size = 16384
        null passwords = yes
        passdb backend = smbpasswd
        security = user
        smb passwd file = /etc/samba/smbpasswd
        use sendfile = yes

#05:00 am
        path = /
        browsable = yes
        read only = yes
        valid users = skafan
        force user = root

        comment     = Home Directories
        browsable   = no
        read only   = no
        create mode = 0750

Hi, did you be able to access / as samba share with root login?
I'm in trouble as you, needing to access whole filesystem via samba.
In other not openwrt Linux distro running samba 3.6 it was just simple but now I can't find any option useful to fill in smb.conf root share.
I can just get access in / directory but not any other directory above, receiving an access denied.
I tried:
Enable core files = yes
Admin users = root
Administrative share = yes
And others but unsuccessfully.
I'll try 'force user = root' as you suggested...
Just for info with samba 4 works... but not in samba 3.6.
Thanks to all in advance

Not works and log seems to be not working adding in smb.conf log file and loglevel nor adding in start script flags for enabling logs
No way to share / ? :roll_eyes:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.