Samba 4 install (opkg?) on Linksys WRT1200AC w/ OpenWRT 21.02.7

Odd issue here... want to see if anybody else has seen it... Did a fresh install of OpenWRT 21.02.7 on a Linksys WRT1200AC. I did this by switching to the Linksys factory firmware partition and installing the OpenWRT factory image as a firmware upgrade and then rebooting into OpenWRT. No problems so far. Next I used the webif to opkg (System... Software), updated the lists (no problem there) and then attempted to install all of Samba 4 server by installing package luci-i18n-samba4-en, which attempted to install all of the dependencies, as it should. Here's where the problem came in: opkg got all the way through installing samba4-libs, and stopped on an attempt to install samba4-server with a message saying the file system was full...


I did notice that my available overlayfs space was quite low and rebooted. After rebooting, the space was about the same, and I went back into the webif Software installation page and installed the last two packages I need to install to make samba4 server installation complete, and opkg was able to do this. So this may be some kind of weird opkg limitation (it was something like 11+ MB) or bug, possibly with interaction with the filesystem...

P.S.: I have some other screen caps of how opkg responded, if anybody wants to see them... I captured the install of samba4-server and then luci-18n-samba4-en (but only the response on the luci install...), and on those opkg worked as expected.

P.P.S.: Please don't harangue me about the switch issue in these routers. I'm well aware of it. That's why I'm stopping at version 21.02.7 and not going any farther...