Running TPL-WDR4900 radio in monitoring mode

Hello, guys. I configured latest OpenWRT on TPL-WDR4900 as 2.4Ghz Wireless Client, installed terminal and hcxdumptool packages, and am trying to run the router in monitoring promiscuous mode to capture packets. The tool works, but the error warns that wpa_supplicant is running and may interfere with it resulting in errors, and indeed the tool exits in a few minutes with max error threshold reached. Some resulting .pcapng files can't be read due to errors.

The router has higher range and sensitivity compare to a PC WiFi Adapter, and better suited for such learning tests. I was trying to find on the web how to disable wpa_supplicant on a certain wlan, or generally on all router radios while running the above tool, but couldn't find a clear answer. Manually killing wpa_supplicant process results in its auto restart shortly after.

There's default_disabled settings option for STA (including Client mode?) in wpa_supplicant.conf in /etc/config/wireless WiFi Config Wiki, but its boolen, not sure if it's the one I need and how to enable it, can't find example in a sample config? Where's wpa_supplicant.conf file is located? And how to manually enable wpa_supplicant via wpa_cli as suggested in that Wiki?

Some KILL examples for wpa_supplicant are given in Support for User-Defined Wpa-Supplicant Config thread. Not sure if its killed permanently though?

kill -9 cat /var/run/ && rm -f /var/run/

Also they give an example of starting wpa_supplicant, not sure why so convoluted way?

wpad wpa_supplicant -B -P /var/run/ -D nl80211 -i wlan2 -c /etc/config/wpad/sta.conf -C /var/run/wpa_supplicant/

Can anyone experienced with pen tests give insight or hint on the subject matter?