Run DDNS manually

I want to control when the ddns script runs by crontab.
The document [OpenWrt Wiki] DDNS client shows that I need to put option 'force_interval' '0' in config and run /usr/lib/ddns/dynamic_dns_updater.sh myddns_ipv6 0 &. It shows to much commands. The wiki needs update. /usr/lib/ddns/dynamic_dns_updater.sh -S myddns_ipv6 start should work.
Then some errors appeared:

Sun Oct 10 18:59:29 2021 user.warn ddns-scripts[20494]: myddns_ipv6: NO valid IP found
Sun Oct 10 18:59:29 2021 user.warn ddns-scripts[20494]: myddns_ipv6: Error in 'expand_ipv6()' - invalid IPv6 found: '' expanded: ''

Part of my config:

config service 'myddns_ipv6'
	option use_ipv6 '1'
	option service_name 'cloudflare.com-v4'
	option lookup_host 'sub.domain.com'
	option domain 'sub@domain.com'
	option password 'token'
	option param_opt '"proxied":false'
	option use_https '1'
	option ip_source 'network'
	option ip_network 'wan6'
	option use_syslog '2'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'
	option username 'Bearer'
	option cacert '/etc/ssl/certs'
	option interface 'wan6'
	option force_interval '0'
	option enabled '1'

I'm sure that I have public IPv6 address.

ip -6 addr list scope global wan
3: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet6 2001:xxxx::17f/128 scope global dynamic noprefixroute 
       valid_lft 2539313sec preferred_lft 552113sec

Solved by changing option interface to 'wan'. This option cannot be changed from web interface. It tries to keep ip_network and interface the same.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.