RTL8821CU Wifi Adapter on OpenWrt

I'm having trouble installing my Cudy Wifi Adapter Driver (RTL8821CU) in the OpenWRT CLI! I've already installed all necessary usb-2 and usb-3 drivers? using kmod and so forth, so I have Open WRT installed and can login via the web browser. After I couldn't get the wifi adapter driver installed I tried to install it through the OpenWRT > System > Software menu where I got this error below...

> #### Executing package manager
> 
> ##### Errors
> 
> Collected errors: * pkg_init_from_file: Malformed package file /tmp/upload.ipk.
> 
> The *opkg install* command failed with code `255`.

Is there anything I'm missing to try and get this working and be able to use my Pi4 as an OpenWRT Router!?

what package (the .ipk file) did you upload? seems like it was not a valid package

By the way, if you search this forum for RTL8821CU, I think you'll find you're SOOL making it work

1 Like

No I tried updating the .zip file of the driver, almost worked too then got that error!! lol

that's not how packages are installed in openWRT - I would argue that it didn't almost work - rather, as evidenced by the error, it completely failed

what zip file are you even talking about?

The zip file here;
http://cudytech.com/filedownload/161037

That won't work. You'll have better luck to try the available modules from the Software page. Filter with rtl and try for example the kmod-rtl8821ae

Hi, I'm having a similar issue with the Cudy AC1300 Wireless Dual Band USB adapter (Model: WU1300S).

Please, how did you end up solving it, dn_angel000?

I was following this: https://www.youtube.com/watch?v=jlHWnKVpygw, and got stuck in 21:40 when attempting to put wlan1 up. It seems the problem is the drivers.

Thanks.

PS: my packages installed:

root@OpenWrt:~#opkg list-installed | grep -i 'usb\|rt2\|mt76\|rtl8'
brcmfmac-firmware-usb - 20201118-3
kmod-mt76-core - 5.4.154+2021-06-06-22b69033-4
kmod-mt76-usb - 5.4.154+2021-06-06-22b69033-4
kmod-mt76x02-common - 5.4.154+2021-06-06-22b69033-4
kmod-mt76x02-usb - 5.4.154+2021-06-06-22b69033-4
kmod-mt76x2-common - 5.4.154+2021-06-06-22b69033-4
kmod-mt76x2u - 5.4.154+2021-06-06-22b69033-4
kmod-rt2800-lib - 5.4.154+5.10.68-1-1
kmod-rt2800-usb - 5.4.154+5.10.68-1-1
kmod-rt2x00-lib - 5.4.154+5.10.68-1-1
kmod-rt2x00-usb - 5.4.154+5.10.68-1-1
kmod-rtl8812au-ct - 5.4.154+2020-01-12-e0d586aa-2
kmod-rtl8821ae - 5.4.154+5.10.68-1-1
kmod-usb-core - 5.4.154-1
kmod-usb-ehci - 5.4.154-1
kmod-usb-gadget - 5.4.154-1
kmod-usb-hid - 5.4.154-1
kmod-usb-net - 5.4.154-1
kmod-usb-net-asix-ax88179 - 5.4.154-1
kmod-usb-net-rtl8152 - 5.4.154-1
kmod-usb-net2280 - 5.4.154-1
kmod-usb-ohci - 5.4.154-1
kmod-usb-uhci - 5.4.154-1
kmod-usb2 - 5.4.154-1
kmod-usb3 - 5.4.154-1
libusb-1.0-0 - 1.0.24-4
rt2800-usb-firmware - 20201118-3
rtl8821ae-firmware - 20201118-3
rtl8822be-firmware - 20201118-3
rtl8822ce-firmware - 20201118-3
usbids - 0.350-1
usbutils - 013-2

I didn't! I was following the same video as you and just bought the same wifi adapter used in the same video!! lol I bought four of those adapters just to try to bond them together (channel bonding) in hopes of making the speed faster, but I doubt it'll work especially if the driver(s) won't work with the device!! lol