Rtl8812au support and maintaince

I am the owner of a TP-Link Archer T2U that has the rtl8812au chipset. Currently the kmod package does not seem to be maintained and it does not support my wireless adapter. (package link) However, the Air Crack NG one supports my device and also includes features such as package capture. I have used it with other Linux machines and it seems pretty stable. It can be found here: https://github.com/aircrack-ng/rtl8812au. (Note: There is a regression with the AC600. You need commit 63cf0b4)

Would it make sense to replace the old version of this package with the Air crack NG one? If not, how would two similar kmod packages be shipped? I am looking to get OpenWRT working with my adapter and I would like to stick with premade packages.

Hello,

The wiki information "OpenWrt release" is not up to date regarding the package. This package is available in the latest OpenWRT 23.05.3. You need to install the package :

opkg update
opkg install kmod-rtl8812au-ct

After the installation, the module is loaded and enabled at startup.

This package is still maintained : https://github.com/openwrt/openwrt/tree/main/package/kernel/rtl8812au-ct

If this don't work, please try with OpenWRT version 22.03.0 and send output of dmesg.

Sorry I did not realize that the page was out of date. I already tried getting this to work on OpenWRT but the dmesg did not show anything useful from what I could see. I will post the logs in a bit.

[    4.375924] NET: Registered PF_PPPOX protocol family
[    4.379873] RTL871X: module init start
[    4.381104] RTL871X: rtl8812au v4.3.14_13455.20150212_BTCOEX20150128-51
[    4.382175] RTL871X: rtl8812au BT-Coex version = BTCOEX20150128-51
[    4.383228] usbcore: registered new interface driver rtl8812au
[    4.384196] RTL871X: module init ret=0

So it seems that it is detected and I must of missed when I looked before. However, there is still no interface listed under luci, iw dev or ip a. Maybe I need to install another package?

Do you see anything useful in logread command ?

You can also try cat /proc/modules | grep 8812 to see if module is used

It shows up in /etc/modules but the logread doesn't have anything listed.

I think this is a kernel issue as it is not in /sys/class/net/

I seems that this module only supports the AC1200 not AC600. The kernel module is working correctly but simply does not support my device.

This chipset will soon be added to the rtw88 driver in the kernel. Hopefully also in OpenWrt.

1 Like

That is excellent news