RT3200\E8450 160Mhz Not working in snapshots

with recent snapshots
I can't get 80+80 aka 160Mhz mode (on 5ghz band ofc) working on my RT3200
setting it to that mode just results in the ap not broadcasting
I see there has been some back and forth on supporting this mode on this unit but I can verify it DID work

Manufacturer spec says 80MHz max.
80+80 is not same as 160
And in most of the world there is no space for 160MHz

1 Like

80+80+ VHT is supported on the stock firmware and according to search the mt76 driver did support that mode at one point
the Option exists enabling it just breaks the ap so I am not sure where you are going

I can not find manufacturer's reference for that.

  • do you see 160 in luci
  • in iw reg get

please provide:

ubus call system board
cat /etc/config/wireless # hide your passwords

mine is working fine with
OpenWrt SNAPSHOT r26843-4cc69a6542 / LuCI Master 24.158.03388~a6f8361
RT3200
only thing not working is miniDLNA
samba and usb hdd are fine
only dump AP tho

Fine as in 160MHz?

yes set to channel 52 so 36-64
works on 160Mhz on my WiFi 6E AX210HMW
also work in 80Mhz on my AC 7265

Seems country limitation.... Need info of that.

I'm in Australia so only 36-64 with DFS for me

OP may not be in such a lucky place.

1 Like

the mode in the config is "HE160"
I think it differs from 80+80 isn't that DBDC
spiting the x4 streams into 2x2

	option htmode 'HE160'
{
        "kernel": "6.6.36",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Linksys E8450 (UBI)",
        "board_name": "linksys,e8450-ubi",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r26883-75cd4ef48d",
                "target": "mediatek/mt7622",
                "description": "OpenWrt SNAPSHOT r26883-75cd4ef48d"
        }
}

config wifi-device 'radio0'
        option type 'mac80211'
        option phy 'wl0'
        option band '2g'
        option channel '1'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Redacted'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option phy 'wl1'
        option cell_density '0'
        option htmode 'HE80'
        option band '5g'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'REDACTED'
        option encryption 'psk-mixed'
        option key 'REDACTED'
        option ieee80211w '1'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
and again with the 160Mhz selected

config wifi-device 'radio0'
        option type 'mac80211'
        option phy 'wl0'
        option band '2g'
        option channel '1'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'REDACTED'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option phy 'wl1'
        option cell_density '0'
        option htmode 'HE160'
        option band '5g'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'REDACTED'
        option encryption 'psk-mixed'
        option key 'REDACTED'
        option ieee80211w '1'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

CC code is set to driver default I have tried US

Set country code to the real one and restart device.

as I said I tried setting the CC code to US which is the default anyway because its a US unit ... in the Us

Last time I checked US used different country code than in your picture.

don't play down @brada4 comment about restart device after setting country code
also having the radio enabled when pick options as then change if enabled or disabled
CC in the pic is AT ? and 160Mhz is an option you don't have set ?

I am not going to waste time posting a picture everytime I make a change
it doesn't work when set to US or Global or any other country code
I have tried thats NOT the problem, driver is likely borked or its some config issue on this unit but its 100% NOT Country Code

they removed support mistakenly with this commit

then added it back with this commit

currently the code seems to indicate support but its been worked on so manytimes its hard to follow whats been done

but the output of iwinfo doesn't lie

root@OpenWrt:~# iwinfo wl1 freq
  5.180 GHz (Band: 5 GHz, Channel 36) [NO_HT40-]
  5.200 GHz (Band: 5 GHz, Channel 40)
  5.220 GHz (Band: 5 GHz, Channel 44)
  5.240 GHz (Band: 5 GHz, Channel 48)
  5.260 GHz (Band: 5 GHz, Channel 52)
  5.280 GHz (Band: 5 GHz, Channel 56)
  5.300 GHz (Band: 5 GHz, Channel 60)
  5.320 GHz (Band: 5 GHz, Channel 64) [NO_HT40+]
  5.500 GHz (Band: 5 GHz, Channel 100) [NO_HT40-]
  5.520 GHz (Band: 5 GHz, Channel 104)
  5.540 GHz (Band: 5 GHz, Channel 108)
  5.560 GHz (Band: 5 GHz, Channel 112)
  5.580 GHz (Band: 5 GHz, Channel 116)
  5.600 GHz (Band: 5 GHz, Channel 120)
  5.620 GHz (Band: 5 GHz, Channel 124)
  5.640 GHz (Band: 5 GHz, Channel 128)
  5.660 GHz (Band: 5 GHz, Channel 132)
  5.680 GHz (Band: 5 GHz, Channel 136)
  5.700 GHz (Band: 5 GHz, Channel 140)
  5.720 GHz (Band: 5 GHz, Channel 144) [NO_HT40+]
  5.745 GHz (Band: 5 GHz, Channel 149) [NO_HT40-]
  5.765 GHz (Band: 5 GHz, Channel 153)
  5.785 GHz (Band: 5 GHz, Channel 157)
  5.805 GHz (Band: 5 GHz, Channel 161)
  5.825 GHz (Band: 5 GHz, Channel 165)
  5.845 GHz (Band: 5 GHz, Channel 169) [NO_IR, INDOOR_ONLY]
  5.865 GHz (Band: 5 GHz, Channel 173) [NO_IR, INDOOR_ONLY]
  5.885 GHz (Band: 5 GHz, Channel 177) [NO_HT40+, NO_IR, INDOOR_ONLY]

You need to power on device with correct country code. Live setting between EU-US-JP is very likely to accumulate radio restrictions.

What do you see via:
iw reg set US
iw list or iw phy
Note that this is kernel status, device may be choking after multiple domain changes.

You might need to try snapshot, or wait for next stable release.

this is the driver version mine is using and is working
kmod-mt76-core 6.6.35.2024.05.17~513c131c-r1