RT-N56U Restoring Original FW


Disclaimer here.. Am a complete newbie so please be gentle :slight_smile:

I have installed OpenWRT version 21.02 on a Asus RT-N56U router. Wanted to try wireless repeater feature of this FW on the router.

Have tried and spent countless hours following instructions on how to do this. Could not get it to work.
Short version is, i am giving up and would like to restore the stock FW again.

I have downloaded the asus FW (trx file) and the restoration utility. I have set the router back to recovery mode via reset button + power on trick and have the power led blinking slowly which should mean that it is in rescue mode. However, the utility said that the router is not in rescue mode.

Is there a way i can flash the stock asus trx fw file from Luci/openwrt?


this should be a fairly simple task, perhaps you should tell us how you had set it up, and what didn't work ?

That was quick :slight_smile: Will try this out and let you know :slight_smile:

Meanwhile, it would be wiser to keep OpenWrt, and as @frollic said, explain your issue with the repreater feature.

1 Like

Again... pleasantly surprised with the quick response :slight_smile:

I followed primarily these 2:


and lotsa combination between the 2.

The short version of it is that I am able to get to the point where the wifi connection is established (i.e. it's showing in the associated stations). Ideally, at this stage, the asus router should've internet connection and will be able to update the list of packages (was trying to download relayd) but it can't. Tried the ping diag tool but that too confirms that it cannot establish an internet connection.

I have tried this for a wouple of weeks, and found that establishing a mesh link is faster to configure. Meanwhile it depends of the other device abilities.

If there's a static IP on the Asus, and no WAN interface, you probably have to set the DNSes and GW manually, for it to be able to DL and install packages.

1 Like


Tried it again but this time, disabled all network interfaces before launching the recovery tool but still no joy. Recovery tool still saying that the wireless router is not in recovery mode (although the router has the blue power led slowly blinking).

Did you try to set static ip? Disable all interfaces in your pc. Only enable ethernet. And set ip address to

Gateway address:

Subnet mask:

Sorry I don't know that device and can't help you.
I just linked you to the page describing the method because it was easy to find.

1 Like

Yes @jayelpee try this, this a classic behavior in such case.

1 Like

Yep. Tried it. No joy.

This solved it! Thank you very much! Whew!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.