RT-N56U: Disabling the 5GHz radio automatically makes the 2.4GHz one unusable

Hello there!

As title says, this is how it works, this issue has existed since the first time I tried using OpenWRT (18.06), and still persists in the latest, 19.07.2 build.

When I am just setting up for the first time, I can't start using the 2.4 radio I've configured, unless I also configure and turn on the 5.0 radio, even if I'm not planning to use it. When I finally configure and turn on the 5.0 radio, the 2.4 becomes visible by devices, and they can connect to it (they can't connect to it even when trying to enter it manually). Curiously, at this point I can disable 5.0, and 2.4 keeps working; however, as soon as the router reboots, the issue returns, and I have to turn on the 5.0 radio once in order to start using the 2.4 one.

So, what could possibly be the issue? Is there any way to completely remove this dependency on the 5.0 module I'm not using at all?

Tried researching a bit more, but still have no idea whether this is a bug or something needing proper configuring...

Anyone? :frowning:

Still can't find an answer to this. If this is potentially a bug, how exactly should I report it if I'm not sure what specifically is going on?

@FurudoErika, welcome to the community!

https://bugs.openwrt.org/

Also,have you searched the threads for others having similar issues?

https://forum.openwrt.org/search

You can also move this/make a thread in the For Developers section.