Rt-n12 stuck in failsafe mode after reboot


I have an Asus RT-N12 A1 that I have been running Tomato on for years. I decided to go back to Openwrt today.

I have tried a few versions, 18.06.0, 17.01.0, 17.01.5 and 15.05.
18.06 appears too big for the firmware partition, so it's not going to work.

The rest all flash ok and I can get to LuCI and configure it without a problem....that is, until I reboot.

The moment I reboot, the router goes into failsafe mode and won't come out.

I've tried running firstboot. It completes on in 17.01.X and confirms that I want to wipe the config, but when I reboot I'm taken back to recovery mode again. 15.05 hangs when I run firstboot.

How can I get out of failsafe mode?

Thanks in advance.


Have you tried flashing the router while in recovery mode?

Hi Wayne,
Thanks for the reply. I can install the Asus firmware in recovery mode. I have then been installing Openwrt using the asus web gui.
If I try to directly install Openwrt in recovery mode then it never boots successfully and goes directly to failsafe mode.