RT-AX53U: 22.03.0 and master: WAN port as LAN port unstable?!

Have any of you tried using the WAN port as a LAN uplink port?

I experience constant changes between the link states "no link" and "link" (Network -> Interfaces -> Devices -> Bridge br-lan -> Bridge vlan filtering) when using the WAN port. For example, connecting via LAN port 1 fixes the problem immediately. So no big deal.

I'm currently using snapshot r20784, but the same behavior occurred on version 22.03.0 as well.

You don't need VLAN filtering. Just simply add the wan port to the lan bridge.

Post your /etc/config/network file and we can show you how this should be done (or validate your current one).

Also, unstable links can sometimes be due to a physical issue with the cable or port on one device or the other. Not to say that you haven't already done some tests to try to confirm everything is okay, but it can be worth double checking.

2 Likes

Hello Peter, thank you very much for your quick reply.

I did what you suggested and added the WAN port to the LAN bridge. The given reference of the menu should only show where the described behavior can be observed in the web ui. To clarify things at bit, please find attached a screenshot of the menu.

Switching the Ethernet cable from LAN1 to WAN causes the link connection to constantly change from no link to link.

Don't get me wrong, this isn't a real problem for me as the main function of the device is to act purely as a plain access point for WiFi devices. I was just curious if anyone might be having the same issue.

Please post the text config.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network

You will find the content of the file /etc/config/network below:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd1f:1cc6:ffc8::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'
	option igmp_snooping '1'
	option stp '1'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '1'
	option name 'br-lan.1'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '2'
	option name 'br-lan.2'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '3'
	option name 'br-lan.3'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '10'
	option name 'br-lan.10'

config device
	option type 'bridge'
	option name 'br1'
	option bridge_empty '1'
	option igmp_snooping '1'
	list ports 'br-lan.1'
	list ports 'bat0.1'
	option stp '1'

config device
	option type 'bridge'
	option name 'br2'
	option bridge_empty '1'
	option igmp_snooping '1'
	list ports 'br-lan.2'
	list ports 'bat0.2'
	option stp '1'

config device
	option type 'bridge'
	option name 'br3'
	option bridge_empty '1'
	option igmp_snooping '1'
	list ports 'br-lan.3'
	list ports 'bat0.3'
	option stp '1'

config device
	option type 'bridge'
	option name 'br10'
	option bridge_empty '1'
	option igmp_snooping '1'
	list ports 'br-lan.10'
	list ports 'bat0.10'
	option stp '1'

config interface 'LAN'
	option proto 'static'
	option ipaddr '192.168.5.110'
	option netmask '255.255.255.0'
	option gateway '192.168.5.1'
	option broadcast '192.168.5.255'
	list dns '192.168.5.1'
	option device 'br1'
	option ip6assign '64'
	list ip6class 'local'

config interface 'IOT'
	option proto 'static'
	option ipaddr '192.168.20.5'
	option netmask '255.255.255.0'
	option device 'br2'
	option defaultroute '0'

config interface 'GUEST'
	option proto 'static'
	option ipaddr '192.168.190.5'
	option netmask '255.255.255.0'
	option defaultroute '0'
	option device 'br3'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'lan1:t'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan1:t'
	list ports 'lan3'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan1:t'
	list ports 'wan:t'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option bridge_loop_avoidance '1'
	option gw_mode 'off'
	option hop_penalty '30'

config interface 'batmesh'
	option proto 'batadv_hardif'
	option master 'bat0'
	option metric '50'

config interface 'batwire'
	option proto 'batadv_hardif'
	option master 'bat0'
	option device 'br-lan'

These two options are likely responsible for your issue. Remove these lines and see if it helps.

Removed all entries of igmp_snooping and stp from /etc/config/network, reboot of the router. The result stays the same. Stable connection via LAN1, fragile connection via WAN.

Is it possible that the physical wan port had an issue?

It was working with AsusWRT, but maybe ironing pins for the serial console on the board damaged that port. If nobody else is experiencing this problem, it must be somehow hardware-related.

But no matter, I don't need this port that much.

So thank very much you for your time and effort in sorting my issue out.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.