RT-ACRH13 Firmware Brick

I installed Oct 2017's firmware last night, now I can't get into my router using the browser. Makes me think the web server is off. Also, the ip it has now is, should have came back with, weird behavior. Now I need to figure out how to talk to the router.

I see some of your guys are getting into the router and talking to the hardware.

Please give me some ideas. I ran a port scan and port 53, 515, 9888, and a couple of CISCO labels ports up in the 40000s (Can't remember the exact number, but can get it again).

Is there a way to use those CISCO ports to get into the router and configure it? Get it back to normal, and reflash it with an older firmware version?

Thanks for the help...

If you can SSH in to the router, run the following commands...



Otherwise, try getting into failsafe mode...


Failing all that, see the ASUS link on the failed firmware upgrade page...


@airbornedude i dont know if you got your router figured out. i bought a ACRH13 for $48 off of amazon during prime day and have been struggling to get it to work with the latest builds. i followed the instructions here http://lede-ac58u.zyxmon.org/HowToFlashRUS.html and downloaded firmwares from here http://lede-ac58u.zyxmon.org/firmware/ and got mine working. the problem seems to be that they used a different dfiffrent chipset altogether (IPQ806x) for their kernel but it works. problem is i cant upgrade it or do anything so i had to download recovery utility from ASUS (not on their site that i could find, someone had a copy elsewhere) and redo it a couple times. i have it working nicely now but buggy occasionally and cant figure out how to upgrade to the proper (IPQ40xx) OpenWRT snapshots.

anyway i have been working with this thing for days. let me know how far you have gotten. its a great little fast router if it can follow the LEDE/OpenWRT releases reliably.

Support for the ipq40xx SOC, including the ACRH13, was originally merged into the existing (similar) ipq806x target - this decision was later revised (as there are some incompatible settings that make using a common kernel ambitious) and support for these SOCs was split into a dedicated ipq40xx target. While you probably need to force (-F|--force) a sysupgrade, it should succeed.

thanks for the advice. so if i SCP the snapshot build for the ACRH13 (AC58U?) to my router and run the command in the CLI with the force flag you think it will work? is that what youre saying? sorry, i just want to be sure.

actually i did it today and it worked fine. it didnt need the -F force flag. i did forget that snapshots come without Luci WebUI so i lost a few hours there but thats my fault. anyway, my ACRH13/RT-AC58U is working fine with the latest snapshot

snapshot i used today is here.

thanks for the information!

Hi - I'm trying OpenWRT with a RT-ACRH13 after being disappoinred with the stock setup. I tried the "Easy Installation" firmware upgrade at http://lede-ac58u.zyxmon.org/HowToFlashENG.html using method 2 from the stock interface. that didn't go well - after waiting some 10 min i rebooted it and got no wifi lights.

i tried to ssh in but it never worked. Tehnically I'm connected via another wifi which goes to the non-wan ethernet port on the RT but it pings in failsafe mode at

I managed to get it into failsafe mode and over many tries managed once to send stock2lede.trx via tftp "put" but after waiting 20 min and then power cycling it only does the same including waiting hrs. I've tried repeatedly to "put" openwrt-r1834-0f04829-ipq806x-asus_rt-ac58u-squashfs-flash-factory.trx with no luck via tftp.

ssh never worked. I don't see any command in tftp that lets me explore the RT's directory structure - I've tried "get' various things mentioned but nothing comes.

My original wifi system (two stations to offer multiple wifi nets for purposes) partially failed amidst this pandemic and I got the RT yesterday… Many years ago I tried OpenWRT on another device long gone so I thought to try it again. (sigh)

Any help appreciated.