RPi4b with Alfa AWUS036ACM Slow WiFi

Hi all,

I have a Raspberry Pi 4b with OpenWrt 20.02 installed. I then installed an Alfa AWUS036ACM USB WiFi adapter. I want to use the Alfa for the external antenna to connect to a roof-mounted array, and the built-in WiFi on the RPi4b as my Access Point network.

I have everything setup and functional, but am getting terrible speeds between the RPi4b and main network over WiFi. It is usable, but barely.

iperf3 is maxing out at 1 Mbps.

I have a feeling it is a driver and/or configuration issue, but I am not sure, and hope someone can help.

During initial setup I ran this, but am not sure if I missed something, specifically for the Alfa dongle:

opkg update
opkg install kmod-mt76x2u kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils openvpn-openssl luci-app-openvpn

Here is the rest of my config:

# lsusb
Bus 002 Device 003: ID 0e8d:7612 MediaTek Inc. Wireless
Bus 001 Device 002: ID 2109:3431  USB2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.188 xhci-hcd xHCI Host Controller
Bus 002 Device 002: ID 0781:5583  USB  SanDisk 3.2Gen1
Bus 002 Device 001: ID 1d6b:0003 Linux 5.4.188 xhci-hcd xHCI Host Controller
# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option country 'CA'
        option hwmode '11g'
        option short_gi_40 '0'
        option htmode 'HT40'
        option channel '11'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb2/2-1/2-1:1.0'
        option cell_density '0'
        option country 'CA'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb2/2-2/2-2:1.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '1234:1234:1234::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option force_link '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.192.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'

And if you disconnect the roof mounted array?