RPI4B: can't install luci [solved]

I'm trying to install openwrt on a raspberry 4B using the snapshot image.

After modifying /etc/config/network I have internet access and can call opkg update from a ssh commandline.

I verified that luci is in the package list (opkg list | grep ^luci),

luci - git-20.021.70181-c99617a-1 - Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme

but calling opkg install luci ends with an error:

root@OpenWrt:/tmp/opkg-lists# opkg install luci
Installing luci (git-20.021.70181-c99617a-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a72/luci/luci_git-20.021.70181-c99617a-1_all.ipk
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a72/luci/luci_git-20.021.70181-c99617a-1_all.ipk, wget returned 8.
 * opkg_install_pkg: Failed to download luci. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package luci.

Indeed, I can't find the mentioned luci package file in the snapshot repository.

My question: is this just a temporary error or a (longer lasting) permanent error?

The output actually shows you what to do :slight_smile:

as I already wrote in my initial posting: I did an opkg update and after that succeeded I called opkg install luci.

Since we are talking about snapshot, I'd say: Try again and post the complete output of

opkg update
opkg install luci

Thanks for your hint. Tried it again and luci with all its dependents was installed successfully. :slightly_smiling_face:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.