RPi4B as a wired router with dumb AP for wireless access

Network novice here and trying to learn.

At present I have a FTTB connection with my ISP (TPG in Sydney, AU). I am currently using the ISP supplied modem router - TP-Link Archer 1600V .

I am trying to setup Openwrt on RPi 4B as a router and then connect Tablet/Phone/laptops in close proximity to the RPi through wireless as a first step. I understand the limitations of the RPi for this purpose on the long run, hence I am thinking of using USB to Ethernet adaptor (TP-Link UE300) to connect my old Netgear D6200 ( another modem+router) as a dumb wireless AccessPoint to connect home devices through this AP. The "to-be" setup would be

Internet >> TP-Link Archer 1600v >> Rpi 4B Wifi AP >> USB to Ethernet TP-Link UE300 >> Netgear D6200(in dumb AP mode)

I have installed OpenWRT on the RPi4B using community build by wulfy23 and LuCI WebUI is enabled.

Issues :
I am unable to connect to the Wifi and the LuCI interface says "wireless radio0 device not active". I am not sure if this due to a problem in my configuration or should I set up the WPA_Supplicant.conf for wireless to work? If so how should this be done?

Also I would appreciate any guidance or steps to achieve the "to-be" state as above, specifically on pointers on setting up Netgear D6200 as dumb AP, including examples of /etc/config/network, wireless configurations would be helpful.

Thank you for your time.

this is a basic AP-mode '11a' (ac) '/etc/config/wireless';

basic etc-config-wireless ac sample
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option country 'AU'
	option htmode 'VHT20'
	#option cell_density '0'
	#option noscan '1'
	#option channel '36'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key 'somerandomhardtoguesspassword'
	option ssid 'ap101'
	option encryption 'psk2+ccmp'

can you explain again why your diagram shows UE300 > RPIwifi ?

not really clear why you need it... is it intended to be a client to the core/isp archer router? is the RPI a long way from the core router? ( probably optimal to use the UE into the core router and use the onboardLAN to the dumbAP )

Thank you @anon50098793.

Wifi AP on RPi4B is for wifi access of devices (tablet//laptops) in close proximity to the RPi as a first step. If this is complex and hard to achieve along with the TP-Link UE300 wired connection for the dumb AP, then I can drop that idea.

the 'to-be' setup would be like below:
TP-Link Archer 1600v >> Rpi 4B (connected through ethrnet cable) >> USB to Ethernet TP-Link UE300 >> Netgear D6200(in dumb AP mode)

Hope this makes sense? Steps to achieve this setup would be much appreciated. Any pointers on setting up Netgear D6200 as dumb AP would be helpful.


running which firmware?

are you using ISP voip/fxs ports? ( have you read the relavent threads on whirlpool re: obtaining credentials etc. )...

your setup is pretty straight forward... the only catch is if you want to;

  • do simple 'double-nat' and treat the RPI as if it were the core router ( except for voip ports on the ISP device )
  • implement an alternative to double nat
  • something else... like a deliberate separate single subnet ( where many other clients still go directly out the ISP device not touching the RPI at all... I believe this was/is your initial intention ) ( in this case your probably don't need/want nat )

if option 3... then best to

  • change the RPI 'downstream/lan' interface address range if your ISP is using 192.168.x.x ... better to do this anyway... and simpler to do when connected directly from a laptop etc. to the 'lan' port...
  • see what part of the ISPROUTER(internal-lan) address space is unassigned... and
  • select a static ip to assign to your 'upstream' interface on the PI... ( out of the box it's simpler to use the UE for that as dhcp is running on the LAN port )
  • assign this static ip and your ISPROUTER-internal-IP as gateway same for DNS or use external dns servers
  • disable NAT on the 'upstream/wan' interface ( EDIT: on second thought... best to leave NAT on to begin with... as turning it off will complicate things with your primary router settings )
  • allow access to ports 80/443/22 on the 'internal/wan' interface so you can manage it from the ISPINTERNAL subnet

see how you go with those steps...

( NOTE: many forum users prefer to leave the 'upstream' interface on dhcp... and this is also possible... I prefer static as you know where it is... can set custom dns servers etc. etc. )

did you manage to resolve this? I'd be interested to do something similar and I have few questions before starting