Rpi4 secure travel router

hey i am trying to get a secure travel router on my raspberry pi 4 using this network chuck video for instructions. I was not able to see openwrt network broadcasting, finally after reading a bit on the forums i was able to get it to broadcast but then it wont let me connect to the ip adress I assigned as to enter the web gui. any help would be appreciated.

Network Config:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd48:8895:0abb::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.4'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option force_link '1'


config interface 'wan'
        option proto 'dhcp'
        option peerdns '0'
        option dns '1.1.1.1 8.8.8.8'

config interface 'vpnclient'
        option ifname 'tun0'
        option proto 'none'


**firewall config:**
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding 

**Wireless Config:**
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option legacy_rates '0'
        option country 'US'
        option hwmode '11g'
        option channel '7'
        option htmode 'HT20'
        option short_gi_40 '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'


**my original wireless config that i backedup:**

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

Your radio is currently shown as disabled. How are you connecting to the device now? Via ethernet?

As a note: AFAIK, the Pi's wifi cannot operate in AP and STA (client) mode simultaneously, which means that the Pi doesn't make a great travel router if the uplink is wifi. You may be better off with a purpose built travel router which has either 2 radios or the ability to run simultaneous AP+STA.

i am supposed to buy a little extra usb wifi antenna as he mentions in the video but plug it in to the rpi later on once i am able to get into the gui and set my home wifi network so i can download its drivers(antenna). currently im connecting the rpi to my laptop with Ethernet yes

So is your issue related only to wifi? After you enable wifi, what happens?

i see openwrt as a network on my iphone or other devices. but when i try to get into the webgui 192.168.1.4 that I set it just shows a dead no connection page.

sorry if its not clear noob learning here:P

This is a bad channel selection. Try 1, 6, or 11.

Try 40 MHz.

What is the output of:

ubus call system board

the config with vht80 is the original config that i wouldnt that even see open wrt wireless network broadcasting.

the one i currently have now that is working is HT20 right above it.
ill try 1 and 6 for the channels im pretty sure i tried 11 but ill try that too

where exactly do you mean 40 mhz on the ubus?

On the 5GHz radio, use 40MHz.

The ubus call dumps information about the device and OpenWrt version.

ubus output:

    "kernel": "5.10.96",
    "hostname": "OpenWrt",
    "system": "ARMv8 Processor rev 3",
    "model": "Raspberry Pi 4 Model B Rev 1.4",
    "board_name": "raspberrypi,4-model-b",
    "rootfs_type": "ext4",
    "release": {
            "distribution": "OpenWrt",
            "version": "SNAPSHOT",
            "revision": "r18784-c32835ccfe",
            "target": "bcm27xx/bcm2711",
            "description": "OpenWrt SNAPSHOT r18784-c32835ccfe"

Try using a current stable release (21.02.1 as of this moment):

oh lol am i using a nightly one? my bad ill close the post then and redo it all and see if thats the issue. thanks for your help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.