RPI4 - Luci Apps not working correctly in latest snapshot build

I have problem with RPI4 factory ext4 snapshot (OpenWrt SNAPSHOT r12980-0bea89a1d0). After instaling Luci, all basic services work correctly (network, dhcp etc). But whenever i try to install any luci-app outside of what was already in snapshot (tried acme, ddns and sqm) Luci GUI doesn't work correctly (i see some options but all inputs are grayed out, tabs are missing, buttons like Add etc. only reload page). All installed serviced are working correctly when configured from SSH, some of the configs even show up in GUI later (but still without possibility to change anything).
System logs don't show any errors, neither webbrowser console (tried also few webbrowsers, same effect).

Anyone has any idea what can be a reason for it?

Could be a bad build, snapshots are not steady versions, rather daily builds. You can try the next day for a new version and hope it is fixed.

Already tried few versions, but sadly same effect. Firewall itself is working fine, but without working Luci Apps it is quite annoying to set up some things because there is hardly any documentation for uci and accepted variables. Code reading in github saved me in few cases.
I hope it will start working correctly at some point, already switched to RPI as main router :wink:

https://openwrt.org/docs/guide-user/base-system/uci and read the configuration file you want.
Some more advanced things not handled by uci.
And of course you can edit the configuration files directly.

1 Like