RPi4 failure - catastrophic

Evening all. the RPi4 / switch setup worked great for the last 5 or so months. Then everyone in the house had to get online with ALL their devices and my AP (pos netgear) decided to take dive!
Also ended up resetting the rpi4 in the process...cept now I don't have any idea how to get back to where I was. :frowning: I'm missing ```
config interface 'lan1' in the configs....How do I put it back?


All I really need is a nudge in the proper direction. :laughing: Thanks

You didn't explain what you did. We don't know where you were and we don't know where you are now.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
iptables-save -c; ip6tables-save -c; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*
1 Like

best practice would be to;

  • reset to defaults or re-install ( if this hasn't happened already )
  • then restore your settings from your previously exported backup .tar.gz
1 Like

I'm about to reinstall... Firsboot erased all my settings, back at stock install. Can install Luci, but every time I try to add the wan interface named eth0.2 and rename lan with eth0 1, I end up with a second lan interface (eth0) and no connectivity.

Backups.... Must haves, will have from now on. :hot_face:


let me ask this before i call it a night.....
when using ifconfig , it lists;
br-lan (with correct IP address)
since I can't seem to get rid of eth0, I moved the WAN connection from eth0.2 to 0.1. I can now access the rip on my network.

Is there anything that says I HAVE to have an eth0.1 and eth0.2 or will it work how it is now setup?

No matter what I do to try and change eth0 to eth0.1 I loose connectivity... I must be missing something.

It all depends on whether or not you are using a managed switch ( 802.11q ) and how that is setup. ( and if you logged back into it to make sure that config is still valid )...

1 Like

There will always be eth0. Do not attach it to any of your networks though. Lan should be eth0.1 and wan eth0.2.

As @anon50098793 said the switch on the other end of the cable has to be configured and working properly.

Set up a local AP on the Pi internal WiFi so you can log in even without Ethernet.


It's starting to ring some very rusty bells. Will connect the managed switch tomorrow and see if that takes care of things.

Based on Rpi4, managed switch configuration woes

Seems like you might have went for a hybrid config with LAN untagged and WAN tagged... ( you didn't post your working config tho' ) :speaking_head:

Sorry for not posting. Everytime I change configs from defaults I lose the ability to connect with ssh. Would have to post screen shots from my phone.

Attempting to reconfigure the same configs I posted back in Jan. Updated the /etc/config/network (DHCP & firewall) the same as previously posted. I don't recall if I needed to connect the managed switch to regain connectivity after configuring in Jan or not. Should have created a backup.

If you are using VLANs (i.e. ethx.y) on the RPi, you will need a managed switch to work with the VLANs (from the RPi, it is likely a trunk, then you'd map the VLANs to the appropriate physical switch ports as access ports with just a single network untagged on those ports).

@mk24 suggested that you enable wifi -- as long as the wifi is enabled and connected to the LAN, you'll be able to connect and change the network config without getting locked out.

1 Like

morning all...Looks like this thing is back up and running. Still not sure why it down in the first place (trying to limit kids access to their xbox's)

Put the switch back in, set eth0.1 to static and connected to the network. eth0.1/br-lan getting the static ip, eth0.2 WAN pulling an ip, and able to log into luci and browse the internet.

I know I should put the kids on their own vlans, but I don't think you can do that with a single ssid can you? maybe another question for another day.

thanks for the help!

Sounds like you got it working... now TAKE THAT BACKUP ! :slight_smile:

Typically if you want to control kids access, you put a second SSID with a different password for them, and connect it to a different VLAN.


The three most important things in our business are two things: BACKUP!