Rpi4 < $(community_build)

yeah that's good info... adguard home likely wouldn't have been added to your sysupgrade.conf (so if you upgrade... it's gone) which likely broke a bit of your network depending on how you set it up...

I actually wrote 90% of the code to support adguardhome but decided against pushing it because of this very reason... it's just too complex to handle all the variations in user config and reliably upgrade (and it's a large package so 'including' it in the upgrade is also another complexity, it will fit tho')...

for adguardhome... you'd need (minimum) it's;

  • /etc/init.d/adguardhome
  • /srv/adguardhome (or wherever you've setup it's datadir)
  • ENABLEDSERVICES="adguardhome"

and even then... there are some firstboot complexities with startup/restart of dnsmasq AND possibly getting network time...

so not for the lighthearted... bare minimum you'd want a PC with a static ip so you can ssh into the router after an upgrade and restart/re-install things or copy a default /etc/config/dhcp back into place to get things back to a sane default...

1 Like

i have adquard home on a separate device now :slight_smile:
I think that could make my life a bit easier then haha but how do you set it up so that it actually does something.
With router os (microtic) i just don't use the advertised dns servers from my isp and then use my adquardhome dns server.

1 Like

I think I have mentioned this before, but when I reboot only my modem or restart wan interface in openwrt, PPPoE connection is successfully established and IP is assigned but I don't know why internet refuses to work and websites refuse to load

We can’t connect to the server at www.google.com.

I had to manually restart dnsmasq and https-dns-proxy services.

So today I decided to wait and internet started working again after 8-10 minutes

Protocol: PPPoE
Address: **************/32
Gateway: *************
DNS 1: 8.8.8.8
Connected: 0h 10m 56s

Is it normal?

1 Like

hi neil1, thanks for staying persistent on this...

this is a good/interesting symptom... not sure what to make of it yet...

the next think you'll have to do is break down the above statements into tangible -> service level testing ( ping gateway, nslookup on the various dns:ports, logread, netstat, ip route, traceroute ) to get us some better information as to where something is wrong...


next time you restart the modem and it's not working... instead of restarting wan... try this...

rm /root/.firstboot.99-kickit; /etc/custom/firstboot/99-kickit

it likely won't do anything special... but you never know...

1 Like

ping and nslookup works fine no issue.
Ping starts working again after few seconds of downtime when restarting WAN interface in openwrt.
but on the browser website doesn't load.

I either restart the modem or restart the wan interface. In both cases I get new IP but I have to either wait or manually restart dnsmasq and https-dns-proxy services.

1 Like

and

don't really work together
( note: with the top statement you usually have to add "from the router to X dns server address at X port" or "from the client to X dns server at X port" to be useful... )

as stated above... here are some commands you can use to compare when it's working and when it's not working...

################ do this when it's working
(lsof -i -nP | grep dns; uci show dhcp) > /tmp/working

################## do this when it's not working
(lsof -i -nP | grep dns; uci show dhcp) > /tmp/notworking

################## do this whenever
diff /tmp/working /tmp/notworking; logread | grep dns | tail -n 30
##################
uci show network | grep dns
1 Like

ok... may have found the/a bug... whats the name of your wan interface? you are comfortable with 'nano' right?

1 Like

here look
nslookup and ping inside openwrt diagnostic working now and pppoe is up for last
Connected: 1h 14m 11s
Now I am going to restart wan interface.

Server:		127.0.0.1
Address:	127.0.0.1#53

Non-authoritative answer:
Name:	openwrt.org
Address: 139.59.209.225
Name:	openwrt.org
Address: 2a03:b0c0:3:d0::1af1:1
PING openwrt.org (139.59.209.225): 56 data bytes
64 bytes from 139.59.209.225: seq=0 ttl=51 time=171.418 ms
64 bytes from 139.59.209.225: seq=1 ttl=51 time=169.984 ms
64 bytes from 139.59.209.225: seq=2 ttl=51 time=170.139 ms
64 bytes from 139.59.209.225: seq=3 ttl=51 time=170.239 ms
64 bytes from 139.59.209.225: seq=4 ttl=51 time=170.167 ms

--- openwrt.org ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 169.984/170.389/171.418 ms

After restart and wait of 17 mintues it is working and yes you are correct ping is only working when I ping 8.8.8.8 or 1.1.1.1 and nslookup is not working, sorry for misinformation.

ping: bad address 'openwrt.org'
;; connection timed out; no servers could be reached

ping 8.8.8.8

Pinging 8.8.8.8 with 32 bytes of data:
Reply from 8.8.8.8: bytes=32 time=141ms TTL=113
Reply from 8.8.8.8: bytes=32 time=141ms TTL=113
Reply from 8.8.8.8: bytes=32 time=141ms TTL=113
Reply from 8.8.8.8: bytes=32 time=141ms TTL=113

Ping statistics for 8.8.8.8:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 141ms, Maximum = 141ms, Average = 141ms
nslookup google.com
Server:  network.lan
Address:  192.168.1.2

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to network.lan timed-out
1 Like

copy and paste this in the terminal...



cat <<'TTT' > /etc/hotplug.d/iface/90-https-dns-proxy
if [ "$ACTION" = 'ifup' ]; then
	case "$INTERFACE" in
		*"wan"*)
			logger -t "https-dns-proxy" "Reloading https-dns-proxy due to $ACTION of $INTERFACE"
			/etc/init.d/https-dns-proxy reload
		;;
	esac
fi
TTT

(afaik) there is a pending procd based upstream fix for this already...

1 Like

paste this output here or message you?

1 Like

pm it to me and try the other fix

post this in ssh session with openwrt?

1 Like

i tried pasting it in ssh session but i am stuck here

[root@network /]# cat <<'TTT' > /etc/hotplug.d/iface/90-https-dns-proxy
> if [ "$ACTION" = 'ifup' ]; then
> case "$INTERFACE" in
>
.                                                           netmsg
20-smp-packet-steering                                      netns-run-cmd.sh
6rdcalc                                                     netperf
80211hplug-minisample.sh                                    netserver
:                                                           netstat
ModemManager                                                netstat-ports.sh
[                                                           nft
[[                                                          nft-qos-helper.sh
acme-manual.sh                                              nice
addgroup                                                    nlbw
addpart                                                     nlbwmon
adduser                                                     nmap
agetty                                                      nmbd
alias                                                       nmblookup
apk                                                         nonprintable.sh
apk_commands                                                noping
ar                                                          nproc
.
.
.
.
.
.
.
.
.
nano                                                        zerotier-idtool
nc                                                          zerotier-one
nc.sh                                                       zipgrep
netifd                                                      zipinfo
netifd-interfaceinfo.sh
> ;;
> esac
> fi
> ssh root@192.168.1.2
>
1 Like

press CTRL+c then try this instead... (when your internet is working)...


curl http://rpi4.wulfy23.info/misc/90-https-dns-proxy > /etc/hotplug.d/iface/90-https-dns-proxy

yes internet is working now.

1 Like
[root@network /]# curl http://rpi4.wulfy23.info/misc/90-https-dns-proxy > /etc/hotplug.d/iface/90-https-dns-proxy
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1517  100  1517    0     0   1260      0  0:00:01  0:00:01 --:--:--  4711
[root@network /]#
1 Like

php7 is gone
anyone using php7 be advised from

18325 php7 > php8

( move to 21.02.x if you rely on php7 stuff || have fun porting/migrating/re-assessing... no idea how portable stuff is but pretty sure there is always lotsa fun involved?)

1 Like

PHP officially supporter versions:
https://www.php.net/supported-versions.php

If it is your own application and it is not working on PHP 8.0 or 8.1 then tools like,
https://github.com/rectorphp/rector will point you in the right direction and help you out. If your PHP application worked without any notices/warnings in PHP 7.4 then it often works just fine in newer PHP versions.

2 Likes

dns-https-proxy not working

Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	openwrt.org
Address: 139.59.209.225
Name:	openwrt.org
Address: 2a03:b0c0:3:d0::1af1:1

1 Like

something to do with this?

cat /etc/hotplug.d/iface/90-https-dns-proxy
#!/bin/sh




#opkg list | grep '^https-dns-proxy ' | awk '{print $3}'
#2021-09-27-1
#2021-09-27-2 #nohotplug


#if grep -q '^VERSION="SNAPSHOT"' /etc/os-release; then exit 0; fi




#OLD service_triggers() { procd_add_config_trigger "config.change" "$packageName" "/etc/init.d/${packageName}" restart; }


############### NEW
#service_triggers() {
#       local iface
#       . /lib/functions/network.sh
#       network_find_wan iface
#       if [ -n "$iface" ]; then
#               procd_add_interface_trigger "interface.*" "$iface" "/etc/init.d/${packageName}" restart
#       fi
#       procd_add_config_trigger "config.change" "$packageName" "/etc/init.d/${packageName}" restart
#}



if grep -q 'network_find_wan' /etc/init.d/https-dns-proxy; then
        exit 0
fi













eval $(grep 'ENABLEDSERVICES=' /root/wrt.ini 2>/dev/null)

if echo ${ENABLEDSERVICES:-"fish"} | grep -q "https-dns-proxy"; then PROXYOK=1; fi
if [ -x /etc/init.d/https-dns-proxy ] && /etc/init.d/https-dns-proxy enabled; then
        PROXYOK=1
fi
[ -z "$PROXYOK" ] && exit 0










############################ at the bottom of /etc/hotplug.d/iface/90-https-dns-proxy


#if [ "$ACTION" = 'ifup' ] && [ "$INTERFACE" = 'wan' ]; then
#       logger -t "https-dns-proxy" "Reloading https-dns-proxy due to $ACTION of $INTERFACE"
#       /etc/init.d/https-dns-proxy reload
#fi



if [ "$ACTION" = 'ifup' ]; then
        case "$INTERFACE" in
                *"wan"*)
                        logger -t "https-dns-proxy" "Reloading https-dns-proxy due to $ACTION of $INTERFACE"
                        /etc/init.d/https-dns-proxy reload
                ;;
        esac
fi