Rpi4 < $(community_build)

Hi. Any idea why clicking "save" on SQM gives me this error?

An error occurred while saving the form:

Option "Queuing disciplines useable on this system. After installing a new qdisc, you need to restart the router to see updates!" contains an invalid input value.

Is it on by default?

Perhaps a larger issue with the wan IP changing frequently on 21.02 ...

1 Like

as stated in the usage notes: enable what you use

I get that error above when I try to save the changes on sqm so that I can enable it. Any idea why that happens?

likely because the service needs to be enabled first...

( not uci/config enabled... init.d/service enabled they are two different things steps are provided in the top two posts as linked )

1 Like

It somehow worked when I clicked above the sqm area, it activated and then I was able to change things. I can enable SQM now. Thanks :slight_smile:

1 Like

It works properly. Just choose the settings inside after reading each config and choose the one which suits your needs. Then you will see the difference.

1 Like

Folks. I am "way behind" on updating - still running OpenWrt SNAPSHOT r16595-f4473baf6e.

I'd be interested in updating but don't want to totally hose my system (which has been very stable).

Any major breaking bugs I should be aware of? Can I just upload and flash the most recent stable version, which appears to be rpi4.64-snapshot-27006-3.5.139-21-r18086-ext4-sys.img?

Thanks for any thoughts or advice...


1 Like

meh... 3.5.139-21-r18086 is not super outstanding in the larger scheme of things...

there are quite a few ssl bugfixes... and one should always assess security risk on their own... but;

  • if you are not using browsers on your router etc
  • you don't have a nested lan or ottherwise more exposure to dns/mitm
  • you don't really need something from the newer builds

then i'd asses the risks as medium at best... and if I were you... i'd be fairly comfortable holding off for another month or so OR update to 21.02.1 which is a tad more reliable and still has most fixes... ( better yet wait for 21.02.2 )...


Luckily my actual threat surface is pretty narrow...

Is the 21.02.1 a version of your build, or are you refering to the the official openwrt build for rpi4? After spending a bunch of time installing and playing with your build (which as been great) last winter, I realize I am now acting like someone who should stick with a just works official build and upgrade infrequently...

If I decide to just move to the official openwrt build will most of my config come across OK?

Thanks for your quick response!


1 Like

unless I say 'official' i'm referring to my variant but purely for ease of migration... and either will work

if you use the backup from the updatecheck bar... then install official from factory... then restore settings... yes should mostly be ok...

i dunno... as i've got 'release' variants... you can just stick to those... and some of the builds migration tweaks may actually make things easier for you...

if you don't have masses of data parked somewhere unknown... (same for fancy service config files etc.)... then upgrade is usually very smooth... and myself and several other users here upgrade alot... with little to no issues...

besides... there is only one way to find out! ( official or not )...

Very true...I have a few minutes this morning and perhaps I'll roll the dice....

This is the 21.02 image you'd recommend?


Thanks again for your input....


1 Like

yeah that's the image... if you install from command line make sure to use -R...

from luci upload you'd want AUTORESTOREAPPLY=1 in /root/wrt.ini

which on that era build I think is editable in banip > advanced > last tab ( if not it's in system > startup > local startup )...

that setting just tries to re-install your last packages... ( so not the end of the world if you don't use it... i've got a command to do it afterwards also )

I'll just use luci, AUTORESTOREAPPLY=1 is set. I'm getting an upgrade: validate-fail and image-check failed, but I can hit the force upgrade.

What I love about doing router upgrades is that if you screw them up, you're locked away from the internet...

Thank again...here goes...

1 Like

yeah force is fine... that's just the old new-unknown certificate...
(but all users are advised to check in here if you see this message just to be safe)

after the upgrade... change;

so you only get update notices / flash from the 'release'(21.02) branch...

Worked great. I am back up, and the home network seems happy and intact. Only (completely unimportant) change is that the argon color scheme went from a nice dark scheme to a light one. Looks like I just need fix the theme...

I changed to UPGRADEsFLAVOUR="release" in /root/wrt.ini

Thanks for all your help!

1 Like

good news...

(switched to light for a change) if you want dark, you'll need putty/ssh(there is also the [tty] link in the updatecheck bar but not sure if it works for everyone) and do a;

touch /etc/dark

(or install darkreader browser plugin)

also... there will be a 21.02.2 in a few weeks... that will have some security fixes so make sure to update ( but there will be a [flash] button you just click once in the updatecheck bar )...

Hi Wulfy23.

This is probably asked quite a couple of times.
But i would really like to get in to openwrt on my pi 4.
I have tried a build of the github page and this worked till i hit the update button.
then the pi rebooted and nothing the pi didn't start.
My question is what is a good build to start on i am not a edge user and only do a update when its necessary.
I have a microtic router on the wall for a situation as described as above :slight_smile:

1 Like


not sure;

  • what build exactly you installed?
  • what update button you clicked?1
  • whether the restart issue was something trivial like incorrect network settings, browser problem or something like that...

it's pretty rare that the build [flash] update will cause a non-boot... (or the appearance of it with correct settings)... (less than 1%)... you are aware that the flash process can take up to 5mins?

  1. if you are able to provide more details... i'm more than happy to repeat your step to try to identify what is exactly going on...

but to answer you question... the most reliable current build is the 21.02.1-1.0.7-3...

then search the thread for UPGRADEsFLAVOUR ... at the moment 'release'(21.02.1) is a bit more solid than 'stable'(master - the best we could get it without being too old)... and less frequent updates...

neither has been updated in around a month... so if you did an update... probably was from 21.02.1 if you installed it to 'stable' the default flavour as you hadn't changed it... ( i may look at auto setting this to 'release' if someone firstboots with 21.02.1 , thanks for the feedback )

i have performed this update(sysupgrade) several times without issues ( but that does not exclude something specific I don't know about )

Okay thanks for the feedback reading a bit more into upgrading.
And maybe there also things related to me in regard of upgrading.
I installed a few things here and there like adquard home etc.
And i saw things like:

  • add any extra services you enable to ENABLEDSERVICES="service1 service2" in /root/wrt.ini (system>startup>local startup)
  • add any special data files and folders to /etc/sysupgrade.conf
  • use the command line: 'rpi-sysup-online.sh -R current' or uploading into LUCI you also have to enable AUTORESTOREAPPLY=1 in wrt.ini ( if you do not wish to re-install packages... the remove the '-R' or disable AUTORESTOREAPPLY=1 )
  • note: the 'one-click-flash' within luci is equivalent to 'rpi-sysup-online.sh -R current'

that where things i didn't do :frowning: .
I think i have to do a couple of things before upgrading to a later version.

1 Like