Rpi4 < $(community_build)

this is mine

[root@dca632 /usbstick 50°]# cat /etc/config/luci_statistics 

config statistics 'collectd'
	option BaseDir '/var/run/collectd'
	option Include '/etc/collectd/conf.d'
	option PIDFile '/var/run/collectd.pid'
	option PluginDir '/usr/lib/collectd'
	option TypesDB '/usr/share/collectd/types.db'
	option Interval '30'
	option ReadThreads '2'

config statistics 'rrdtool'
	option default_timespan '1hour'
	option image_width '600'
	option image_path '/tmp/rrdimg'

config statistics 'collectd_rrdtool'
	option enable '1'
	option DataDir '/tmp/rrd'
	option RRARows '144'
	option RRASingle '1'
	option RRATimespans '1hour 1day 1week 1month 1year'

config statistics 'collectd_csv'
	option enable '0'
	option StoreRates '0'
	option DataDir '/tmp'

config statistics 'collectd_email'
	option enable '0'
	option SocketFile '/var/run/collectd/email.sock'
	option SocketGroup 'nogroup'

config statistics 'collectd_logfile'
	option enable '0'
	option LogLevel 'notice'
	option File '/var/log/collectd.log'
	option Timestamp '1'

config statistics 'collectd_network'

config statistics 'collectd_syslog'
	option enable '0'
	option LogLevel 'warning'
	option NotifyLevel 'WARNING'

config statistics 'collectd_unixsock'
	option enable '0'
	option SocketFile '/var/run/collectd/query.sock'
	option SocketGroup 'nogroup'

config statistics 'collectd_apcups'
	option enable '0'
	option Host 'localhost'
	option Port '3551'

config statistics 'collectd_chrony'
	option enable '0'
	option Host '127.0.0.1'
	option Port '323'
	option Timeout '2'

config statistics 'collectd_contextswitch'
	option enable '0'

config statistics 'collectd_cpu'
	option enable '1'
	option ReportByCpu '1'
	option ReportByState '1'
	option ShowIdle '0'
	option ValuesPercentage '1'

config statistics 'collectd_cpufreq'
	option enable '0'

config statistics 'collectd_curl'
	option enable '0'

config statistics 'collectd_df'
	option enable '0'
	option Devices '/dev/mtdblock/4'
	option MountPoints '/overlay'
	option FSTypes 'tmpfs'
	option IgnoreSelected '0'
	option ValuesPercentage '0'

config statistics 'collectd_dhcpleases'
	option enable '0'
	option Path '/tmp/dhcp.leases'

config statistics 'collectd_exec'
	option enable '1'

config statistics 'collectd_interface'
	option enable '1'
	option Interfaces 'br-lan'
	option IgnoreSelected '0'

config statistics 'collectd_ipstatistics'
	option enable '0'

config statistics 'collectd_iptables'
	option enable '0'

config collectd_iptables_match
	option table 'nat'
	option chain 'luci_fw_postrouting'
	option target 'MASQUERADE'
	option source '192.168.1.0/24'
	option outputif 'br-ff'
	option name 'LAN-Clients traffic'

config collectd_iptables_match
	option chain 'luci_fw_postrouting'
	option table 'nat'
	option target 'MASQUERADE'
	option source '10.61.230.0/24'
	option outputif 'br-ff'
	option name 'WLAN-Clients traffic'

config statistics 'collectd_iwinfo'
	option enable '1'

config statistics 'collectd_load'
	option enable '1'

config statistics 'collectd_memory'
	option enable '1'
	option ValuesAbsolute '1'
	option ValuesPercentage '0'

config statistics 'collectd_netlink'
	option enable '0'
	option IgnoreSelected '0'
	option VerboseInterfaces 'br-lan'
	option QDiscs 'br-lan'

config statistics 'collectd_nut'
	option enable '0'
	list UPS 'myupsname'

config statistics 'collectd_olsrd'
	option enable '0'
	option Port '2006'
	option Host '127.0.0.1'

config statistics 'collectd_openvpn'
	option enable '0'

config statistics 'collectd_ping'
	option TTL '127'
	#option Interval '650'
	option Interval '250'
	#option AddressFamily 'ipv6'
	option AddressFamily 'ipv4'
	#option Hosts '202.142.142.142 8.8.8.8'
	#option Hosts '2404:6800:4006:814::200e'
	option Hosts 'google.com'
	option enable '1'

config statistics 'collectd_processes'
	option Processes 'uhttpd dnsmasq dropbear'
	option enable '1'

config statistics 'collectd_sensors'
	option enable '0'

config statistics 'collectd_snmp6'
	option enable '0'
	option Interfaces 'br-lan'
	option IgnoreSelected '0'

config statistics 'collectd_splash_leases'
	option enable '0'

config statistics 'collectd_tcpconns'
	option enable '0'
	option ListeningPorts '0'
	option LocalPorts '22 80'

config statistics 'collectd_thermal'
	option IgnoreSelected '0'
	option enable '1'

config statistics 'collectd_uptime'
	option enable '0'

config collectd_exec_input 'collectd_exec_input'
	option cmduser 'nobody'
	option cmdgroup 'nogroup'
	option cmdline '/usr/libexec/collectd/sqm_collectd.sh eth1'

config statistics 'collectd_dns'
	option enable '1'
	option Interfaces 'br-lan'
	option IgnoreSources '127.0.0.1'

config statistics 'collectd_irq'
	option enable '1'
	option IgnoreSelected '1'

config statistics 'collectd_entropy'
	option enable '1'

config statistics 'collectd_conntrack'
	option enable '1'

config statistics 'collectd_disk'
	option enable '1'
	list Disks 'mmcblk0p1'
	list Disks 'mmcblk0p2'
	list Disks 'sda1'

statistics is pretty binary for many modules... if they are not installed or the config is incorrect the service will fail to start... it will usually tell you in the log... but you left those lines out... (edit: my bad.. with a 'uci parse error' you probably wouldn't get far enough for a 'module load' error)

prime cantidates are: disk iptables irq... just keep restarting... checking the log.... and removing sections until you find the culprit...
(quite possibly I have a setup bug - i.e. if you've unplugged a disk recently that could do it...)

i do my best to give a default 'full featured' config... but anything specific is really up to the end user to tweak... it's way too difficult to predict or accomodate for all setups... that said... if i've got a bug... i'd rather remove a section than have it work half the time...

totally understable. i do not expect you to solve my misconfigurations. my knowledge to track down such things is...narrow. i am very grateful for your work. for completeness-reasons here is mine.
please feel free to ignore. i really dont want to waste your time.

config statistics 'collectd'
        option BaseDir '/var/run/collectd'
        option Include '/etc/collectd/conf.d'
        option PIDFile '/var/run/collectd.pid'
        option PluginDir '/usr/lib/collectd'
        option TypesDB '/usr/share/collectd/types.db'
        option Interval '30'
        option ReadThreads '2'

config statistics 'rrdtool'
        option default_timespan '1hour'
        option image_width '600'
        option image_path '/tmp/rrdimg'

config statistics 'collectd_rrdtool'
        option enable '1'
        option DataDir '/tmp/rrd'
        option RRARows '144'
        option RRASingle '1'
        option RRATimespans '1hour 1day 1week 1month 1year'

config statistics 'collectd_csv'
        option enable '0'
        option StoreRates '0'
        option DataDir '/tmp'

config statistics 'collectd_email'
        option enable '0'
        option SocketFile '/var/run/collectd/email.sock'
        option SocketGroup 'nogroup'

config statistics 'collectd_logfile'
        option enable '0'
        option LogLevel 'notice'
        option File '/var/log/collectd.log'
        option Timestamp '1'

config statistics 'collectd_network'

config statistics 'collectd_syslog'
        option enable '0'
        option LogLevel 'warning'
        option NotifyLevel 'WARNING'

config statistics 'collectd_unixsock'
        option enable '0'
        option SocketFile '/var/run/collectd/query.sock'
        option SocketGroup 'nogroup'

config statistics 'collectd_apcups'
        option enable '0'
        option Host 'localhost'
        option Port '3551'

config statistics 'collectd_conntrack'
        option enable '1'

config statistics 'collectd_contextswitch'
        option enable '0'

config statistics 'collectd_cpu'
        option enable '1'
        option ReportByCpu '1'
        option ReportByState '1'
        option ShowIdle '0'
        option ValuesPercentage '1'

config statistics 'collectd_cpufreq'
        option enable '0'

config statistics 'collectd_curl'
        option enable '0'

config statistics 'collectd_df'
        option enable '0'
        option Devices '/dev/mtdblock/4'
        option MountPoints '/jffs'
        option FSTypes 'tmpfs'
        option IgnoreSelected '0'
        option ValuesPercentage '0'

config statistics 'collectd_dns'
        option Interfaces 'br-lan'
        option IgnoreSources '127.0.0.1'
        option enable '1'

config statistics 'collectd_entropy'
        option enable '1'

config statistics 'collectd_exec'
        option enable '1'

config statistics 'collectd_interface'
        option enable '1'
        option Interfaces 'br-lan'
        option IgnoreSelected '0'

config statistics 'collectd_iptables'
        option enable '0'

config collectd_iptables_match
        option table 'nat'
        option chain 'luci_fw_postrouting'
        option target 'MASQUERADE'
        option source '192.168.1.0/24'
        option outputif 'br-ff'
        option name 'LAN-Clients traffic'

config collectd_iptables_match
        option chain 'luci_fw_postrouting'
        option table 'nat'
        option target 'MASQUERADE'
        option source '10.61.230.0/24'
        option outputif 'br-ff'
        option name 'WLAN-Clients traffic'

config statistics 'collectd_iwinfo'

config statistics 'collectd_load'
        option enable '1'

config statistics 'collectd_memory'
        option enable '1'
        option ValuesAbsolute '1'
        option ValuesPercentage '0'

config statistics 'collectd_netlink'
        option enable '0'
        option IgnoreSelected '0'
        option VerboseInterfaces 'br-lan'
        option QDiscs 'br-lan'

config statistics 'collectd_nut'
        option enable '0'
        list UPS 'myupsname'

config statistics 'collectd_olsrd'
        option enable '0'
        option Port '2006'
        option Host '127.0.0.1'

config statistics 'collectd_ping'
        option TTL '127'
        option Interval '2300'
        option Hosts '10.11.12.1 8.8.8.8'
        option AddressFamily 'ipv4'
        option enable '1'

config statistics 'collectd_processes'
        option Processes 'uhttpd dnsmasq dropbear'
        option enable '1'

config statistics 'collectd_sensors'
        option enable '0'

config statistics 'collectd_splash_leases'
        option enable '0'

config statistics 'collectd_tcpconns'
        option enable '0'
        option ListeningPorts '0'
        option LocalPorts '22 80'

config statistics 'collectd_thermal'
        option enable '1'

config statistics 'collectd_uptime'
        option enable '0'

config statistics 'collectd_openvpn'

config collectd_exec_input 'collectd_exec_input'
        option cmduser 'nobody'
        option cmdgroup 'nogroup'
        option cmdline '/usr/libexec/collectd/sqm_collectd.sh eth1'

config statistics 'collectd_irq'
        option enable '1'
        option IgnoreSelected '1'

config statistics 'collectd_chrony'

config statistics 'collectd_dhcpleases'

config statistics 'collectd_ipstatistics'

config statistics 'collectd_snmp6'

config statistics 'collectd_disk'
        option enable '1'
        list Disks 'mmcblk0p1'
        list Disks 'mmcblk0p2'

config statistics 'collectd_irq'
        option enable '1'
        option IgnoreSelected '1'

config statistics 'collectd_disk'
        option enable '1'
        list Disks 'mmcblk0p1'
        list Disks 'mmcblk0p2'

/etc/config/luci_statistics: uci: Parse error (invalid command) at line 190, byte 0
/etc/config/luci_statistics

/etc/config/luci_statistics: line 2: config: command not found
/etc/config/luci_statistics: line 3: option: command not found
...
/etc/config/luci_statistics: line 188: config: command not found
/etc/config/luci_statistics: line 190: config: command not found
/etc/config/luci_statistics: line 191: option: command not found
/etc/config/luci_statistics: line 192: list: command not found
/etc/config/luci_statistics: line 193: list: command not found
/etc/config/luci_statistics: line 195: config: command not found
/etc/config/luci_statistics: line 196: option: command not found
/etc/config/luci_statistics: line 197: option: command not found
/etc/config/luci_statistics: line 199: config: command not found
/etc/config/luci_statistics: line 200: option: command not found
/etc/config/luci_statistics: line 201: list: command not found
/etc/config/luci_statistics: line 202: list: command not found
Sat Jul  3 02:50:37 2021 daemon.err collectd[22313]: Configuration file /tmp/collectd.conf is empty.
Sat Jul  3 02:50:37 2021 daemon.err collectd[22313]: Error: Parsing the config file failed!
Sat Jul  3 02:50:37 2021 daemon.info procd: Instance collectd::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

3am here. my eyes.

1 Like

line 190 is near the bottom ( good think phpeditor shows lline numbers ) and is near the first 'disk' section which there should not be two of?
(do does look like a bug with 'disk' being added)... remove that disk section and see how it goes...

lines-to-remove
config statistics 'collectd_disk'
        option enable '1'
        list Disks 'mmcblk0p1'
        list Disks 'mmcblk0p2'

another option is something like;

opkg update
opkg install --force-reinstall --force-maintainer luci-app-statistics

it worked. you fixed everything. i am a happy girl now.
thanks again. back to work.

1 Like

I just wanted to report, that I have upgraded to 3.2 once again and can confirm, that the mac changes do apply properly, if a valid mac is being used. As I had used multiple different mac generators would say, that it made sense to add a check for invalid mac before setting it, so others cannot run into this issue again.

1 Like

thanks for checking back in...

yeah... seems like there is no validation of least significant (mcast) via luci...

you can create an issue

pretty simple thing to resolve... ( even tho it's a kernel / user issue... agree that UI validation / better feedback is beneficial )

1 Like

Not sure if this is the right place to ask but I want to try. - I am just installing dockerd, docker-compose, docker and luci-app-dockerman. On installing luci-app-dockerman I get this one:

Collected errors:
 * check_data_file_clashes: Package libwebsockets-full wants to install file /usr/lib/libwebsockets.so
	But that file is already provided by package  * libwebsockets-openssl
 * check_data_file_clashes: Package libwebsockets-full wants to install file /usr/lib/libwebsockets.so.17
	But that file is already provided by package  * libwebsockets-openssl
 * opkg_install_cmd: Cannot install package luci-app-dockerman.

Is it safe to have luci-app-dockermans installation overwrite libwebsockes.so?

1 Like

'probably'... there is another smaller depandancy quirk with docker (may be a note in packages.txt on github)

the two packages that 'overlap' with websockets are

  • mosquitto
  • ttyd

so if those aren't important to you (may continue to work... just untested) should be fine...

may need
--force-depends and/or --force-overwrite or something like that tho' (or just delete the files)


related packages issue from march 2020 https://github.com/openwrt/packages/issues/11632
1 Like

I found mosquitto but what is 'ttyd'?

Am I understanding it correctly to opkg install luci-app-dockerman --force-depends --force-overwrite?

EDIT: Found ttyd, terminal integration for luci
EDIT2: opkg install luci-app-dockerman --force-depends --force-overwrite worked

1 Like

try it and see...

ttyd ignore... i'm adding that manually ( but it does create websockets libs )

1 Like

I have been looking for a configuration option in lucy, that allows to set the WIFI to 2.4ghz (some older devices dont support 5ghz) or optimally to run it in dual band, can you eventually hint me where to look for it?

never done this myself... afaik... does not support dual-band@ap-mode

(for only 2.4 there is a tip somewhere on this thread or look on the top post for 'index' something thread link)

1 Like

Im have been searching for the past 15 minutes, I cant seem to find it. I went through all links trying to find 'index' in them but I didnt find it - searched the thread for 'ac mode' '2.4 ghz' 'ac mode' and so on, ill keep searching.

1 Like

Ah darn, I should have seen that one, thank you for helping out.

EDIT: Alright I have now changed operating frequency to Legacy with 2.4ghz but as it seems (if I haven't forgotten something) the change is not reflected in config-wifi-device:

cat /etc config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option band '5g'
        option cell_density '0'
        option country 'DE'
        option hwmode '11g'
        option channel 'auto'
        option legacy_rates '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option key 'very_secret_pw'
        option ssid 'SSID'
        option wmm '0'
        option wpa_disable_eapol_key_retries '1'

option band is still set to 5g. I guess I just change it to 24g manually and reboot?

EDIT2: I have changed the band to '24g' manually and it now has changed the band properly to 2.4ghz.

1 Like

@anon50098793
is this build related?

1 Like

lol... 99.9% chance yes...

thanks for the info... will check it out...

(is that 3.2.61-20 by any chance?)

1 Like

G'Day all, newbie here. Got a rpi4b on the way and want to give Openwrt a crack to use as my router, and relegate my ERX-SFP to poe switch status. Got a UE300 ethernet dongle to accompany. Just wanted to confirm if I should use 3.1 vs 3.2 branch? Is there a stability difference? Have a fairly basic config, just a separate VLAN for IoT devices, a few extra firewall rules as applicable and use Wireguard for remote access/managment. Wireless won't be used, access points in house are powered via switch.

Any tips appreciated. Looking forward to giving it all a crack.

1 Like

That's not a valid band option, use one of these instead:

 2g, 5g, 60g, 6g

See for reference: https://git.openwrt.org/?p=openwrt/openwrt.git;a=blob;f=package/kernel/mac80211/files/lib/wifi/mac80211.sh;h=0763da8fd813e880f848bcd389d29a2387eeedde;hb=8504212f65865449dd6b9ed9daa0ba9781f8f287#l123)

3 Likes