Rpi4 < $(community_build)

for now... it's probably not 'technically-correct' but remove all your 'config device' sections and just put this;

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

edit: i see this is present higher... remove the LOWER device sections...

another option if you really dont want to re-install 3.1... is to create entirely in the old format... and NOT use luci until the next upgrade...;

old-format
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda9:424a:1c04::/48'
	#option packet_steering '1'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'router'
	option delegate '0'
	option ipaddr '10.2.3.1'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option hostname 'router'
	option macaddr '00:11:32:96:42:65'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix '56'

your original config did not look all that bad... but like I said... there have been several changes to the master code... normally i'd just say give me a bit and i'll test your config... but on a build that does not have all the current fixes/logic... it's likely asking for trouble (hence the 3 given workarounds)

edit: one other relevant point here is some mac addresses can be invalid and rejected by netifd

you are the first person to report an actual issue with it... ( but... I did not test factory... so either way... seeing the config that was generated has been really helpful :scream: )

but i'm aware of several other things (vpn-pbr, migration of some options, etc. etc. that have since seen patches)

(network section only... you can use the rest of it!)

while what is really going on here is still unknown... I changed the name of the 3.2 folder on github to +_experimental to make it clearer... the reason it remains/ed up is to allow build users to migrate/get familiar with the new config format... and allow some broader testing with said format (and migrate between the two.. but only possible if you started on 3.1 or lower)... so once again... your feedback was very usefull... cheers...

I ran some tests with the 4 characters you supplied from the macs you assigned...

they were invalid/rejected...

(so likely not the build after all)

edit: re your EDIT5+6:

great news...

just assigned the mac and did 'ifdown NAME:aka:wan' then 'ifup NAME:aka:wan'

afaik no wireless device is/should be defined in 'config/network' ... it is done in 'config/wireless' search the forum for examples...

after the update my pi4 keeps rebooting :frowning: now going to flash stable version

1 Like

error trying to login wia web

/usr/lib/lua/luci/ccache.lua:70: error loading module 'luci.controller.adblock' from file '/usr/lib/lua/luci/controller/adblock.lua':
	/usr/lib/lua/luci/controller/adblock.lua:2: unexpected symbol near '#'
stack traceback:
	[C]: in function 'loader'
	/usr/lib/lua/luci/ccache.lua:70: in function </usr/lib/lua/luci/ccache.lua:61>
	[C]: in function 'require'
	/usr/lib/lua/luci/dispatcher.lua:1103: in function 'createindex'
	/usr/lib/lua/luci/dispatcher.lua:1203: in function 'createtree'
	/usr/lib/lua/luci/dispatcher.lua:693: in function 'menu_json'
	/usr/lib/lua/luci/dispatcher.lua:794: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:479: in function </usr/lib/lua/luci/dispatcher.lua:478>

errors in ssh
it just kept rebooting

ThuJul117:51:472021 23.764530] 965-lucicommandsadd.sh> command-leave: rpisupport@/bin/rpi-support.sh [ok]
ThuJul117:51:472021 23.795318] 965-lucicommandsadd.sh> command-leave: restorepackages@/bin/restorepackages.sh
ThuJul117:51:472021 23.853282] 965-lucistatisticssqmfixup.sh> no wan interface -> using eth1 and not enabling
update-unavailable
root@network /55# opkg update

one more try after reboot

ThuJul118:07:322021 No NSS support for mDNS detected, consider installing nss-mdns!
ThuJul118:07:322021 Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
ThuJul118:07:322021 Failed to contact D-Bus daemon.


1 Like

can confirm. same happens for me. permanent reboot. build from 3006 was working.
unfortunately 3.2.61-20_r17073 actually is the only remaining one that is still up under builds. atm no way to downgrade if no local backup available.

temporarily switched to @damianperera build from 2906. it works.

furthermore 'statistics' (where you could see graphs for cpu, temps, etc.) is gone from luci-menu...couldn't figure out why with my very limited skills.

1 Like

thanks for the heads up, apologies... 3.1.57-50_r16707 restored...

i ran through several tests... and was unable to identify the exact issue

'3.2.61-30' is a revised r17073
(reverted (most) custom changes back to 3.1.50)

1 Like

thanks for your quick support, as always.
3.2.61-30 works for me.
most likely it was an issue with a specific config,
that reasons at least to me remains unknown.
i am just glad to have it working again.

so thanks again.

2 very minor things i noticed and could not identify the cause. the missing statistics menu entry in luci, which worked normal, to speak it was just there/available in the builds before 1st july. the other thing is that ntp-settings under system-system-menu are not backed up when sys-upgrade is done. it gets defaulted everytime. maybe it is working this way as expected. i just happen to notice and wondered as i like to set my own ntp's.

br

1 Like
/etc/init.d/luci_statistics restart; sleep 12; logread | tail -n30

with the ntp... yes... that was a recent addition that needs fine tuning... if you change your settings and post;

uci show system | grep ntp

i'll be able to better detect/use it to compare and can improve the logic most likely...

thanks for the info...

(edit: maybe try changing NTP_FAST="server1 server2" looks like i'm grabbing from this variable in /root/wrt.ini or system>startup>local startup note:this is only written each install tho' so you'd have to change it manually for now... i'll try and change it so it only applies over a default setup also)

(commenting it out should get you back to the default system.ntp next install)

fun fact: half the reason I did that ntp change was due to collectd(luci_statistics) erroring out when it can't get time quick enough on boot...

3.2.61-30 comes with a non-linux native web terminal [tty] and text [editor] if putty is not your thing...

It just kept rebooting
when I removed all my usb devices, usb to ethernet adapter and other usb storage, it was able to boot. I then just decided to format my card and install it from scratch and config everything again. Took me few hours
:sleeping:

should i update or not?

stable[minor-update] online:3.2.61-30(3.2.61-20)  
1 Like

can you run;

tail -n3 /boot/config.txt
[root@network /]# tail -n3 /boot/config.txt
# Place your custom settings here.
dtparam=sd_poll_once
dtoverlay=dwc2
1 Like

best to run this and reboot...

sed -i 's|^dtoverlay=dwc2|#dtoverlay=dwc2|g' /boot/config.txt

i thought it would be smart to enable networking over the usb-c_otg port... turns out it is not so smart...

after that... yeah... may as well update I think...

1 Like

it's done. Anything else to do?

1 Like

there may have been a section added for interface 'gether' in networking...

but it should not really cause problems unless you have other 'usbX' (tethering/modem) devices in use or use 10.11.12.x as a subnet... [another not-so-smart idea of mine]

1 Like

hands up, thats me...

1 Like

i fear posting the result...

Sat Jul 3 00:00:25 2021 daemon.err collectd[16650]: Configuration file /tmp/collectd.conf is empty.
Sat Jul 3 00:00:25 2021 daemon.err collectd[16650]: Error: Parsing the config file failed!
Sat Jul 3 00:00:25 2021 daemon.info procd: Instance collectd::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

/:
i recognised it earlier in syslog but thought it worked before, didnt touched it, so cant be it, just ignore. i am failure. still wonder why it makes the whole menu gone.

system.ntp=timeserver
system.ntp.use_dhcp='0'
system.ntp.server='ntp1.dismail.de' 'ntp2.dismail.de' 'ntp3.dismail.de'

it was

NTP_FAST="time.cloudflare.com"

changed to

NTP_FAST="ntp1.dismail.de ntp2.dismail.de ntp3.dismail.de"

also noticed this before in syslog when it error-stated when updating pkg's (iirc) 'last time was bla and new timestamp is older' (likewise).

pheditor is nice to have, didnt knew it before.
tty links to 'rpi-ip/ttyd' which then gets forwarded to 'ttyd.router' and (at least for me) cant be resolved.
maybe dns-problem on my side, but atm it has no usecase for me as long as ssh is reliable, which it has been since forever. seems like pheditor also has a 'terminal' in the bottom-part. strange times.

1 Like

if your using dnsmasq... there should be an entry with your lan ip similar to this;

uci show dhcp | grep router
dhcp.@dnsmasq[0].address='/router/10.2.3.1'

(next version will probably just use the ip anyway as I tried it on my second router and it sent me to the first
:shushing_face: )

cat /etc/config/luci_statistics; ucivalidate.sh

it is. same output for me.

pardon the question. you want the output? it is a lot, too much i am afraid.
or should i look for anything specific?

1 Like