Rpi4 < $(community_build)

Is the power supply good enough? Maybe during power on with all the components drawing a lot of power, the usb3 adapters do not get the power they need. Do they seem to be working after a cold boot? Can you see them in dmesg or ip link ?

I will just provide some anecdotal notes here; I'm not sure whether they are more broadly applicable or just to OpenWrt RPi4 users (or even more specifically to those who have similarities to my own configuration). I only note these things by virtue of not having seen them elsewhere, so felt it necessary to do so.

If you're attempting to apply SQM to a Wireguard interface, do be sure to include the requisite overhead for your designated protocol. That is, by default 40 for wireguard and then an additional 20 for IPv4 and then a further 20 for IPv6 (if you include it in your network stack). To exemplify: I have a VDSL connection via PPPoE, such that my default overhead is 34. To allow for Wireguard I add 40 for the default configuration, then a further 20 for IPv4. No more than that as I do not have IPv6, such that my overhead in SQM is 94.

Additionally: I have found it to be the case where attached to the Wireguard interface that better performance is gained by not leveraging the NAT argument for SQM; that instead it is preferable to default to the nonat configuration.

Moreover, that it is preferential to use the USB-Ethernet connection for WAN. This, in my own experience, resulted in fewer dropped packets - most notably when using Wireguard. Similarly, using ethtool to disable power saving mechanisms for the USB-Ethernet (WAN) interface resulted in better throughput.

I will again state that my conclusions are wholly anecdotal and seem true in all the tests I've performed in my configuration. I would gladly welcome contradiction as I've little capability to contrast my own experiences with my given configuration.

Thank you for your work, Wulfy23. It's good to see a concerted effort to support a configuration that has not been meant for it by default. Also, as a continuation of my previous post, that it's good to see that proper IRQ balancing has been implemented. IRQBalance in and of itself does precious little beyond initial config (is it even meant to adjust according to load?), but there are certainly lessons to be gleaned from what it does currently.

1 Like

I just flashed OpenWrt on my Pi 4B, connected it with LAN to my PC and opened the LuCI dashboard.

Now I would like to set up the wifi. Unfortunately in LuCI it shows under "Wireless" tab:
radio0 Generic MAC80211 82.11nac Device is not active

What can I do?

go to 'services' check 'wpad' is enabled and started...

go back to wireless, setup... enable and start...

other than that search this thread or the forum for setting your country code...

1 Like

Thank you! It works now.

For others more detailed:

Enable+Start wpad:
→ System → Startup → "wpad" → click on "disabled" to enable it → "restart"

Change country code:
→ Network → Wireless → SSID ap101 → edit → Advanced settings → Country Code: <select-your-country-code>

Change password:
→ Wireless Security → Key: "strongPW"

Save+Restart:
(→ Network → Wireless →) Restart → Save & Apply → Restart

For some reason my lan doesn't get internet from the wan.

For my wan I use eth1 (an usb lan adapter) that works. Via ssh@openwrt I can ping 8.8.4.4 as well as www.google.de ==> so internet works in general.

My lan is a "br-lan" (containing eth0 and wlan0)
What I could find on the internet the firewall looks okay (lan -> wan accept and wan has masquerading).

Any idea whats wrong here?

from what you have said... 'lan' = both wired and wireless...

have you tested both wired and wireless?

this suggests you have a dns issue...

  • where did you configure the dns settings on the router
  • what did you set them to?

Out of the box... openwrt will use dns servers advertised by your wan interface dhcp server...

if you are not using dhcp on your wan interface... then you need to enter which (upstream) dns server your dnsmasq(local dns server) will forward queries to...

via ssh both works:

ping 8.8.4.4
ping www.google.de

So the wan itself has no dns issues (because I entered the dns).
my config:

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0'

config interface 'wan'
	option proto 'static'
	option ipaddr '192.168.12.36'
	option netmask '255.255.255.0'
	option gateway '192.168.12.1'
	option ifname 'eth1'
	list dns '192.168.12.1'

I tested from both. wired and wireless. both the same. no internet at all (also tried with the pings)

1 Like

the dns server entry under your wan interface applies to the host(router only)...

go into your DNS-SERVER settings and set the upstream dns-server that you will hand out to clients that it will use for requests from clients...

you need a reverse route on your primary router (192.168.12.1)

in future when dealing with multiple networks... please ping each router along the path...

anyway... your issues are not really build specific... so for further assistance... please create a separate thread...

If the firewall configuration is left to defaults, it will work.
@phqzgunsfjror maybe open a new thread to solve it there.

1 Like

Thank you.
After a fresh install internet works on 'lan' now. I also changed the order: at first I configured 'wan' and then the wifi.

Does it support WPA3? I cannot even connect via WPA2. Only WPA seems to work...

the answer to that is complicated... does it work (currently on this os)?, not that i'm aware of...

you can start it but clients probably wont connect...

WPA2 can be made operable...

best to get a real AP

WPA2 doesn't work either... (if I go into my notebook wifi settings, I can see it only takes WPA)

My goal was to test OpenWrt and see whether it can fullfill my requirements but it makes a lot of problems :smiley:

What is actually the purpose of this Rpi4 build?

@anon50098793 have you seen this?

1 Like

yeah... thats your pretty typical full distro udev handler rules...

if only it was that simple

:sneezing_face:

one of my recent debian re-installs brought up a usb nic as;

eth-aabbcc112233

that was pretty cool too...

Sounds like a good password /j

1 Like

I wondering how much code would need to be ported to make that work :frowning:

1 Like

ran into an issue (general) with usb3 hubs over the last two days... plenty of online references once I knew what to search for...

essentially, some models of usb3(powered) hubs make the pi cease to boot(cold start)... something to do with backpower...

pretty easy to spot as not LAN leds light up...

non working hub;

link

working hub

link

1 Like