Rpi4 < $(community_build)

Another vote to please keep this alive


This is too important to vanish. We all want it to live longer.

1 Like

is there a way to execute rpi-perftweaks.sh on the official 22.03 build?

i don't this is dead, there's a 22.03 build on GitHub inside the folder untested.

1 Like

Screenshot 2022-09-10 022915

Should I upgrade?

but on the website the latest image says "untested"

I think I will wait.

1 Like

just recieved an up date noteification on the splash bar

flavour:stable online:2.1.6-2

:slight_smile: has anyone tried it

1 Like

im running 2.1.6-2 seems stable so far.


Working fine here

1 Like

I finally fixed the issue of IPTV stutter and stream stopping after a few mins. It was an issue with VDSL PTM interface in the modem settings. I was creating separate interfaces for IPTV and internet with vlans. You just need 1 PTM vdsl bridge interface without mentioning any vlan ID.
Created separate vlans in the openwrt interfaces for IPTV and WAN pppoe, Its working fine now.

@trendy You and wulfy tried to help and now it's finally fixed.

so stupid of me. :smiling_face_with_tear:

I install Adguard post each update using the script

curl -s -S -L https://raw.githubusercontent.com/AdguardTeam/AdGuardHome/master/scripts/install.sh | sh -s -- -v -r

But after each update the config gets wiped so is there any way to restore that post update?

I do not use the opkg version adguard as it takes extra steps to make it persistent.

new minor update but it's not showing flash option.

Click on minor update..it will download a sysupgrade file..

1 Like

yes, it did but how to manually update and keep all the settings?

Just upload it and select keep all settings

1 Like

These packages were not restored after the update. I manually installed them.

opkg install igmpproxy samba4-server vsftpd  luci-app-samba4 ca-certificates simple-adblock luci-app-simple-adblock

Just updated too

I always generate a backup just in case before.

A,so, don’t forget to restart dyndns and update your servers!

2.1.6-7 working fine here.

Could someone please post the contents of the "CONFIGURE OKPG" under the software tab as i think i have old info and it wont okpg update.


Hi, I have version 7.1.37-7

cat /etc/opkg.conf
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
option check_signature

cat /etc/opkg/customfeeds.conf
#################### customfeeds.conf
src/gz git_core https://github.com/wulfy23/rpi4-opkg/raw/master/r20522-545c6113c9/core
src/gz git_base https://github.com/wulfy23/rpi4-opkg/raw/master/r20522-545c6113c9/base
src/gz git_luci https://github.com/wulfy23/rpi4-opkg/raw/master/r20522-545c6113c9/luci

cat /etc/opkg/distfeeds.conf
#################### distfeeds.conf
src/gz openwrt_kmods http://downloads.openwrt.org/snapshots/targets/bcm27xx/bcm2711/kmods/5.15.64-1-77f617b6f61273204da192df1ab64187
src/gz openwrt_packages http://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a72/packages
src/gz openwrt_routing http://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a72/routing
src/gz openwrt_telephony http://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a72/telephony

################# commented lines read by opkg-official>upgrade
#src/gz openwrt_core https://downloads.openwrt.org/snapshots/targets/bcm27xx/bcm2711/packages
#src/gz openwrt_base https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a72/base
#src/gz openwrt_luci https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a72/luci
1 Like

Hi, first, thank for sharing this script. It just works. One question. I'm trying to reset a usb device (iphone in my case) with usbreset command and after that the system doesn't bring it up again.

root@OpenMPTCProuter:~# usbreset 
  usbreset PPPP:VVVV - reset by product and vendor id
  usbreset BBB/DDD   - reset by bus and device number
  usbreset "Product" - reset by product name

  Number 002/002  ID 0bda:8153  USB 10/100/1000 LAN
  Number 001/007  ID 05ac:12a8  iPhone
  Number 001/002  ID 2109:3431  USB2.0 Hub
  Number 001/004  ID 0bda:8152  USB 10/100 LAN
root@OpenMPTCProuter:~# usbreset 05ac:12a8
Resetting iPhone ... ok
root@OpenMPTCProuter:~# logread |tail
Thu Sep 29 15:22:49 2022 kern.debug kernel: [ 2745.931877] ipheth 1-1.3:4.2: no of_node; not parsing pinctrl DT
Thu Sep 29 15:22:49 2022 kern.info kernel: [ 2745.938777] ipheth 1-1.3:4.2: Apple iPhone USB Ethernet device attached
Thu Sep 29 15:22:49 2022 daemon.err usbmuxd[20593]: [15:22:49.867][3] Removed device 1 on location 0x10007
Thu Sep 29 15:22:50 2022 user.warn kernel: [ 2746.075851] vMkickanic_net_add> INTERFACE:eth1 7e:a1:ae:f0:c1:c5 is mac_original known to /etc/config/network
Thu Sep 29 15:22:50 2022 user.warn kernel: [ 2746.090529] vMkickanic_net_add> kick_a_nic eth1 > ethf0c1c5
Thu Sep 29 15:22:50 2022 kern.info kernel: [ 2746.104874] ipheth 1-1.3:4.2 ethf0c1c5: renamed from eth1
Thu Sep 29 15:22:54 2022 daemon.notice netifd: Interface 'wan2' is enabled
Thu Sep 29 15:22:54 2022 daemon.warn [7628]: <warn>  [eth1] invalid sysfs path read for net/eth1
Thu Sep 29 15:22:54 2022 daemon.warn [7628]: <warn>  [base-manager] couldn't handle kernel event: device net/eth1 not found
Thu Sep 29 15:22:54 2022 daemon.warn [7628]: <warn>  [base-manager] couldn't handle kernel event: Invalid 'action' parameter given: 'move' (expected 'add' or 'remove')

Reboot helps anyway
How to fix this?

Thanks in advance