Rpi4 < $(community_build)

yes, they are maintained at wulfy, I recommend using 7.1.13 with 5.15 kernel and I have no problems, I use mwan3, sqm with one FTTH 1000 / 300mbs line and the other line 100 / 20mbs in 4g

hi, if you use another router what happens? if you get the same problem it is probable an isp problem, if instead everything works I assume it is a filesytem problem on the sd

1 Like

You/They are being cg-natted.

how to add vlan802.1p and vlanmuxid for my bridged wan pppoe connection?

0 and 20 are for iptv and 0 and 10 are for internet

my wan settings

config interface 'wan'
        option proto 'pppoe'
        option device 'eth1'
        option username '*****'
        option ipv6 'auto'
        option hostname 'router'
        option mtu '1500'
        option password '*****'
        option keepalive '2 5'
        option peerdns '0'
        list dns '8.8.8.8'
        list dns '1.1.1.1'
        list dns '9.9.9.9'

I don't know why it keeps getting 10... ip from wan pppoe instead of public IP and I have to restart wan interface and sometimes reboot both modem and pi4 couple of times for it to work.

I get this error when I restart wan interface.

Unknown error (USER_REQUEST)

I tried this solution
by adding

LCP echo failure threshold 2
LCP echo interval 5

but it worked only once

I tried 2 different routers. Sometimes they work and sometimes they don't

Which values do I need to add? seems to be 2 values for each.

Access Concentrator
Service Name
Host-Uniq tag content (It is used by host to uniquely associate an Access Concentrator response (PADO or PADS) to a particular Host request (PADI or PADR))
Added those values in PPPoE-WAN interface along with
LCP echo failure threshold=2
LCP echo interval =5

Great job everyone. Keeping this alive

I recently had power outages which caused corruption in this rom, anyone else faced this?
The statistics app stopped working and the overview page became turtle slow.
This was on latest build on a usb3 pendrive.

Maybe your SD card got corrupted. I'd start there.

It was a usb3 pendrive and it works totally fine.

hello, I use a usb3 ssd disk ext4, it often happens that after shutting down at the next boot it tells me to check the file system. I do not report malfunctions to active applications, statistics and nlbwmon

1 Like

Ok so I will try a clean flash now.

hi, did you solve the problem, was it the file system or the usb stick?

2 Likes

I have flashed it on an sd card now, still seems to slow down when it boots after a power fail, but like you said it does some repair stuff and becomes responsive again.
While it dials ppoe during the initial boot after power returns the overview page becomes unresponsive for some time.

Newer Major 7.1.31-3 won't flash for me. Neither the red "flash" link nor a manual flash works. I can supply error information if this is not already known.

hi, I haven't tried the update from 7.1.13 to 7.1.31 yet, tonight after work I try (from Italy). However it is better to open an issue on https://github.com/wulfy23/rpi4/issues

hi, i had your same problems with sd cards, for this reason i switched to very performing usb3 ssd. Filesystem problems remain after shutdown

Will do.

Regards,

Jeff Alperin
H: 561-666-7789
C: 561-797-9876