RPi 4 radio not working

Recently installed on 2 different RPi 4, 21.02.0-rc1 on the first and current snapshot (added luci) on the second and I cannot get the built-in WiFi radio to work, yet I can do this with my eyes closes on Linksys 8300's.

I did use raspi-config to set the radio to CA to make sure the eeprom was properly setup.

I tried to find other clues on this forum, but there doesn't seem to be much out there, unless I am completely searching the wrong way.

Any ideas please ?

It's good that you already set the country code with Raspi-Config. One less thing to verify...
Please go to System / Startup and try restarting WPAD service.

On my RasberryPi4, wireless only worked after I restarted the wpad service manually. I took me quite a while to find this out...

Before that, I was resorting to manually removing WPAD and installing hostapd to make it work, but now that I figured this out, it seems to work with WPAD as well.

Thanks, did the trick.

However, seems to work AC at 20MHz only, unless I am doing something wrong.

Are there any known issues with certain parameters that are known not to work or are difficult to configure ?