RPi 4 how to config openWRT + dnsmasq for getting IP-Addesses + a lot of questions

I've installl openWRT 21.02 on RPi4; okay this was the easiest part.
My target is --> config and using RPi4 as a full replacement for my linksys WiFi router.
RPi4 should be only a WiFi AP, DNS, DHCP _- ergo dnsmasq-server; not Firewall - use ipfire on other device.

With my config below I get no IP-Adresses over wlan (br-lan)

My configuration looks like:

root@LANrouter:/etc/config# cat network  

config interface 'loopback'
       option device 'lo'
       option proto 'static'
       option ipaddr ''
       option netmask ''

config globals 'globals'
       option ula_prefix 'fd9c:12aa:afeb::/48'

config interface 'lan'
       option ifname 'eth0 wlan0'
       option type 'bridge'
       option proto 'static'
       option ipaddr ''
       option netmask ''
       list dns_search 'klara100.lan'

config interface 'WAN'
       option proto 'static'
       option device 'eth1'
       option ipaddr ''
       option gateway ''

config device
       option name 'eth1'
       option ipv6 '0'

config device
       option name 'wlan0'
       option ipv6 '0'

config device
       option name 'eth0'
       option ipv6 '0'

config interface 'wlan0'
       option proto 'dhcp'
       option delegate '0'
       option ip4table 'default'
       option device 'wlan0'

config route
       option interface 'WAN'
       option target ''
       option netmask ''
       option gateway ''
root@LANrouter:/etc/config# cat dhcp  

config dnsmasq
       option localise_queries '1'
       option rebind_protection '1'
       option rebind_localhost '1'
       option expandhosts '1'
       option leasefile '/tmp/dhcp.leases'
       option localservice '1'
       option ednspacket_max '1232'
       option local 'klara100.lan'
       option domain 'klara100.lan'
       option resolvfile '/etc/resolv.conf'
       option quietdhcp '1'
       list addnhosts '/etc/hosts'
       option authoritative '1'
       list server ''
       option filterwin2k '1'
       option loglevel '4'

config dhcp 'lan'
       option interface 'br-lan'
       option start '100'
       option limit '150'
       option leasetime '12h'
       option dhcpv4 'server'
       option ra 'server'
       option ra_slaac '1'
       list ra_flags 'managed-config'
       list ra_flags 'other-config'
       option loglevel '4'

config dhcp 'wan'
       option interface 'wan'
       option ignore '1'

config odhcpd 'odhcpd'
       option maindhcp '0'
       option leasefile '/tmp/hosts/odhcpd'
       option leasetrigger '/usr/sbin/odhcpd-update'
       option loglevel '4'

config dhcp 'wlan0'
       option interface 'wlan0'
       list ra_flags 'none'
       option ignore '1'

and wireless

root@LANrouter:/etc/config# cat wireless

config wifi-device 'radio0'
       option type 'mac80211'
       option channel '36'
       option hwmode '11a'
       option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
       option country 'DE'
       option txpower '9'
       option htmode 'VHT40'
       option cell_density '2'

config wifi-iface 'wifinet0'
# config wifi-iface 'wlan0'
       option device 'radio0'
#     option device 'wlan0'
       option mode 'ap'
       option ssid 'Klara101'
       option encryption 'psk'
       option key '1234567890'
       option network 'br-lan'

that's all :grinning:
Info: using today RPi3 as a dnsmasq-Server. I'm using the config files from RPi3 for openWRT --> dnsmasq-dns.conf

# Lokale Domain

I need help for understanding was is wrong; I've problems for understanding what can I config an Konsle and was ist to do on uci Interface; I missing some console-configs inputs on uci interface (WEB; for example /etc/hosts.
What I'm missing too is syslogs; journalctl which helps me to find error; how can I resolve this

Need I --> odhcpd???
Don't need firewall modul - opkg remove firewall ????
How to configure ipforward from (br-lan : eth0 wlan0) to wan??

I hope somebody can give me some help.


You can answer in German as you like

iptables is rather built-in (especially if you need to NAT), so simply allow all.

Weil Sie bereits eine statische IP-Adresse zugewiesen haben.

Because you already assigned a static IP address.

No, https://translate.google.com can be used.

The file to edit is /etc/config/dhcp

See: https://openwrt.org/docs/guide-quick-start/start

RPi3 replaces Linksys for wifi? How you bear RPi3 bad wifi performance?

okay, could be a solution; but I don't want to have NAT; all client mus show it org. (DHCP) IP address.
NAT only on ipfire.

RPi3 B+ is my dnsmasq-server now; RPi4  is the replacement for my linksys WiFi router and RPi3 B+;
Do you know LinksSys MB7350 - I know this router ;

Sorry, I need a static IP for LAN and WLAN - because this interface is the default gw for all clients in this LAN (network);
DHCP should offer IP address for all client ; either an eth0 (LAN) or wlan0 (wlan)

Then we must have a language barrier:

Did you enable DHCP on the interfaces you desire?