RP4 | Attended SysUpgrade | DDNS app issues


Last night I updated my main router using Attended SysUpgrade.

I cloned the flash disk to a .img file, copied it to a new flash disk and used that to complete the updates.

21.02 > 21.05 > 22.03

Everything seemed to go well, but there were a few issues:

  • The SSH cert that I generated for my OpenWrt WAP was missing and had to be regenerated and uploaded to the WAP.
  • The web-security certificate for my DDNS provider (dynu) was missing and I had to download the file again.
  • DDNS is functional, but the services list is missing.

I tried uninstalling/installing the software package, but it didn't fix the issue.

The package is listed as compatible with 22.03.

Any ideas?

Where did you store these files?

Re the ddns list, what does the following command return

opkg list-installed | grep ddns

The SSH cert was in /root/.ssh.
The web-security cert was in /etc/ssl/certs/dynamicdns/dynu

 OpenWrt 22.03.3, r20028-43d71ad93e
root@rp4-openwrt:~# opkg list-installed | grep ddns
ddns-scripts - 2.8.2-25
ddns-scripts-services - 2.8.2-25
luci-app-ddns - git-22.339.34822-6da87df

In Luci goto system > Backup / Flash Firmware > Configuration > open list

If those files are not listed in the list then add the locations into the box to ensure they are saved during an upgrade.

Re the ddns lists. Have you pressed the "Update DDns Services List" button?

Thanks. I've added them to the list.

Yes. I've rebooted, etc, but it still shows 'no list'.

What happens when you press update list? Does the timestamp get updated or still says no list?

Can you press the button then check the system log for any recent messages? Can you provide the relevant output here.

There is no timestamp.

My configured DDNS is working fine.

I tried to configure a new 'test' service and it resulted in an error message related to the service name.

No problem then :laughing:

Is there anything in the system log that is relevant? An error perhaps?

I can't find anything in the logs.

It seems the Service List package is broken.

Can you run

/usr/bin/ddns service update

Please provide the output. This should give us clues to the reason why the list isn't updating.

Sorry for the delay, I've been a bit busy.

root@rp4-openwrt:~# /usr/bin/ddns service update
Certification file not found (/etc/ssl/certs/dynamicdns/)

root@rp4-openwrt:~# cd /etc/ssl/certs/dynamicdns/
root@rp4-openwrt:/etc/ssl/certs/dynamicdns# ls


A bit of a strange one. I deleted the CA Certs Path and set it to IGNORE. I restarted the service, but it still said NO_LIST.

I changed it back to /etc/ssl/certs/dynamicdns/ and now the issue is fixed.


Very strange!

I was going to suggest you install the regular ca-certificates and ca-bundle or point directly to your cert file.

Glad it's working!

Maybe the relevant file wasn't carried forward during the update and DDNS only creates a new file when the directory is set?

Relevant file?

I've just checked the folder and it still only contains the 'dynu' folder that I manually created.

I'm not sure why it's working either. But pleased it is!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

Thanks for your help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.