Routing issue two devices

Resolves. The issue was the bridge.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

Let's see:

config interface 'wan'
	option device 'eth0'
	option proto 'none'

config interface 'wan6'
	option device 'eth0'
	option proto 'dhcpv6'
	option disabled '1'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'

You have WAN / WAN6 disabled, and there is only one interfaced (LAN). These lines are useless, because you do not have a WAN interface:

config route
	option interface 'wan'
	option target '0.0.0.0/0'
	option gateway '192.168.1.1'

Also, these lines are also useless, because you already specified this route on the LAN interface:

config route
	option interface 'lan'
	option target '0.0.0.0/0'
	option gateway '192.168.1.1'

And here is the real issue:

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.22.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'

The gateway is outside the network range of the LAN interface... The gateway is precisely the device that routes packages when the destination is outside the range of an interface; if the gateway is outside the range of the interface, how are packets supposed to reach the gateway?

If the main router is at 192.168.1.0/24, what is the point in having an access point at 192.168.22.0/24?