Routing IPv6 traffic from devices connected to lan interface to a host on a different interface

I have two routers running OpenWrt, both with their own fiber connection. I have a cable between the lan4 ports on both routers, so I can access the other in case one of the uplinks would go down.

On router 1:

config interface 'bridge'
	option device 'lan4'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option ip6addr 'fc10::1/64'

On router 2:

config interface 'bridge'
	option device 'lan4'
	option proto 'static'
	option ipaddr '192.168.10.2'
	option netmask '255.255.255.0'
	option ip6addr 'fc10::2/64'

The firewall settings on both routers:

config zone
	option name 'bridge'
	option network 'bridge'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option masq '1'

config forwarding
	option src 'lan'
	option dest 'bridge'

This works without issues from the routers themselves. I can access each router from the other one over IPv4 and over IPv6.

From clients connected to the routers, however, only IPv4 works. So I can reach router 2 from clients connected to router 1 when I access 192.168.10.2, but for fc10::2 all packets are dropped (even though fc10::2 works fine from router 1 itself).

I'm guessing that IPv6 traffic from the lan interface isn't routed to the bridge interface, and I've tried setting up (static) IPv6 rules, but to no avail so far.

I'm probably missing something simple, so hopefully somebody can tell me what.

Hi

it is working because you using
option masq '1'
and it is working for IPv4

but IPv6 is not covered with this option
you need to add
option masq6 '1'
in FW zone

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.