routerUSBtty: No shell/prompt, able to send/recieve input

I've flashed my RP-WD03 router.
Installed drivers for USB-RS232 adapter, following:

However I don't get anything showing on connection, no shell.

I can send and receive using:

cat /dev/ttyUSB0
echo "Test" > /dev/ttyUSB0

This shows OK on both devices, so the connection is working.

My inittab contents are:

::sysinit:/etc/init.d/rcS S boot
::shutdown:/etc/init.d/rcS K shutdown
ttyUSB0::askfirst:/bin/ash --login

I've rebooted the router
I've tried using ttyUSB0::askfirst:/bin/login to get a login prompt

Is there anything I'm obviously missing? Feels like some process is not listening for a connection that routes to the shell?
Any suggestions?

I'm fairly noob with OpenWRT/Linux so apologies if it's a simple issue.

I don't think it's a simple issue... I tried this a few months ago and had similar results...

so, likely candidates would be procd / hotplug changes over the last 12+months rendering this functionality suspect...


Thanks for the reply, I've tried flashing 18.06.0 and 18.06.2 without saving config, same result. Wondering if maybe it's something with the USB packages?

1 Like

ok... maybe my theory is flawed...

you might try;

  • enable procd debug / preinit stderr etc. etc.
  • if your device has space... use the buildroot and add those modules within the kernel ( should work )
1 Like

Some hardware/drivers may be incompatible, thus perhaps you should change the approach.
Assuming your final goal is to set up a management interface, there are different ways to do this.
E.g. using network aliases for a static L3 address, or splitting VLANs for a separate L2 interface.


Thank you for the replies, I've got it working using agetty.

opkg install agetty
/usr/sbin/agetty -h -t 60 ttyUSB0 9600 vt102

I'm using this approach to connect some old dos handhelds.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.