Routers are not able to connect in ad-hoc mode using OSLR

I have configured my raspberry pi with olsr, but while connect it to another router it isnt working.
Looking for some help here.

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option htmode 'HT20'

config wifi-iface 'wifinet0'
	option ssid 'OpenWrt'
	option encryption 'none'
	option device 'radio0'
	option mode 'adhoc'
	option network 'mesh'

/etc/config/


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd52:f03e:6497::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'mesh'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.10.10.2'
	list dns '8.8.8.8'

The other router's ipaddr is 10.10.10.1

/etc/config/oslrd


config olsrd

config LoadPlugin
	option library 'olsrd_arprefresh.so.0.1'
	option ignore '0'

config LoadPlugin
	option library 'olsrd_dyn_gw.so.0.5'
	option ignore '0'

config LoadPlugin
	option library 'olsrd_httpinfo.so.0.1'
	option port '1978'
	list Net '0.0.0.0 0.0.0.0'
	option ignore '0'

config LoadPlugin
	option library 'olsrd_nameservice.so.0.4'
	option ignore '0'

config LoadPlugin
	option library 'olsrd_txtinfo.so.1.1'
	option accept '0.0.0.0'
	option ignore '0'

config Interface
	option ignore '0'
	option interface 'mesh'

config LoadPlugin
	option library 'olsrd_jsoninfo'
	option ignore '0'

config LoadPlugin
	option library 'olsrd_nameservice'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_txtinfo'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_arprefresh'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_bmf'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_dot_draw'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_dyn_gw'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_dyn_gw_plain'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_httpinfo'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_mdns'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_p2pd'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_pgraph'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_secure'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_watchdog'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_quagga'
	option ignore '1'

/var/etc/olsrd.conf


DebugLevel 0
AllowNoInt yes

LoadPlugin "olsrd_arprefresh.so.0.1"
{
}

LoadPlugin "olsrd_dyn_gw.so.0.5"
{
}

LoadPlugin "olsrd_httpinfo.so.0.1"
{
	PlParam "Net" "0.0.0.0 0.0.0.0"
	PlParam "port" "1978"
}

LoadPlugin "olsrd_nameservice.so.0.4"
{
	PlParam "name" "OpenWrt"
}

LoadPlugin "olsrd_txtinfo.so.1.1"
{
	PlParam "accept" "0.0.0.0"
}

LoadPlugin "olsrd_jsoninfo.so.1.1"
{
}

Interface "wlan0"
{
}


Active host net announcements are being populated but they arent connecting

Thanks for the help.

for setting up I followed this guide.

check output of to confirm mesh support of wifi

iw phy

or

use USB wifi adapters like RT2800 that support mesh

or

use mesh over ethernet

Wiphy phy0
        max # scan SSIDs: 10
        max scan IEs length: 2048 bytes
        max # sched scan SSIDs: 16
        max # match sets: 16
        max # scan plans: 1
        max scan plan interval: 508
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * P2P-client
                 * P2P-GO
                 * P2P-device
        Band 1:
                Capabilities: 0x1020
                        HT20
                        Static SM Power Save
                        RX HT20 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 16 usec (0x07)
                HT TX/RX MCS rate indexes supported: 0-7
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed } <= 1, #{ P2P-device } <= 1, #{ P2P-client, P2P-GO } <= 1,
                   total <= 3, #channels <= 2
                 * #{ managed } <= 1, #{ AP } <= 1, #{ P2P-client } <= 1, #{ P2P-device } <= 1,
                   total <= 4, #channels <= 1
        Supported extended features:
                * [ 4WAY_HANDSHAKE_STA_PSK ]: 4-way handshake with PSK in station mode
                * [ 4WAY_HANDSHAKE_STA_1X ]: 4-way handshake with 802.1X in station mode

That's the output i got.

yes IBBS is for adhoc mesh

other adapters will show MESH for 802.11s

refer to these guides to see if you missed something with your OLSR configuration

usually the libraries and json support programs

also you need HNA settings for each network or subnet and 0.0.0.0 for the gateway node

https://www.metamesh.org/multi-port-routers

https://www.metamesh.org/single-port-routers

https://justingoetz.net/docs/docs_openwrt/olsr/adhoc-wpa.html

Also look at this previous thread

The link for that tutorial does not exist anymore:(

I tried a lot with raspberry pi but couldn't get it working:(