Router won't boot from root overlay after the power outage

I have a TP-Link MR3420 v2 and I am using the latest LEDE firmware on it with ExtRoot /overlay configuration. Everything works fine most of the times but if there is a power outage then after the power comes back the router reboots from the firmware configuration and doesn't care about the /overlay unless you manually reboot the router. I use a 1 gb usb stick and it fires up as soon as the router has power so idk what is going wrong.

I also tried to delay the boot process with the delay option in fstab from 5 to 10 seconds but it is still the same. I was thinking about using the crontab to setup manual reboots but that seems like an overkill because i have no idea when the power would be out.

So I wanna know if there is any thing I can do to make sure that the /overlay configuration works every time the router boots up. Or maybe there is any way to check if the /overlay is working properly when the router boots up.

Any suggestions would be helpful! Thanks