Router unreachable even after hard reset - briefly connects after reset


I have trouble connecting to archer C7 router. It started innocently enough (doesn't it always) by me trying to reconfigure settings inside (to-date) well-functioning openwrt. I managed to delete IP address of the router (not gateway, not broadcast, just the IP address under networking) and save the settings. This resulted in me being cut off from the router settings. Upon finding out that the router just hasn't reverted to another common ip address, and that I can't reach it via ssh either, I tried a failsafe mode... then I tried hard reset. The router does not provide me with an IP address now, so I went on to set up my ip address to When I power on the router while holding the reset button for a few seconds while sending a constant ping to I get a few packets through few seconds after releasing the button. But that's about it. Regardless if I plug it to wan or lan port. What should be my next steps?


Actually entering the failsafe mode?

If you have just a config problem, failsafe mode should enable you to fix it.
Entering it requires you to push a button during a 2 second window, so I doubt it you have managed it so far.

(Keeping a button pressed is not the correct way. You likely need to repeatedly pus it during boot process, unless you are quick to react to LED blinking changes. See wiki about generic failsafe)

I would have thought I had already hard-reseted it by repeatedly going through 30-30-30s routine.

There is no 30-30-30 in OpenWrt. (That is mainly a myth from ancient times)

You were right. Spamming the reset button was the solution. I feel ashamed, lol. Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.