Hello everyone,
I just got a new GL-MT6000 to replace my old FritzBox 5530 + D-Link DGS-1100-08 setup, specifically the D-Link switch was to configured for port trunking to connect two PCs (both running ubuntu with netplan for configuring the interfaces) with dual Gigabit link between each other and another port of the switch was connected to the FritzBox for internet connection.
Summing up:
D-Link port 1 was connected to one of the LAN ports of the FritzBox
D-Link ports 3 and 4 were bonded and connected to the first PC (from now on called the "server")
D-Link ports 5 and 6 were bonded and connected to the second PC (from now on called the "workstation")
After setting up the GL-MT6000 both the available 2.5G ports were used: one for WAN and the other for the workstation that has a 2.5G NIC; the server has two Gigabit NICs, I'm trying to replicate the old setup following as close as possible various guides available on the internet, unfortunately they are either about Multi-WAN setups, about bonding+VLAN, outdated (ifenslave package is no more in the repositories) or even going off-topic because the device used has not multiple network interfaces but a single interface for the CPU and an integrated unmanaged switch.
I need your help to setup a simple 802.3ad Link Aggregation without involving WANs or VLANs, hoping I didn't miss any important detail when explaining my configuration.
brada4
January 3, 2025, 4:28am
2
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall
root@GL-MT6000:~# ubus call system board
{
"kernel": "5.4.238",
"hostname": "GL-MT6000",
"system": "ARMv8 Processor rev 4",
"model": "GL.iNet GL-MT6000",
"board_name": "glinet,gl-mt6000",
"release": {
"distribution": "OpenWrt",
"version": "21.02-SNAPSHOT",
"revision": "r15812+1082-46b6ee7ffc",
"target": "mediatek/mt7986",
"description": "OpenWrt 21.02-SNAPSHOT r15812+1082-46b6ee7ffc"
}
}
root@GL-MT6000:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd09:93ca:9386::/48'
config device
option name 'br-lan'
option type 'bridge'
option macaddr '[REDACTED]'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'lan5'
config device
option name 'lan1'
option macaddr '[REDACTED]'
config device
option name 'lan2'
option macaddr '[REDACTED]'
config device
option name 'lan3'
option macaddr '[REDACTED]'
config interface 'lan'
option device 'br-lan'
option ip6assign '60'
option isolate '0'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.254.0'
config device
option name 'eth1'
option macaddr '[REDACTED]'
config interface 'wan'
option force_link '0'
option ipv6 '0'
option metric '10'
option disabled '0'
option device 'eth1.100'
option proto 'pppoe'
option username '[REDACTED]'
option password '[REDACTED]'
option vlanid '100'
option peerdns '1'
config interface 'wan6'
option proto 'dhcpv6'
option device '@wan'
option disabled '1'
config interface 'tethering6'
option device '@tethering'
option proto 'dhcpv6'
option disabled '1'
config interface 'wwan6'
option device '@wwan'
option proto 'dhcpv6'
option disabled '1'
config interface 'guest'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.9.1'
option netmask '255.255.255.0'
option ip6assign '60'
option multicast_querier '1'
option igmp_snooping '0'
option isolate '0'
option bridge_empty '1'
option disabled '1'
config interface 'wwan'
option proto 'dhcp'
option metric '20'
option classlessroute '0'
config interface 'secondwan'
option ipv6 '0'
option proto 'dhcp'
option metric '15'
option force_link '0'
option classlessroute '0'
config interface 'secondwan6'
option proto 'dhcpv6'
option device '@secondwan'
option disabled '1'
option metric '15'
config rule 'policy_direct_rt'
option lookup 'main'
option suppress_prefixlength '0'
option priority '1100'
config rule 'policy_default_rt_vpn'
option mark '0x8000/0xc000'
option lookup '8000'
option priority '1101'
option invert '1'
config rule6 'policy_direct_rt6'
option lookup 'main'
option suppress_prefixlength '0'
option priority '1100'
config rule6 'policy_default_rt_vpn6'
option mark '0x8000/0xc000'
option lookup '8000'
option priority '1101'
option invert '1'
config rule 'policy_default_rt_vpn_ts'
option lookup 'main'
option priority '1099'
option mark '0x80000/0xc0000'
option invert '0'
config rule 'policy_relay_lo_rt_lan'
option lookup '16800'
option in 'loopback'
option priority '1'
config interface 'wgserver'
option proto 'wgserver'
option config 'main_server'
option disabled '0'
root@GL-MT6000:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
option rebind_protection '0'
option filter_aaaa '1'
option enable_tftp '1'
option tftp_root '/tftp'
option dhcp_boot 'netboot.xyz.efi'
option noresolv '1'
option localuse '0'
list server '127.0.0.1#3053'
config dhcp 'lan'
option interface 'lan'
option dhcpv4 'server'
option force '1'
list ra_flags 'none'
option start '356'
option limit '101'
option ignore '0'
option leasetime '720m'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config domain
option name 'console.gl-inet.com'
option ip '192.168.1.1'
config domain
option name 'console.gl-inet.com'
option ip '::ffff:192.168.1.1'
config dhcp 'guest'
option interface 'guest'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'disabled'
option ra 'disabled'
config dhcp 'secondwan'
option interface 'secondwan'
option ignore '1'
root@GL-MT6000:~# cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
config zone
option name 'wan'
option output 'ACCEPT'
option forward 'REJECT'
option mtu_fix '1'
option input 'DROP'
option masq '1'
list network 'wan'
list network 'wan6'
list network 'wwan'
list network 'secondwan'
config forwarding
option src 'lan'
option dest 'wan'
option enabled '1'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config rule
option name 'Support-UDP-Traceroute'
option src 'wan'
option dest_port '33434:33689'
option proto 'udp'
option family 'ipv4'
option target 'REJECT'
option enabled 'false'
config include
option path '/etc/firewall.user'
config include 'nat6'
option path '/etc/firewall.nat6'
option reload '1'
config rule 'process_mark'
option name 'process_mark'
option dest '*'
option proto 'all'
option extra '-m owner --gid-owner 65533'
option target 'MARK'
option set_xmark '0x8000/0xc000'
config rule 'wan_in_conn_mark'
option name 'wan_in_conn_mark'
option src 'wan'
option dest '*'
option set_xmark '0x8000/0xc000'
option target 'MARK'
option enabled '0'
option extra '-m mark --mark 0x0/0x3f00 -j CONNMARK --set-xmark 0x8000/0xc000'
config rule 'lan_in_conn_mark_restore'
option name 'lan_in_conn_mark_restore'
option src 'lan'
option dest '*'
option set_xmark '0x8000/0xc000'
option target 'MARK'
option enabled '0'
option extra '-m connmark --mark 0x8000/0xc000 -j CONNMARK --restore-mark --nfmask 0xc000 --ctmask 0xc000'
config rule 'out_conn_mark_restore'
option name 'out_conn_mark_restore'
option dest '*'
option set_xmark '0x8000/0xc000'
option target 'MARK'
option enabled '0'
option extra '-m connmark --mark 0x8000/0xc000 -j CONNMARK --restore-mark --nfmask 0xc000 --ctmask 0xc000'
config include 'swap_wan_in_conn_mark'
option type 'script'
option reload '1'
option path '/etc/firewall.swap_wan_in_conn_mark.sh'
option enabled '0'
config zone
option name 'guest'
option forward 'REJECT'
option output 'ACCEPT'
option input 'REJECT'
list network 'guest'
config forwarding
option src 'guest'
option dest 'wan'
option enabled '1'
config rule
option name 'Allow-DHCP'
option src 'guest'
option target 'ACCEPT'
option proto 'udp'
option dest_port '67-68'
config rule
option name 'Allow-DNS'
option src 'guest'
option target 'ACCEPT'
option proto 'tcp udp'
option dest_port '53'
config include 'vpn_server_policy'
option type 'script'
option path '/etc/firewall.vpn_server_policy.sh'
option reload '1'
option enabled '1'
config rule 'process_mark_dns'
option name 'process_mark_dns'
option dest '*'
option proto 'all'
option extra '-m owner --gid-owner 453'
option target 'MARK'
option set_xmark '0x8000/0xc000'
config rule 'process_mark_stubby'
option name 'process_mark_stubby'
option dest '*'
option proto 'all'
option extra '-m owner --gid-owner 410'
option target 'MARK'
option set_xmark '0x8000/0xc000'
config rule 'process_explict_vpn'
option name 'process_explict_vpn'
option dest '*'
option proto 'all'
option extra '-m owner --gid-owner 20000'
option target 'MARK'
option set_xmark '0x20000/0x20000'
config include 'vpn_client_deal_leak'
option type 'script'
option reload '1'
option path '/etc/firewall.vpn_client_deal_leak.sh'
option enabled '1'
config include 'glblock'
option type 'script'
option path '/usr/bin/gl_block.sh'
option reload '1'
config redirect
option name 'GL-HTTP'
option proto 'tcp udp'
option dest_ip '192.168.1.4'
option enabled '1'
option dest 'lan'
option dest_port '80'
option src_dport '80'
option src 'wan'
config redirect
option name 'GL-HTTPS'
option proto 'tcp udp'
option dest_ip '192.168.1.4'
option enabled '1'
option dest 'lan'
option dest_port '443'
option src_dport '443'
option src 'wan'
config redirect
option name 'GL-HomeAssistant'
option proto 'tcp udp'
option dest_ip '192.168.1.5'
option enabled '1'
option dest 'lan'
option dest_port '8123'
option src_dport '8123'
option src 'wan'
config redirect
option enabled '1'
option dest_ip '192.168.1.4'
option dest 'lan'
option src 'wan'
option name 'GL-QBitTorrent'
option proto 'tcp udp'
option dest_port '6881'
option src_dport '6881'
config redirect
option enabled '1'
option src 'wan'
option dest 'lan'
option name 'GL-WireGuard'
option proto 'tcp udp'
option src_dport '13231'
option dest_port '13231'
option dest_ip '192.168.1.10'
config rule 'sambasharewan'
option src 'wan'
option dest_port '137 138 139 445'
option dest_proto 'tcpudp'
option target 'DROP'
config rule 'sambasharelan'
option src 'lan'
option dest_port '137 138 139 445'
option dest_proto 'tcpudp'
option target 'ACCEPT'
config rule 'glnas_ser'
option src 'wan'
option dest_port '6000-6002'
option dest_proto 'tcp'
option target 'DROP'
config rule 'webdav_wan'
option src 'wan'
option dest_port '6008'
option dest_proto 'tcp'
option target 'DROP'
config forwarding 'wgserver2wgclient'
option src 'wgserver'
option dest 'wgclient'
option enabled '0'
config forwarding 'wgserver2ovpnclient'
option src 'wgserver'
option dest 'ovpnclient'
option enabled '0'
config rule 'wgserver_allow'
option name 'wgserver_allow'
option target 'ACCEPT'
option src 'wan'
option proto 'udp'
option family 'ipv4'
option dest_port '51820'
option enabled '1'
config zone 'wgserver'
option name 'wgserver'
option output 'ACCEPT'
option mtu_fix '1'
option network 'wgserver'
option input 'DROP'
option masq '1'
option masq6 '1'
option enabled '1'
config forwarding 'wgserver2wan'
option src 'wgserver'
option dest 'wan'
option enabled '1'
config forwarding 'lan2wgserver'
option src 'lan'
option dest 'wgserver'
option enabled '1'
config rule 'wgserver_allow_dns'
option name 'wgserver_allow_dns'
option src 'wgserver'
option target 'ACCEPT'
option dest_port '53'
option enabled '1'
brada4
January 3, 2025, 1:34pm
4
Ask gl.inet to provide you with luci-proto-bonding or equivalent.
It appears you are using firmware that is not from the official OpenWrt project.
When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org ). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.
You may find that the best options are:
Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org ).
Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).
If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.
Ok, thanks, I just wrote on their forum.
system
Closed
January 15, 2025, 11:46am
6
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.