Router only offers a /62 in DHCVPv6 prefix adverts

I've been delegated a /56 IPv6 prefix from my ISP. My edge router gets these adverts okay, and is set to be a server for dhcpv6 and ra options for lan in /etc/config/dhcp. Downstream I have another router with reqprefix set to 60, and it asks for that in DHCPv6 Solicit requests. The edge router responds with a /62 in the DHCPv6 Advertise, which isn't much for a downstream router to play with. How can I get the edge router to offer a /60?

The edge router's /etc/config/dhcp is

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/'
        option nonwildcard '1'
        option localservice '1'
        option logqueries '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'eth0'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'eth1'

OpenWRT is 18.06.2 on an RPi 3B+

Sorry, this was an earlier version of
|Odhcpd gets wrong prefix from DHCPv6 SOLICIT messages 1 and I only posted this by mistake

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.