Router LEDs problem on asus RT-AC51U

Hello guys i install the 19.07 version on my router and now i can see only one blue light on my hardware ( Asus RT-AC51U) - the power.
i went trough the GUI and i found option for Led configuration. I need help with applying the correct settings so i can power up my lights for the wan, lan and wifi interfaces.
Also i checked trough the forum and i can see only people with the same problem last year in 18.06. release.

thanks in advance

1 Like

@kraskata, welcome to the community!

Can you show us what LED options are available to you on the menu?

hi lleachii,
please see the flowing pictures

OK. Simply assign the LED you desire to the activity you want.

For example, I set my WAN for receive on netdev for WAN (eth0.2 in my instance). For 2.4 WiFi, I use phy0tx.


thanks for the reply.
i have tried every single option from the gui but its unsuccessful.
this is from my current system file ;

config led
	option dev 'wlan1'
	option sysfs 'rt-ac51u:blue:wifi'
	option default '1'
	option trigger 'netdev'
	list mode 'link'
	list mode 'tx'
	list mode 'rx'
	option name '2.4 G'

config led
	option dev 'wlan0'
	option sysfs 'rt-ac51u:blue:wifi'
	option default '1'
	option trigger 'netdev'
	list mode 'link'
	list mode 'tx'
	list mode 'rx'
	option name '5G'

i dont have any options for example like "rt-ac51u:blue:wan" for the wan interface.

Could you please provide your "config led" ?

Hello @reinerotto this is currently from my configs

Screenshot from 2020-01-16 08-27-26

Same here, only Power LED working, 19.07.0

same, only power LED works and the settings make no difference, was same with v18 as with new 19.07.1

Know problem. I tried to activate GPIOs, but received:

root@OpenWrt:/sys/class/gpio# echo 1 > export
ash: write error: Resource busy

etc.. kernel log shows GPIOs:

[    0.633698] rt2880_gpio 10000600.gpio: registering 24 gpios
[    0.639155] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    0.645456] rt2880_gpio 10000688.gpio: registering 1 gpios
[    0.650784] rt2880_gpio 10000688.gpio: registering 1 irq handlers
[    0.863099] gpio-export gpio_export: 1 gpio(s) exported

They recently pushed a fix for the 2.4G WiFI LED on master branch.
You could try it with snapshot or build from source.
Here's the commit WiFi LED

Does anyone currently have any workable LEDs other than the PWR indicator?

My workaround for this problem:

If you want to enable the gpio's and with that the led's just change the value of the file "/sys/devices/platform/10000000.palmbus/10000600.gpio/gpiochip0/gpio/enable-leds/value" to 0.
To enable those permanently you have to add the following command to a script that runs while booting: echo 0 > "/sys/devices/platform/10000000.palmbus/10000600.gpio/gpiochip0/gpio/enable-leds/value". I just put the command to the last line of the start() method in the file "/etc/init.d/led".

1 Like

many thanks foxergy! It works on my unit also! Once set the value to zero the 5 leds associated with ethernet ports start blinking with trafic (exactly like the stock fw). The other three leds configurable for me are usb - power and 2.4 ghz wifi (that is mapped simply as wifi). Unfortunately the 5ghz led seems unavailable for now!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.