I had a working OpenWrt setup for 2 years with no issues but suddenly one night it stopped working and couldn't figure out what happened, so I posted here and got some suggestions about my PiHole messing up and change DNS to public ones and it was working after that for couple of weeks and stopped again yesterday night when the Xfinity modem restarted after which I am unable to fix it. So, I went ahead and reset the whole thing and installed a fresh latest firmware to setup from scratch but I am having so many weird things happen.
After first boot, LAN interface still shows the old Pihole DNS server even without me setting up anything
Ping test returns 100% packet loss
One time package update worked but stopped after that
Connected to the router through LAN cable but still can't get internet to work on the client laptop
Basic setup of WiFi radios and connecting to them also not giving any internet
Added 1.1.1.1, 4.4.4.4 at Network > DHCP and DNS > Forwarders but still no internet
While you didn't share your network config, I'm going to guess that the problem is that you've got the same subnet defined on the upstream (wan) as the lan. If both interfaces have the same or overlapping subnets, routing will break.
You need to change one or the other.
Ideally you can remove the upstream router entirely, but if it is a combo modem+router, you'll need to see if you can set the device into bridge mode (disabling its onboard routing + wifi) so that it passes your ISP issued IP address to the wan of your OpenWrt router.
If that's not possible, the next best option is to change the IP address of the OpenWrt lan. I'd recommend an address like 192.168.5.1.
SSH is fine. It will scrub everything. This is the first time I've seen something, other than a RPi, fail to completely clear settings after a fresh install but the result looks the same: something from the last config persisted.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
You are right on the subnet part as my AT&T router is set to 192.168.1.1 and I need it to make some other devices connected directly to AT&T router to work and have the AT&T WiFi as backup. So, I have always used the last option you mentioned and have the OpenWrt router's IP set to 192.168.2.1 and did the same after current reset also but but that didn't help much
config defaults
option syn_flood 1
option input REJECT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option dest_port 546
option family ipv6
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT
# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT
# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP
# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp
# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp
### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT
#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
To be clear, the connection between the Xfinity router and the OpenWrt router is LAN > WAN, right? And please confirm that the intent is for the "personal devices" to exist on a separate network relative to the NAS and pihole and such... is that correct?
look at the terminal output that you get when you enter:
cat /etc/config/firewall
Then look at the output, specifically in the lan section that I called out. Do all of the lines have ' single quotes for the last value, or is it only as I pointed out in the above post?