Router is connected to WAN successfully, but every website aside from Google fails to load

Hey there! It seems I'm dealing with a particularly strange issue.

Since last night (about 22 hours ago from the writing of this post), the router I was using with AdguardHome and Unbound (Raspberry Pi 4B 4GB) has seemingly begun to drop all connectivity both from itself and from the other devices on the network to anything that isn't or

I am able to perform a dig query without issue to any website, but pings are constantly failing even after rebooting the network interface, the network service and the router itself.

From what I can see from tcpdump's output, the router is able to send keep-alive packages to the Zerotier and Wireguard networks I have configured, but anything aside from what's showing in the Network Interfaces tab never actually reaches the WAN interface.

At first I thought this may be because of filesystem corruption, so yesterday I wiped the mSD card and started over, but tonight the same problem has appeared for seemingly no reason even after working correctly for around 16 hours of no downtime.

What sort of logs should I look into to start diagnosing the issue?

and if you disable wireshark and zerotier ?

Same result, though now it seems that the issue is coming and going.

So far I've seen it happen 3 times, first at 3AM, then at 1AM and lastly again at 2AM the same way, but the last two times the internet connection has returned in about an hour compared to the first time that took 4 hours without any changes in configuration or network topography, so I'm starting to suspect it might be a problem with my ISP, though I'm still not sure how Google keeps working under those conditions.

Have you tried using an alternative router (not openwrt) if you suspect ISP?

So far I haven't been able to catch the problem using my computer to dial directly into the GPON ONT through PPPoE, but I was able to catch that services using AWS would fail randomly a few days ago. As of now the failures haven't been showing up as much, so I'll keep an eye out for a few days then close the thread, since I haven't found a way to reliably reproduce the issue.

In any case, thanks for the help!

Google often has caching servers at ISP premises. Maybe your ISP faces problems with his uplinks...

Or there is something wrong with your MTU and everything with large TCP packets fails. Google uses UDP. But one would expect this be permanent problem.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.