Router connected with USB tether but wifi not working

Hello team,

I've successfully enabled USB tethering on my router and the router is connected to the internet (ping/updates successful) however when I try to broadcast wifi:

My personal phone Note 10+ (different to the tethered phone) states "couldn't get an IP address"
My PC and other phones can connect to the network however there is no internet coming through

Have searched but don't seem to be able to find anyone with similar issues. Am looking to create my first network but very novice when it comes to things like this so I don't really have any idea what I'm doing so any assistance would be much appreciated!

post your /etc/config/network

Do you have a link with instructions on how to show these?

winscp to the router, edit/view the file.
or ssh to it, and run cat /etc/config/network

Ah thank you

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd29:cfba:02e7::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'c2:56:27:b9:68:61'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option ifname 'usb0'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option ifname 'usb0'

config interface 'wwan'
        option proto 'dhcp'

config interface 'USBTether'
        option proto 'dhcp'
        option device 'usb0

post your /etc/config/firewall too.

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option input 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option forward 'ACCEPT'
        list network 'USBTether'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled 'false'

config include
        option path '/etc/firewall.user'

root@OpenWrt:~#         option netmask '255.255.255.0'

These settings were copied from the guide linked here, configured through LUCI:

my personal phone (note 10+) which cannot get an IP address suggests setting a shorter IP address lease time in the router's DHCP if that helps?

this looks weird ...remove all the w*

Remove everything about USBtether you don't need it. Make usb0 the device of the wan network instead of wan, which is the wan Ethernet port. That port will go unused for now. Remove the option ifname from network interfaces, that is the deprecated old syntax.

Edit: and what @frollic said, the lan firewall zone should just be lan. The wan firewall zone should be wan (and wan6 if you want to try to use IPv6). In other words default configuration. Resetting the whole router to defaults and starting over is also viable if you have access to a wired network to readily re-install the USB tether drivers.

At this point you should have Internet on your PC wired to the LAN port. If you start up a wifi AP attached to the lan network, it should also work.

1 Like

Done, removed from lan firewall setting
Still doesn't want to connect. Should I be restarting after changes?

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option input 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option forward 'ACCEPT'
        list network 'USBTether'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled 'false'

config include
        option path '/etc/firewall.user'

never hurts to restart.

if it doesn't work, reset, as @mk24 said.

1 Like

Yes I'd do that:

  • Reset to defaults
  • Connect to Internet and install USB tether drivers
  • Connect smartphone and turn on tethering, confirm usb0 is created
  • Change wan & wan6 network interface device to usb0
  • Configure wifi AP on lan
2 Likes

Thanks guys, I might try the reset. Do you have a link with instructions to * Change wan & wan6 network interface device to usb0?

they're in the wiki your posted yourself

1 Like

Ah! seen..

Changed both to usb0, rebooted router but still not working.
Why would the wiki recommend creating a new interface if changing device could possibly have been the solution to my issue?

Anyway, will reset and see where that gets me.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd29:cfba:02e7::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'c2:56:27:b9:68:61'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'usb0'
        option device 'usb0'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'usb0'
        option device 'usb0'
        option reqaddress 'try'
        option reqprefix 'auto'

config interface 'wwan'
        option proto 'dhcp'

config interface 'USBTether'
        option proto 'dhcp'
        option device 'usb0'

if you keep the original wan, as it is, it could be used for a wired internet connection, in parallell, or the cell phone wan as fail over.

1 Like

You did not delete the USBTether interface or remove the option ifname lines though.

1 Like

Thanks guys, the reset worked and am using my new wireless network to type this. :slightly_smiling_face:
Changed the device of wan and wan6 to usb0 after installing the tethering packages.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.