Router can connect to the internet but wireless devices can't

Hi all,
I'm a newbie here and I'm trying to set up my old router to practice ( Huawei EchoLife HG553 aka Vodafone station, which supports the latest release of openwrt). My goal is to connect smartphone via USB or K4203 or K3765 usb sticks to give this router internet capabilities (no ADSL). I managed to install openWRT successfully and set up a wan for each device. Everything works fine only if I'm connected through LAN (router has internet). Mobile devices get wrong IP and DNS is not set.
Here is the ipconfig of the Lan connected PC.
image
I think the problem is here but I can't figure out how to solve it. Hope that you can clear my mind over it. Thank you very much in advance.

It seems like the wifi devices are not seeing the dhcp. Is your router’s wireless interface bridged to br-lan?

Mmm, I think it is correctly bridged... Maybe I should post all the config for more details?
Here's the LuCi interface for wireless:

Yes it is bridged. Do post your network config.

There you go:


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde4:62fb:6f9e::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.101'
        option device 'eth0.1'
        option nat '1'

config switch
        option name 'switch0'
        option reset '1'
        option enable '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '5t 0 1 2'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option description 'WAN'
        option ports '5t 3'

config interface 'WAN'
        option device 'eth0.2'
        option proto 'dhcp'

config switch_vlan
        option device 'switch0'

config interface 'LTEWAN'
        option proto '3g'
        option service 'umts'
        option ipv6 'auto'
        option device '/dev/ttyUSB0'
        option apn 'iliad'

config interface '3GWAN'
        option proto 'dhcp'
        option device 'eth1'

config interface 'MOBILE'
        option device 'usb0'
        option proto 'dhcp'                                        

You are mixing (wrongly) the old and the new syntax. If you want to use the new syntax:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.101'

If you prefer the old syntax, first remove the config device section:

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.101'
        option netmask '255.255.255.0'
        option ip6assign '60'

If you need to activate masquerading on the lan zone, the correct place is in /etc/config/firewall.

2 Likes

Mmmm this fixed the problem. maybe initially I used the terminal with old syntax, then using luci, I think it overwritten the existing settings using the new one...
Thank you very much!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.