Router behind router: ?error? on WAN6

Hello,
I have installed an openwrt router on my network for many years, but after an update (a few years ago), i configured it incorrectly, today I don't understand how I configured it (it still works) and I am sure there is an error with WAN6 (using DHCPv6 don't work), can you help me correct it? thank you

My setup is with 2 networks:
ISP router (DHCP on ,NAT on) 192.168.1.1
V
Openwrt router (DHCP on, NAT on) 192.168.2.1
V
switch 192.168.2.x

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd38:3a8e:37fb::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option gateway '192.168.1.1'

config interface 'wan'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'static'
        option netmask '255.255.255.0'
        list dns '8.8.8.8'
        list dns '8.8.4.4'
        option ipaddr '192.168.1.254'
        option gateway '192.168.1.1'

config interface 'wan6'
        option ifname '@wan'
        option _orig_ifname '@wan'
        option _orig_bridge 'false'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.2'
        option gateway '192.168.1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

Why do you have ipv4 addresses in the wan6 section

2 Likes

because it work only with an ipv4, when i set DHCPv6 client, i can't reach internet.
maybe it's a bridge problem?

ok, it's when I change my WAN6 client to DHCPv6 and save, I lose the connection.
solution: I had to restart WAN also after making the change and save to recover the connection

thank you

That doesn't look right

Did you test ipv6 from a computer connected to the router

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.