Router as Wi-Fi extender / repeater / bridge configuration (DHCP not working)

Hi,

I have a DIR825 with 16MB flash and 128MB of ram with WNDR3800 firmware.
I have configured the router to work as a WIFI range extender in bridge mode. The configuration works fine when I connect it to the main router and the PCs are able to get IPs automatically without any issue.
The problem is, I also have a WIFI range extender, a TP-Link RE300 with the default firmware and when I connect the DIR825 via WIFI to the RE300, the PCs connected to it do not get an IP via DHCP.

This is the configuration I have.


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda5:dc91:3ce2::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config device
	option name 'eth0'
	option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
	option blinkrate '2'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5'

config switch_port
	option device 'switch0'
	option port '1'
	option led '6'

config switch_port
	option device 'switch0'
	option port '2'
	option led '9'

config switch_port
	option device 'switch0'
	option port '5'
	option led '2'

config interface 'wwan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.254'
	list dns '192.168.1.254'
	option ipaddr '192.168.1.2'

config interface 'BRIDGE'
	option proto 'relay'
	list network 'lan'
	list network 'wwan'
	option ipaddr '192.168.1.2'


config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:11.0'
	option htmode 'HT40'
	option channel 'auto'
	option txpower '20'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:12.0'
	option htmode 'HT40'
	option txpower '20'
	option cell_density '0'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'sta'
	option network 'wwan'
	option ssid 'RE300'
	option encryption 'psk2'
	option key '************'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '************'
	option encryption 'psk2'
	option key '************'
	option network 'lan'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid '************'
	option encryption 'psk2'
	option key '************'
	option network 'lan'



config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'
	list ra_flags 'none'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


Use relayd & stabridge

remark : ipaddr is 192.168.2.182 and not 1.182 in my exemple

diable DHCP
the DHCP address is given on the WIFI master side by the main router 192.168.1.xxx

Hi,

Thank you for the reply.

I have DCHP set with "ignore" so, it should be disabled.
This configuration works fine when I connect the DIR825 to the main internet provider router, the problem is when I connect it to the wifi repeater "RE300". Connected to it, the computers are not able to get an IP address via DHCP. It's like the RE300 is somehow blocking DHCP, but the computers connected to the RE300 are able to get IPs fine.

Isn't it necessary to define the same IP in the bridge interface as in the wwan?
reading here:https://openwrt.org/docs/guide-user/network/wifi/relay_configuration
is says: "This “Local IPv4 address” (empty in above screen shot, sorry, I don't have enough rights to upload a new screen shot) needs to match the IP address assigned by the Wifi-network (eg. from 192.168.1.0/24 range"

Thank you.

The range extenders do something similar to relayd, if not exactly relayd, inside. So you have double relayd which is something that may not work at all.

Maybe there is a hidden 192.168.2.0 network inside the RE300 which is conflicting. Try using an obscure IP for your hidden network.

For your wifi ->
You can remove AP and use only wwan for radio1 for test

If you connected your computer in WIFI you do not connect to the ap.
You must always connect to the master WIFI RE300
Extender/relay is transparent with the same SSID

For the lan ->
1 - BRIDGE remove ip not used
2 - Use as me 192.168.2.xxx for lan
3 - Port wan can used as a normal lan

a config without DSA with my old MT-300 used as a printer server ( repeater with my BOX )

network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5a:f069:7d4c::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.230'
	option delegate '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 1 0'

config interface 'STABRIDGE'
	option proto 'relay'
	list network 'lan'
	list network 'wwan'
	option delegate '0'

config interface 'wwan'
	option proto 'static'
	option ipaddr '192.168.1.230'
	option netmask '255.255.255.0'
	list dns '192.168.1.1'
	list dns '8.8.8.8'
	option delegate '0'
	option gateway '192.168.1.1'


wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'MT300N-V2-230'
	option encryption 'psk2'
	option key '0123456789'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'sta'
	option network 'wwan'
	option ssid 'Livebox-954A'
	option key '023456789'
	option encryption 'psk2'


1 Like

I gave up on using relaybridge.
How can I set it up as a wifi client and use DHCP to advertise a different network?
I'm confused if I should set up WAN interface or not.