Routed Client Doc Erroneous?


#1

Re: OpenWrt Project: Routed Client page https://openwrt.org/docs/guide-user/network/routedclient

Problem: iwlist scan fails

Router Details: Linksys WRT1900ACS V2, OpenWrt LEDE 17.01.5 installed and reset to default values

Following the preliminary instructions given near the top of the page --
RoutedClient-iwlist

PuTTY returns --
iwlist-fail

(Here I assume that the bullet notes such as "Remove the disable 1 option from the wireless configuration" refer to the commands listed above and are not instructions of further things to do before executing iwlist scan.)


Routed Client Experiment #1: Is this a Routed Client?
#2

iwlist has been replaced by iw, see
https://openwrt.org/docs/guide-developer/networking/network.interfaces#old_and_deprecated_utilities_for_networking_and_traffic_control

https://openwrt.org/docs/guide-user/network/routedclient should be updated accordingly.


#3

There is also no need to put the device in station mode anymore nowadays, a mere iwinfo radio0 scan should suffice, regardless of the state the radio is in.


#5

When I try to thank people individually I get a message to the effect it is redundant and I should post something different. So let me try this.

Thank you tmomas and jow.

Perhaps I should not be wasting forum drive space thanking people and just use the thumbs up and/or solved flags in the future?

In this thread both tmomas and jow share the solution since they both provide informative details, but I can only flag one as a solution.


closed #6

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.