Routed AP configuration. Adding DHCPv6 doesn't work

Hello,
I got a TP-Link RE650 running OpenWRT as Routed AP. I followed the official tutorial and the IP4 setup kind of works. (192.168.0.m-Router) -> (SwitchVlan1) -> (RE650-OpenWRT) -> (192.168.1.n-SwitchVlan2/WLAN). The only change on my old router was adding an ip4-static-route to OpenWRT. I am still experiencing that the radios (radio0 and radio1 for both wifi devices) are randomly getting disabled and they are only occasionally powering up. Maybe you spot a problem there. I have to reload network service multiple times till the radios get assigned.

I don't know much about IPv6 but I want to get it running too. My internet connection is dual stack. I enabled prefix delegation on my old router. My first step on OpenWRT was to add a DHCPv6 interface on the same device as the DHCP Client and add it to the same firewall zone. After powering the new interface up it got a IPv6 and IPv6-PD address starting with 2a02 with a prefix length of 64 respectively 62. When going to diagnostics tab and pinging on ip6 it always gets 100% packet loss. Can you please help me with setting IPv6 up? I tried to ignore the failed test and set everything to 'relay mode' in my wlan interface under dhcp ipv6 configuration. In that case the interface doesn't come up at all. I tried to add a new firewall zone for IPv6 which has masquerade = off but this was not successful.

This is the system log when reenabling the DHCPv6 interface:

Wed Oct 23 23:13:12 2019 daemon.notice netifd: Interface 'lan6' is now down
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: reading /tmp/resolv.conf.auto
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: using local addresses only for domain test
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: using local addresses only for domain onion
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: using local addresses only for domain localhost
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: using local addresses only for domain local
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: using local addresses only for domain invalid
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: using local addresses only for domain bind
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: using local addresses only for domain lan
Wed Oct 23 23:13:12 2019 daemon.info dnsmasq[1686]: using nameserver 192.168.0.1#53

Wed Oct 23 23:13:36 2019 daemon.notice netifd: Interface 'lan6' is setting up now
Wed Oct 23 23:13:40 2019 daemon.warn netifd: You have delegated IPv6-prefixes but haven't assigned them to any interface. Did you forget to set option ip6assign on your lan-interfaces?
Wed Oct 23 23:13:40 2019 daemon.notice netifd: Interface 'lan6' is now up
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: reading /tmp/resolv.conf.auto
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using local addresses only for domain test
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using local addresses only for domain onion
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using local addresses only for domain localhost
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using local addresses only for domain local
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using local addresses only for domain invalid
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using local addresses only for domain bind
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using local addresses only for domain lan
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using nameserver 192.168.0.1#53
Wed Oct 23 23:13:40 2019 daemon.info dnsmasq[1686]: using nameserver fd00::9a9b:cbff:feca:cb1e#53
Wed Oct 23 23:13:40 2019 user.notice firewall: Reloading firewall due to ifup of lan6 (eth0.1)
Wed Oct 23 23:13:41 2019 daemon.warn odhcpd[950]: A default route is present but there is no public prefix on lan thus we don't announce a default route!

The configuration was done with luci. I don't understand everything from the files.
network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0a:1e56:17ad::/48'

config interface 'lan'
	option ifname 'eth0.1'
	option proto 'dhcp'

config interface 'lan6'
	option ifname 'eth0.1'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config interface 'wlan'
	option proto 'static'
	option type 'bridge'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.1'
	option delegate '0'
	option ifname 'eth0.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '6t 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '6t 0t'

dhcp


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'wlan'
	option leasetime '12h'
	option interface 'wlan'
	option start '150'
	option limit '100'

firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config forwarding
	option src 'lan'
	option dest 'wan'

config include
	option path '/etc/firewall.user'

config zone
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'LAN'
	option output 'ACCEPT'
	option masq '1'
	option mtu_fix '1'
	option network 'lan lan6'

config zone
	option network 'wlan'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'WLAN'
	option output 'ACCEPT'

config forwarding
	option dest 'LAN'
	option src 'WLAN'

config forwarding
	option dest 'WLAN'
	option src 'LAN'

wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'wlan'
	option mode 'ap'
	option ssid 'blabla'
	option encryption 'psk2+ccmp'
	option key 'blabla'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'VHT80'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'wlan'
	option mode 'ap'
	option ssid 'blabla'
	option encryption 'psk2+ccmp'
	option key 'blabla'
	list maclist 'blabla'
	option macfilter 'deny'

You have a general problem here. The ethernet port is now assigned to the LAN interface, but you are still running DHCP server and announcing IPv6 RAs.
My opinion is to restore factory defaults, then go for DumbAP. Do you need routedAP for some specific reason?

Thank you for your response!
I would like to use two separated subnets for ip4. After setup I want to restrict the communication from 192.168.0.m to 192.168.1.n.

On the LAN port (eth0) there is a vlan-capable managed switch which separates the ports to eth0.1 and eth0.2. eth0.1 is used for the communication between the old router and OpenWRT. eth0.2 is used for communication between OpenWRT and it's 192.168.1.n subnet. The virtual interface wlan in OpenWRT is a bridge between eth0.2, wlan0 and wlan1.

Is there still a problem in my setup?

Yes, because the LAN interface runs dhcp servers.
You could make some corrections here and make it work, however I think it would be much easier to stick to the default OpenWrt configuration of LAN and WAN interfaces. Like this it will work out of the box, and you only need to reassign the physical interfaces that belong to each uci interface. (eth0.1 to LAN and eth0.2 to WAN)

1 Like

I think you mean eth0.1 to WAN and eth0.2 to LAN. eth0.1 is connected to the gateway router. eth0.2 is connected to the user devices.

I just reseted OpenWRT and started all over again.
The first thing I want to do is installing luci and connecting to the old router. I have to set my PC to 192.168.1.2 so I can ssh to OpenWRT 192.168.1.1. I used to change the static ip to dhcp and started configuring from that point. But this time I looked deeper into the files. Why are there firewall rules configured for wan when there is no wan interface? My factory settings are (lan and wan zone in firewall) and (lan interface which is a bridge of both wifi and eth0.1).

I set my configuration for vlan and changed lan interface to eth0.2.

For WAN at first I tried adding this to network:

config interface 'wan'
	option ifname 'eth0.1'
	option proto 'dhcp'
	option ip6assign '60'

I got a IP4 and IP6 with that. In diagnostics I could ping IP4 but IP6 got me 'permission denied'.
My second try was to add this instead:

config interface 'wan'
	option ifname 'eth0.1'
	option proto 'dhcp'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

With that setup I got an IPv4, IPv6 and IPv6-PD. Ping with IPv6 is still:

5 packets transmitted, 0 packets received, 100% packet loss

Could you post the configs and the troubleshooting commands? Copy and paste the whole with the backslashes.

uci show network;uci show wireless; \
uci show firewall; uci show dhcp; \
ip -4 addr ; ip -4 ro ; ip -4 ru; \
ip -6 addr ; ip -6 ro ; ip -6 ru; \
iptables-save; ip6tables-save; \
head -n -0 /etc/firewall.user; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*

thank you very much!

root@OpenWrt:~# uci show network;uci show wireless; \
> uci show firewall; uci show dhcp; \
> ip -4 addr ; ip -4 ro ; ip -4 ru; \
> ip -6 addr ; ip -6 ro ; ip -6 ru; \
> iptables-save; ip6tables-save; \
> head -n -0 /etc/firewall.user; \
> ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd78:07ef:f495::/48'
network.wan=interface
network.wan.ifname='eth0.1'
network.wan.proto='dhcp'
network.wan6=interface
network.wan6.ifname='@wan'
network.wan6.proto='dhcpv6'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0.2'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].vid='1'
network.@switch_vlan[0].ports='6t 0t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].vid='2'
network.@switch_vlan[1].ports='6t 0t'
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.channel='11'
wireless.radio0.hwmode='11g'
wireless.radio0.path='pci0000:00/0000:00:00.0/0000:01:00.0'
wireless.radio0.htmode='HT20'
wireless.radio0.disabled='1'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid='OpenWrt'
wireless.default_radio0.encryption='none'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.channel='36'
wireless.radio1.hwmode='11a'
wireless.radio1.path='pci0000:00/0000:00:01.0/0000:02:00.0'
wireless.radio1.htmode='VHT80'
wireless.radio1.disabled='1'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='OpenWrt'
wireless.default_radio1.encryption='none'
firewall.@defaults[0]=defaults
firewall.@defaults[0].syn_flood='1'
firewall.@defaults[0].input='ACCEPT'
firewall.@defaults[0].output='ACCEPT'
firewall.@defaults[0].forward='REJECT'
firewall.@zone[0]=zone
firewall.@zone[0].name='lan'
firewall.@zone[0].network='lan'
firewall.@zone[0].input='ACCEPT'
firewall.@zone[0].output='ACCEPT'
firewall.@zone[0].forward='ACCEPT'
firewall.@zone[1]=zone
firewall.@zone[1].name='wan'
firewall.@zone[1].network='wan' 'wan6'
firewall.@zone[1].input='REJECT'
firewall.@zone[1].output='ACCEPT'
firewall.@zone[1].forward='REJECT'
firewall.@zone[1].masq='1'
firewall.@zone[1].mtu_fix='1'
firewall.@forwarding[0]=forwarding
firewall.@forwarding[0].src='lan'
firewall.@forwarding[0].dest='wan'
firewall.@rule[0]=rule
firewall.@rule[0].name='Allow-DHCP-Renew'
firewall.@rule[0].src='wan'
firewall.@rule[0].proto='udp'
firewall.@rule[0].dest_port='68'
firewall.@rule[0].target='ACCEPT'
firewall.@rule[0].family='ipv4'
firewall.@rule[1]=rule
firewall.@rule[1].name='Allow-Ping'
firewall.@rule[1].src='wan'
firewall.@rule[1].proto='icmp'
firewall.@rule[1].icmp_type='echo-request'
firewall.@rule[1].family='ipv4'
firewall.@rule[1].target='ACCEPT'
firewall.@rule[2]=rule
firewall.@rule[2].name='Allow-IGMP'
firewall.@rule[2].src='wan'
firewall.@rule[2].proto='igmp'
firewall.@rule[2].family='ipv4'
firewall.@rule[2].target='ACCEPT'
firewall.@rule[3]=rule
firewall.@rule[3].name='Allow-DHCPv6'
firewall.@rule[3].src='wan'
firewall.@rule[3].proto='udp'
firewall.@rule[3].src_ip='fc00::/6'
firewall.@rule[3].dest_ip='fc00::/6'
firewall.@rule[3].dest_port='546'
firewall.@rule[3].family='ipv6'
firewall.@rule[3].target='ACCEPT'
firewall.@rule[4]=rule
firewall.@rule[4].name='Allow-MLD'
firewall.@rule[4].src='wan'
firewall.@rule[4].proto='icmp'
firewall.@rule[4].src_ip='fe80::/10'
firewall.@rule[4].icmp_type='130/0' '131/0' '132/0' '143/0'
firewall.@rule[4].family='ipv6'
firewall.@rule[4].target='ACCEPT'
firewall.@rule[5]=rule
firewall.@rule[5].name='Allow-ICMPv6-Input'
firewall.@rule[5].src='wan'
firewall.@rule[5].proto='icmp'
firewall.@rule[5].icmp_type='echo-request' 'echo-reply' 'destination-unreachable' 'packet-too-big' 'time-exceeded' 'bad-header' 'unknown-header-type' 'router-solicitation' 'neighbour-solicitation' 'router-advertisement' 'neighbour-advertisement'
firewall.@rule[5].limit='1000/sec'
firewall.@rule[5].family='ipv6'
firewall.@rule[5].target='ACCEPT'
firewall.@rule[6]=rule
firewall.@rule[6].name='Allow-ICMPv6-Forward'
firewall.@rule[6].src='wan'
firewall.@rule[6].dest='*'
firewall.@rule[6].proto='icmp'
firewall.@rule[6].icmp_type='echo-request' 'echo-reply' 'destination-unreachable' 'packet-too-big' 'time-exceeded' 'bad-header' 'unknown-header-type'
firewall.@rule[6].limit='1000/sec'
firewall.@rule[6].family='ipv6'
firewall.@rule[6].target='ACCEPT'
firewall.@rule[7]=rule
firewall.@rule[7].name='Allow-IPSec-ESP'
firewall.@rule[7].src='wan'
firewall.@rule[7].dest='lan'
firewall.@rule[7].proto='esp'
firewall.@rule[7].target='ACCEPT'
firewall.@rule[8]=rule
firewall.@rule[8].name='Allow-ISAKMP'
firewall.@rule[8].src='wan'
firewall.@rule[8].dest='lan'
firewall.@rule[8].dest_port='500'
firewall.@rule[8].proto='udp'
firewall.@rule[8].target='ACCEPT'
firewall.@include[0]=include
firewall.@include[0].path='/etc/firewall.user'
dhcp.@dnsmasq[0]=dnsmasq
dhcp.@dnsmasq[0].domainneeded='1'
dhcp.@dnsmasq[0].boguspriv='1'
dhcp.@dnsmasq[0].filterwin2k='0'
dhcp.@dnsmasq[0].localise_queries='1'
dhcp.@dnsmasq[0].rebind_protection='1'
dhcp.@dnsmasq[0].rebind_localhost='1'
dhcp.@dnsmasq[0].local='/lan/'
dhcp.@dnsmasq[0].domain='lan'
dhcp.@dnsmasq[0].expandhosts='1'
dhcp.@dnsmasq[0].nonegcache='0'
dhcp.@dnsmasq[0].authoritative='1'
dhcp.@dnsmasq[0].readethers='1'
dhcp.@dnsmasq[0].leasefile='/tmp/dhcp.leases'
dhcp.@dnsmasq[0].resolvfile='/tmp/resolv.conf.auto'
dhcp.@dnsmasq[0].nonwildcard='1'
dhcp.@dnsmasq[0].localservice='1'
dhcp.lan=dhcp
dhcp.lan.interface='lan'
dhcp.lan.start='100'
dhcp.lan.limit='150'
dhcp.lan.leasetime='12h'
dhcp.lan.ra_slaac='1'
dhcp.lan.ra_flags='managed-config' 'other-config'
dhcp.lan.ra='relay'
dhcp.lan.dhcpv6='relay'
dhcp.lan.ndp='relay'
dhcp.wan=dhcp
dhcp.wan.interface='wan'
dhcp.wan.ignore='1'
dhcp.odhcpd=odhcpd
dhcp.odhcpd.maindhcp='0'
dhcp.odhcpd.leasefile='/tmp/hosts/odhcpd'
dhcp.odhcpd.leasetrigger='/usr/sbin/odhcpd-update'
dhcp.odhcpd.loglevel='4'
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
3: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
5: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.0.3/24 brd 192.168.0.255 scope global eth0.1
       valid_lft forever preferred_lft forever
default via 192.168.0.1 dev eth0.1  src 192.168.0.3
192.168.0.0/24 dev eth0.1 scope link  src 192.168.0.3
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::9ada:c4ff:fe92:6086/64 scope link
       valid_lft forever preferred_lft forever
3: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:908:1139:7f7c::1/62 scope global dynamic
       valid_lft 6978sec preferred_lft 3378sec
    inet6 fd78:7ef:f495::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::9ada:c4ff:fe92:6086/64 scope link
       valid_lft forever preferred_lft forever
5: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:908:1139:7f60:9ada:c4ff:fe92:6086/64 scope global dynamic
       valid_lft 6975sec preferred_lft 3375sec
    inet6 fe80::9ada:c4ff:fe92:6086/64 scope link
       valid_lft forever preferred_lft forever
default from 2a02:908:1139:7f60::/64 via fe80::9a9b:cbff:feca:cb1e dev eth0.1  metric 512
default from 2a02:908:1139:7f7c::/62 via fe80::9a9b:cbff:feca:cb1e dev eth0.1  metric 512
2a02:908:1139:7f60::/59 from 2a02:908:1139:7f60::/64 via fe80::9a9b:cbff:feca:cb1e dev eth0.1  metric 512
2a02:908:1139:7f60::/59 from 2a02:908:1139:7f7c::/62 via fe80::9a9b:cbff:feca:cb1e dev eth0.1  metric 512
2a02:908:1139:7f60::/64 dev eth0.1  metric 256
2a02:908:1139:7f7c::/64 dev br-lan  metric 1024
unreachable 2a02:908:1139:7f7c::/62 dev lo  metric 2147483647  error -148
fd78:7ef:f495::/64 dev br-lan  metric 1024
unreachable fd78:7ef:f495::/48 dev lo  metric 2147483647  error -148
fe80::/64 dev eth0  metric 256
fe80::/64 dev eth0.1  metric 256
fe80::/64 dev br-lan  metric 256
anycast 2a02:908:1139:7f60:: dev eth0.1  metric 0
anycast 2a02:908:1139:7f7c:: dev br-lan  metric 0
anycast fd78:7ef:f495:: dev br-lan  metric 0
anycast fe80:: dev eth0.1  metric 0
anycast fe80:: dev eth0  metric 0
anycast fe80:: dev br-lan  metric 0
ff00::/8 dev eth0  metric 256
ff00::/8 dev br-lan  metric 256
ff00::/8 dev eth0.1  metric 256
0:      from all lookup local
32766:  from all lookup main
4200000000:     from 2a02:908:1139:7f7c::1/62 iif br-lan lookup unspec unreachable
4200000001:     from all iif lo lookup unspec 12
4200000003:     from all iif br-lan lookup unspec 12
4200000005:     from all iif eth0.1 lookup unspec 12
4200000005:     from all iif eth0.1 lookup unspec 12
# Generated by iptables-save v1.8.3 on Thu Oct 24 12:35:43 2019
*nat
:PREROUTING ACCEPT [88:11393]
:INPUT ACCEPT [46:2582]
:OUTPUT ACCEPT [53:3739]
:POSTROUTING ACCEPT [11:729]
:postrouting_lan_rule - [0:0]
:postrouting_rule - [0:0]
:postrouting_wan_rule - [0:0]
:prerouting_lan_rule - [0:0]
:prerouting_rule - [0:0]
:prerouting_wan_rule - [0:0]
:zone_lan_postrouting - [0:0]
:zone_lan_prerouting - [0:0]
:zone_wan_postrouting - [0:0]
:zone_wan_prerouting - [0:0]
-A PREROUTING -m comment --comment "!fw3: Custom prerouting rule chain" -j prerouting_rule
-A PREROUTING -i br-lan -m comment --comment "!fw3" -j zone_lan_prerouting
-A PREROUTING -i eth0.1 -m comment --comment "!fw3" -j zone_wan_prerouting
-A POSTROUTING -m comment --comment "!fw3: Custom postrouting rule chain" -j postrouting_rule
-A POSTROUTING -o br-lan -m comment --comment "!fw3" -j zone_lan_postrouting
-A POSTROUTING -o eth0.1 -m comment --comment "!fw3" -j zone_wan_postrouting
-A zone_lan_postrouting -m comment --comment "!fw3: Custom lan postrouting rule chain" -j postrouting_lan_rule
-A zone_lan_prerouting -m comment --comment "!fw3: Custom lan prerouting rule chain" -j prerouting_lan_rule
-A zone_wan_postrouting -m comment --comment "!fw3: Custom wan postrouting rule chain" -j postrouting_wan_rule
-A zone_wan_postrouting -m comment --comment "!fw3" -j MASQUERADE
-A zone_wan_prerouting -m comment --comment "!fw3: Custom wan prerouting rule chain" -j prerouting_wan_rule
COMMIT
# Completed on Thu Oct 24 12:35:43 2019
# Generated by iptables-save v1.8.3 on Thu Oct 24 12:35:43 2019
*mangle
:PREROUTING ACCEPT [3053:2012246]
:INPUT ACCEPT [648:75192]
:FORWARD ACCEPT [2381:1934514]
:OUTPUT ACCEPT [716:304917]
:POSTROUTING ACCEPT [3097:2239431]
-A FORWARD -o eth0.1 -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
COMMIT
# Completed on Thu Oct 24 12:35:43 2019
# Generated by iptables-save v1.8.3 on Thu Oct 24 12:35:43 2019
*filter
:INPUT ACCEPT [0:0]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [0:0]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
-A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
-A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
-A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
-A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
-A INPUT -i eth0.1 -m comment --comment "!fw3" -j zone_wan_input
-A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
-A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
-A FORWARD -i eth0.1 -m comment --comment "!fw3" -j zone_wan_forward
-A FORWARD -m comment --comment "!fw3" -j reject
-A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
-A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
-A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
-A OUTPUT -o eth0.1 -m comment --comment "!fw3" -j zone_wan_output
-A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
-A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp-port-unreachable
-A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
-A syn_flood -m comment --comment "!fw3" -j DROP
-A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
-A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
-A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
-A zone_lan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
-A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
-A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
-A zone_lan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
-A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
-A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
-A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
-A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
-A zone_wan_dest_ACCEPT -o eth0.1 -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
-A zone_wan_dest_ACCEPT -o eth0.1 -m comment --comment "!fw3" -j ACCEPT
-A zone_wan_dest_REJECT -o eth0.1 -m comment --comment "!fw3" -j reject
-A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
-A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
-A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
-A zone_wan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
-A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
-A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
-A zone_wan_input -p udp -m udp --dport 68 -m comment --comment "!fw3: Allow-DHCP-Renew" -j ACCEPT
-A zone_wan_input -p icmp -m icmp --icmp-type 8 -m comment --comment "!fw3: Allow-Ping" -j ACCEPT
-A zone_wan_input -p igmp -m comment --comment "!fw3: Allow-IGMP" -j ACCEPT
-A zone_wan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
-A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
-A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
-A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
-A zone_wan_src_REJECT -i eth0.1 -m comment --comment "!fw3" -j reject
COMMIT
# Completed on Thu Oct 24 12:35:43 2019
# Generated by ip6tables-save v1.8.3 on Thu Oct 24 12:35:43 2019
*mangle
:PREROUTING ACCEPT [46:17365]
:INPUT ACCEPT [2:128]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [12:1184]
:POSTROUTING ACCEPT [12:1184]
-A FORWARD -o eth0.1 -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
COMMIT
# Completed on Thu Oct 24 12:35:43 2019
# Generated by ip6tables-save v1.8.3 on Thu Oct 24 12:35:43 2019
*filter
:INPUT ACCEPT [0:0]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [0:0]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
-A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
-A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
-A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
-A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
-A INPUT -i eth0.1 -m comment --comment "!fw3" -j zone_wan_input
-A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
-A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
-A FORWARD -i eth0.1 -m comment --comment "!fw3" -j zone_wan_forward
-A FORWARD -m comment --comment "!fw3" -j reject
-A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
-A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
-A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
-A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
-A OUTPUT -o eth0.1 -m comment --comment "!fw3" -j zone_wan_output
-A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
-A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp6-port-unreachable
-A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
-A syn_flood -m comment --comment "!fw3" -j DROP
-A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
-A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
-A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
-A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
-A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
-A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
-A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
-A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
-A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
-A zone_wan_dest_ACCEPT -o eth0.1 -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
-A zone_wan_dest_ACCEPT -o eth0.1 -m comment --comment "!fw3" -j ACCEPT
-A zone_wan_dest_REJECT -o eth0.1 -m comment --comment "!fw3" -j reject
-A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
-A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
-A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
-A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
-A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
-A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
-A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
-A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
-A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
-A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
-A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
-A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
-A zone_wan_input -s fc00::/6 -d fc00::/6 -p udp -m udp --dport 546 -m comment --comment "!fw3: Allow-DHCPv6" -j ACCEPT
-A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 130/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
-A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 131/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
-A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 132/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
-A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 143/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 133 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 135 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 134 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 136 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
-A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
-A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
-A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
-A zone_wan_src_REJECT -i eth0.1 -m comment --comment "!fw3" -j reject
COMMIT
# Completed on Thu Oct 24 12:35:43 2019
# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
lrwxrwxrwx    1 root     root            16 Oct 22 13:16 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 Oct 24 12:28 /tmp/resolv.conf
-rw-r--r--    1 root     root           110 Oct 24 12:32 /tmp/resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==
# Interface wan
nameserver 192.168.0.1
search fritz.box
# Interface wan6
nameserver fd00::9a9b:cbff:feca:cb1e

What address are you trying to ping?
Does the default gateway reply? (fe80::9a9b:cbff:feca:cb1e)
Run a tcpdump to verify that packets go out and return.
tcpdump -i eth0.1 -vvn icmp6

I've run all of the commands on OpenWRT. I installed tcpdump in luci.

PING fe80::9a9b:cbff:feca:cb1e (fe80::9a9b:cbff:feca:cb1e): 56 data bytes

--- fe80::9a9b:cbff:feca:cb1e ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss
PING google.com (2a00:1450:4001:81a::200e): 56 data bytes

--- google.com ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss
PING openwrt.org (2a03:b0c0:3:d0::1af1:1): 56 data bytes

--- openwrt.org ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

tcpdump for openwrt.org ping:

tcpdump: listening on eth0.1, link-type EN10MB (Ethernet), capture size 262144 bytes
13:00:23.812377 IP6 (flowlabel 0xf5f42, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f7c::1 > 2a03:b0c0:3:d0::1af1:1: [icmp6 sum ok] ICMP6, echo request, seq 0
13:00:24.820902 IP6 (flowlabel 0xf5f42, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f7c::1 > 2a03:b0c0:3:d0::1af1:1: [icmp6 sum ok] ICMP6, echo request, seq 1
13:00:25.830856 IP6 (flowlabel 0xf5f42, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f7c::1 > 2a03:b0c0:3:d0::1af1:1: [icmp6 sum ok] ICMP6, echo request, seq 2
13:00:26.840851 IP6 (flowlabel 0xf5f42, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f7c::1 > 2a03:b0c0:3:d0::1af1:1: [icmp6 sum ok] ICMP6, echo request, seq 3
13:00:27.850833 IP6 (flowlabel 0xf5f42, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f7c::1 > 2a03:b0c0:3:d0::1af1:1: [icmp6 sum ok] ICMP6, echo request, seq 4
13:00:28.870721 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::9ada:c4ff:fe92:6086 > fe80::9a9b:cbff:feca:cb1e: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::9a9b:cbff:feca:cb1e
          source link-address option (1), length 8 (1): 98:da:c4:92:60:86
            0x0000:  98da c492 6086
13:00:28.870983 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::9a9b:cbff:feca:cb1e > fe80::9ada:c4ff:fe92:6086: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::9a9b:cbff:feca:cb1e, Flags [router, solicited]

my mobile phone is connected to the wifi of the old router. On test-ipv6.com it gets 10/10

Can you try this?
ping -I 2a02:908:1139:7f60:9ada:c4ff:fe92:6086 ipv6.google.com

after very long time something happened:

root@OpenWrt:~# ping -I 2a02:908:1139:7f60:9ada:c4ff:fe92:6086 ipv6.google.com
PING ipv6.google.com (2a00:1450:4001:800::200e) from 2a02:908:1139:7f60:9ada:c4ff:fe92:6086: 56 data bytes
64 bytes from 2a00:1450:4001:800::200e: seq=0 ttl=54 time=44859.594 ms
64 bytes from 2a00:1450:4001:800::200e: seq=1 ttl=54 time=43854.387 ms
64 bytes from 2a00:1450:4001:800::200e: seq=2 ttl=54 time=42844.501 ms
64 bytes from 2a00:1450:4001:800::200e: seq=3 ttl=54 time=41834.589 ms
64 bytes from 2a00:1450:4001:800::200e: seq=4 ttl=54 time=40825.235 ms
64 bytes from 2a00:1450:4001:800::200e: seq=5 ttl=54 time=39815.255 ms
64 bytes from 2a00:1450:4001:800::200e: seq=6 ttl=54 time=38805.450 ms
64 bytes from 2a00:1450:4001:800::200e: seq=7 ttl=54 time=37795.571 ms
64 bytes from 2a00:1450:4001:800::200e: seq=15 ttl=54 time=29715.777 ms
64 bytes from 2a00:1450:4001:800::200e: seq=16 ttl=54 time=28705.890 ms
64 bytes from 2a00:1450:4001:800::200e: seq=17 ttl=54 time=27695.993 ms
64 bytes from 2a00:1450:4001:800::200e: seq=18 ttl=54 time=26686.089 ms
64 bytes from 2a00:1450:4001:800::200e: seq=27 ttl=54 time=17606.362 ms
64 bytes from 2a00:1450:4001:800::200e: seq=28 ttl=54 time=16596.485 ms
64 bytes from 2a00:1450:4001:800::200e: seq=29 ttl=54 time=15586.556 ms
64 bytes from 2a00:1450:4001:800::200e: seq=30 ttl=54 time=14576.659 ms
64 bytes from 2a00:1450:4001:800::200e: seq=31 ttl=54 time=13566.765 ms
64 bytes from 2a00:1450:4001:800::200e: seq=32 ttl=54 time=12556.892 ms
64 bytes from 2a00:1450:4001:800::200e: seq=33 ttl=54 time=11546.981 ms
64 bytes from 2a00:1450:4001:800::200e: seq=34 ttl=54 time=10537.194 ms
64 bytes from 2a00:1450:4001:800::200e: seq=36 ttl=54 time=8517.442 ms
64 bytes from 2a00:1450:4001:800::200e: seq=37 ttl=54 time=7508.679 ms
64 bytes from 2a00:1450:4001:800::200e: seq=38 ttl=54 time=6498.771 ms
64 bytes from 2a00:1450:4001:800::200e: seq=39 ttl=54 time=5488.892 ms
64 bytes from 2a00:1450:4001:800::200e: seq=40 ttl=54 time=4478.973 ms
64 bytes from 2a00:1450:4001:800::200e: seq=41 ttl=54 time=3469.087 ms
64 bytes from 2a00:1450:4001:800::200e: seq=42 ttl=54 time=2459.180 ms
64 bytes from 2a00:1450:4001:800::200e: seq=43 ttl=54 time=1449.382 ms
64 bytes from 2a00:1450:4001:800::200e: seq=44 ttl=54 time=439.516 ms
64 bytes from 2a00:1450:4001:800::200e: seq=45 ttl=54 time=14.962 ms
64 bytes from 2a00:1450:4001:800::200e: seq=46 ttl=54 time=19.969 ms
64 bytes from 2a00:1450:4001:800::200e: seq=47 ttl=54 time=13.897 ms
64 bytes from 2a00:1450:4001:800::200e: seq=48 ttl=54 time=14.339 ms
64 bytes from 2a00:1450:4001:800::200e: seq=49 ttl=54 time=16.962 ms
64 bytes from 2a00:1450:4001:800::200e: seq=50 ttl=54 time=12.555 ms
64 bytes from 2a00:1450:4001:800::200e: seq=51 ttl=54 time=13.998 ms
64 bytes from 2a00:1450:4001:800::200e: seq=52 ttl=54 time=12.119 ms
64 bytes from 2a00:1450:4001:800::200e: seq=53 ttl=54 time=13.893 ms
64 bytes from 2a00:1450:4001:800::200e: seq=54 ttl=54 time=16.819 ms
64 bytes from 2a00:1450:4001:800::200e: seq=55 ttl=54 time=13.357 ms
64 bytes from 2a00:1450:4001:800::200e: seq=56 ttl=54 time=12.870 ms
64 bytes from 2a00:1450:4001:800::200e: seq=57 ttl=54 time=13.378 ms
64 bytes from 2a00:1450:4001:800::200e: seq=58 ttl=54 time=21.005 ms
64 bytes from 2a00:1450:4001:800::200e: seq=59 ttl=54 time=14.206 ms
64 bytes from 2a00:1450:4001:800::200e: seq=60 ttl=54 time=14.180 ms
64 bytes from 2a00:1450:4001:800::200e: seq=61 ttl=54 time=12.179 ms
64 bytes from 2a00:1450:4001:800::200e: seq=62 ttl=54 time=13.369 ms
64 bytes from 2a00:1450:4001:800::200e: seq=63 ttl=54 time=13.273 ms
64 bytes from 2a00:1450:4001:800::200e: seq=64 ttl=54 time=13.365 ms
64 bytes from 2a00:1450:4001:800::200e: seq=65 ttl=54 time=20.446 ms
64 bytes from 2a00:1450:4001:800::200e: seq=66 ttl=54 time=12.752 ms
64 bytes from 2a00:1450:4001:800::200e: seq=67 ttl=54 time=13.842 ms
^C
--- ipv6.google.com ping statistics ---
68 packets transmitted, 52 packets received, 23% packet loss
round-trip min/avg/max = 12.119/11474.228/44859.594 ms

When I restarted pinging, it didn't reply in short time again

edit: or in long time...

--- ipv6.google.com ping statistics ---
520 packets transmitted, 0 packets received, 100% packet loss

Have you installed any other packages on the OpenWrt by any chance? These are terrible response times for ping by the way.

Usually the ping should be like 20 or less. Just like at the end of the first test. I manually installed luci and openssh-sftp-server. I flashed newest openwrt-ramips-mt7621-tplink_re650-v1-squashfs-sysupgrade.bin on tuesday. It's a snapshot build because the device has no release yet

I had almost the same issues when I was trying to make mwan3 work, but this doesn't seem to be the case with you.
One more troubleshooting if you may:
ifstatus wan ; ifstatus wan6 ; ifstatus lan

root@OpenWrt:~# ifstatus wan ; ifstatus wan6 ; ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 6426,
        "l3_device": "eth0.1",
        "proto": "dhcp",
        "device": "eth0.1",
        "updated": [
                "addresses",
                "routes",
                "data"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.0.3",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "192.168.0.1",
                        "source": "192.168.0.3/32"
                }
        ],
        "dns-server": [
                "192.168.0.1"
        ],
        "dns-search": [
                "fritz.box"
        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "leasetime": 864000,
                "ntpserver": "192.168.0.1"
        }
}
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 6422,
        "l3_device": "eth0.1",
        "proto": "dhcpv6",
        "device": "eth0.1",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a02:908:1139:7f60:9ada:c4ff:fe92:6086",
                        "mask": 64,
                        "preferred": 3288,
                        "valid": 6888
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2a02:908:1139:7f7c::",
                        "mask": 62,
                        "preferred": 2586,
                        "valid": 6186,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2a02:908:1139:7f7c::",
                                        "mask": 62
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2a02:908:1139:7f60::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 6888,
                        "source": "::/0"
                },
                {
                        "target": "2a02:908:1139:7f60::",
                        "mask": 59,
                        "nexthop": "fe80::9a9b:cbff:feca:cb1e",
                        "metric": 512,
                        "valid": 1488,
                        "source": "2a02:908:1139:7f7c::/62"
                },
                {
                        "target": "2a02:908:1139:7f60::",
                        "mask": 59,
                        "nexthop": "fe80::9a9b:cbff:feca:cb1e",
                        "metric": 512,
                        "valid": 1488,
                        "source": "2a02:908:1139:7f60:9ada:c4ff:fe92:6086/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::9a9b:cbff:feca:cb1e",
                        "metric": 512,
                        "valid": 1488,
                        "source": "2a02:908:1139:7f7c::/62"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::9a9b:cbff:feca:cb1e",
                        "metric": 512,
                        "valid": 1488,
                        "source": "2a02:908:1139:7f60:9ada:c4ff:fe92:6086/64"
                }
        ],
        "dns-server": [
                "fd00::9a9b:cbff:feca:cb1e"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "0038001401001000fd000000000000009a9bcbfffecacb1e00170010fd000000000000009a9bcbfffecacb1e005600102a02090811397f609a9bcbfffecacb1e"
        }
}
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 6427,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "2a02:908:1139:7f7c::",
                        "mask": 62,
                        "preferred": 2586,
                        "valid": 6186,
                        "local-address": {
                                "address": "2a02:908:1139:7f7c::1",
                                "mask": 62
                        }
                },
                {
                        "address": "fd78:7ef:f495::",
                        "mask": 60,
                        "local-address": {
                                "address": "fd78:7ef:f495::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

Before I run out of ideas, try to switch the following to hybrid, rather than relay, which requires extra configuration in the wan interface.

dhcp.lan.ra_slaac='1'
dhcp.lan.ra_flags='managed-config' 'other-config'
dhcp.lan.ra='relay'
dhcp.lan.dhcpv6='relay'
dhcp.lan.ndp='relay'

https://openwrt.org/docs/guide-user/network/ipv6/start#router_advertisement_dhcpv6

I'm not sure how to set up the wan interface. In the lan interface I set everything to hybrid. Ping still not working. This is the current dhcp config for wan interface:

config dhcp 'wan'
	option interface 'wan'
	option disabled '1'

Which interface is openhab actually using for pinging? Does it even go through lan interface or does it just use wan and wan6?

I pinged ipv6.google.com from a pc that is directly hooked up to the router. That worked without a problem:

dergerat@dergerat:~$ ping -6 ipv6.google.com
PING ipv6.google.com(fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e)) 56 data bytes
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=1 ttl=54 time=15.9 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=2 ttl=54 time=14.0 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=3 ttl=54 time=13.9 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=4 ttl=54 time=17.1 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=5 ttl=54 time=13.2 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=6 ttl=54 time=14.2 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=7 ttl=54 time=24.5 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=8 ttl=54 time=13.4 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=9 ttl=54 time=17.5 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=10 ttl=54 time=13.7 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=11 ttl=54 time=14.6 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=12 ttl=54 time=13.7 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=13 ttl=54 time=14.6 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=14 ttl=54 time=15.1 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=15 ttl=54 time=13.5 ms
64 bytes from fra16s45-in-x0e.1e100.net (2a00:1450:4001:800::200e): icmp_seq=16 ttl=54 time=15.0 ms
^C
--- ipv6.google.com ping statistics ---
16 packets transmitted, 16 received, 0% packet loss, time 15023ms
rtt min/avg/max/mdev = 13.237/15.289/24.565/2.692 ms
root@dergerat:/home/dergerat# tcpdump -i wlp6s0 -vvn icmp6
tcpdump: listening on wlp6s0, link-type EN10MB (Ethernet), capture size 262144 bytes
18:58:16.514658 IP6 (flowlabel 0x41f58, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f60:9c61:fa36:9f2a:9b6a > 2a00:1450:4001:800::200e: [icmp6 sum ok] ICMP6, echo request, seq 1
18:58:16.529489 IP6 (flowlabel 0x41f58, hlim 54, next-header ICMPv6 (58) payload length: 64) 2a00:1450:4001:800::200e > 2a02:908:1139:7f60:9c61:fa36:9f2a:9b6a: [icmp6 sum ok] ICMP6, echo reply, seq 1
18:58:17.516264 IP6 (flowlabel 0x41f58, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f60:9c61:fa36:9f2a:9b6a > 2a00:1450:4001:800::200e: [icmp6 sum ok] ICMP6, echo request, seq 2
18:58:17.538647 IP6 (flowlabel 0x41f58, hlim 54, next-header ICMPv6 (58) payload length: 64) 2a00:1450:4001:800::200e > 2a02:908:1139:7f60:9c61:fa36:9f2a:9b6a: [icmp6 sum ok] ICMP6, echo reply, seq 2
18:58:18.517055 IP6 (flowlabel 0x41f58, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f60:9c61:fa36:9f2a:9b6a > 2a00:1450:4001:800::200e: [icmp6 sum ok] ICMP6, echo request, seq 3
18:58:18.532171 IP6 (flowlabel 0x41f58, hlim 54, next-header ICMPv6 (58) payload length: 64) 2a00:1450:4001:800::200e > 2a02:908:1139:7f60:9c61:fa36:9f2a:9b6a: [icmp6 sum ok] ICMP6, echo reply, seq 3
18:58:19.518322 IP6 (flowlabel 0x41f58, hlim 255, next-header ICMPv6 (58) payload length: 64) 2a02:908:1139:7f60:9c61:fa36:9f2a:9b6a > 2a00:1450:4001:800::200e: [icmp6 sum ok] ICMP6, echo request, seq 4
18:58:19.546853 IP6 (flowlabel 0x41f58, hlim 54, next-header ICMPv6 (58) payload length: 64) 2a00:1450:4001:800::200e > 2a02:908:1139:7f60:9c61:fa36:9f2a:9b6a: [icmp6 sum ok] ICMP6, echo reply, seq 4

I checked the configuration of the switch. There are many options but nothing seems to belong to ipv6. Everything is on default settings there besides of vlan configuration. I gonna try to hook OpenWRT directly to the router without the switch in between later.

I was referring to this

config dhcp wan
    option dhcpv6 relay
    option ra relay
    option ndp relay
    option master 1

From what I've seen it uses an IP from the LAN, or any other available interface. Could be GUEST too.

A switch cannot be the problem, because it operates in Layer 2, while IPv4 and IPv6 are in Layer 3.

I got some news.

First of all: I hooked up a PC to the same switch, directly connected to the old router. Pinging ipv6.google.com works. Then I used the same cable and put it to OpenWRT and nope. At least the same ipv6-address got dns-resolved. I tried to minimize all the files to just get a bare minimum of configuration files, but still the same.

Then I took out an old TP-Link TL-WA850RE v1 with OpenWRT. I copied the same minimum-configuration files and pinging ipv6 worked. So my conclusion is: I don't think that the RE650's Hardware is broken. There must be a problem with the OpenWRT software for the device.

Here are my minimum files:
/etc/config/dhcp: empty
/etc/config/wireless: only keep wifi-devices (radio). delete all interfaces. otherwise the file gets recreated at reboot
/etc/config/firewall (only keep a default rule):

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config include
	option path '/etc/firewall.user'

/etc/config/network on RE650 (I think there is an integrated switch. I didn't try to remove the lines):

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd34:ce41:1e54::/48'

config interface 'lan'
	option ifname 'eth0.1'
	option proto 'dhcp'

config interface 'lan6'
	option ifname '@lan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 6t'

/etc/config/network on TP-Link TL-WA850RE v1:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0a:b36e:24b4::/48'

config interface 'lan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'lan6'
	option ifname '@lan'
	option proto 'dhcpv6'

That is from TP-Link TL-WA850RE v1 device:

PING openwrt.org (2a03:b0c0:3:d0::1af1:1): 56 data bytes
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=0 ttl=55 time=15.862 ms
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=1 ttl=55 time=22.555 ms
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=2 ttl=55 time=13.299 ms
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=3 ttl=55 time=14.246 ms
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=4 ttl=55 time=14.526 ms

--- openwrt.org ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 13.299/16.097/22.555 ms

Now we know why RE650 just has a snapshot build. If there are any devs reading this: I found a bug :slight_smile:
@trendy thank you very much for your time! I'm sorry that we couldn't solve the problem together.

Well... we did our best anyway. I hope in the future to get some stable release available and surf problem-free.