Rootfs not showing in df (TP-Link) & factory resetting

Hello guys, i am in a serious dilemma, i have Tp-link wr941nd v3.2 router with 4 mb flash. The only image which works with it is official openwrt 12.09 Attitude adjustment or gargoyle 1.6.x. I dont use dd-wrt because it had a problem of writing to Intel S33 flash (got it recovered through serial tftp and wget) and i want to use AdBlock and SQM. Apart from these rest all builds keeps on resetting to factory settings and rebooting after 2-3 minutes. I have been trying to make it work for many months on and off, but now i am at end of my wits.

So based on my testing, difference in 12.09 is that by using df -h command i get rootfs partition

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    1.1M    232.0K    856.0K  21% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    14.3M    892.0K     13.4M   6% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock3            1.1M    232.0K    856.0K  21% /overlay
overlayfs:/overlay        1.1M    232.0K    856.0K  21% /

Where as in all other around 25 different builds (community builds included) that i have tried rootfs is not mounted on / and its df output is like this

root@LEDE:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2048      2048         0 100% /rom
tmpfs                    14600       404     14196   3% /tmp
/dev/mtdblock3             960       236       724  25% /overlay
overlayfs:/overlay         960       236       724  25% /
tmpfs                      512         0       512   0% /dev

Is this rootfs the issue that i am not able to keep newer builds running for more than 2-3 minutes?
Thank you for your help.

edit: one more thing, serial port log just mentions factory resetting, no other info why is it happening, i can test other things out if you want. Thanks

If it helps here are the kernel log taken from luci interface.
Compared both, found differences in partitions size , also
[ 8.115537] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
in 18.06. Kindly help.

I certainly don’t recall mount tables from 2012 and Attitude Adjustment is not supported, running on a kernel with significant, well-known security problems and the applications and even 802.11 protocols have the same problems.

You’ll likely never get SQM and AdBlock running on an old 4 MB router between flash and RAM limitations. With a 400 MHz MIPS-based SoC, even if you got it installed, much more than 100 mbps of throughput with SQM would surprise me.

More info on your router’s device page

Suitable replacement devices start at under US$20

Yeah jeff, you are right my router is almost obsolete, but even then i have tried 2.7mb tiny and maximum stripped firmware and they do not run stably.
The log files i have provided are for default official openwrt builds, but same reset, reboot happens in lite builds too.
May be a hw issue but tplink fw runs ok as well as 12.09 builds.

OK, let me be blunt -- it is obsolete and has been for several years.

Secure firmware that has SQM and AdBlock isn't going to run on that device. All the firmware you have had any success with, including the TP-Link firmware, is known insecure. 12.09 is now seven years old and is not supported. It's somewhere between irresponsible and stupid to be running seven-year-old firmware that is known to be insecure on a device that faces the Internet when suitable replacements are available for not much more than a coffee and a beer. (which is hardly "new' content) and linked on the device page

32 MB can work for minimal router/AP functions, but may repeatedly “crash”, depending on your hardware and use case

4MB devices can't fit anything noteworthy

Well, time to buy a new router then. Thanks for your help

There are some good suggestions at

and the posts following. Ignore the title, as the responses are to the perceived intent of the OP's question.

If looking for a low- or moderately-priced option, there are may opinions in the very long thread

Knowing your budget and needs (and location, as prices vary across the world) would help narrow things down, if you wanted further suggestions of devices to consider.

1 Like