Root password issue for 21.02 RC2 on Raspberry Pi 3 B?

Hey all.
I know normally openwrt has no default root password but somehow it's asking me a real root password. I mean not the blank password.
I downloaded the file twice and verified its sha256sum. I even tried formatting my microsd card more than once. But it still asks for password on first boot, so I can't login to LuCi or connect via ssh.
No such problem on 19.07.7 btw. I guess only for 21.02 RC2.

I'm using


I would be very grateful if someone could try this and correct/verify me. I am pretty shocked tbh lol.
Thanks in advance.

As it is installed on an SD Card just plug the SD card into a PC and check the password file.

Thanks for your reply.
I tried that but sadly there is no password file on microsd card.

The password file most likely is on the second parition that is formatted with ext2 (my guess haven't used openwrt on the Pi) and OS X stupidly can not read ext2 natively. Suggest to fireup virtualbox with a Linux OS that will allow you to read it.
Or you can connect SD Card reader to the Pi when you boot from another SD card to check this card from the Pi.

how exactly?

I meant erasing the microsd card with disk utility on my mac

1 Like

most likely it hasn't played ball with the partition scheme... your going to need to dd zero's or 'zero out data' on a (fulldisk) partition or use another tool...

carefull with these tools...

I burned that exact image, but not booted from it: there is no root password:

cat /etc/shadow

I think you are right guys. I guess my microsd card is "dirty" from previous uses somehow. Exactly like as you said. I should clean it before retry.
So how can I do that on ubuntu? Like this one? I'm not sure how to do that.
sudo dd if=zero of=/dev/mmcblk

it may be '/dev/mmcblk0'

tip: you don't really need to zero the whole thing... you just need to go over the previous overlay filesystem which is beyond the rootfs...

so to speed things up something like;

dd if=/dev/zero of=/dev/mmcblkX bs=1M count=1000; sync

should be ok...

You were completely right. dd zero'ing the sd card did the trick. Thanks a lot.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.