Root password <empty> not accepted by Luci 19.07 (Kimax U35WF)

Hi,

I have just tried to install OpenWrt 19.07.2 r10947-65030d81f3 on my router Kimax U35WF.
After install, I was able to see my login page.
In the manual it says that my initial username is "root".
If you leave the passwordfield empty, it should login (for the first time).

I was able to see the loginpage, but OpenWRT keeps refusing me from logging in.
Also by SSH no login is possible.
It seems that the password is different or my firmwareupdate did not succeed.

Can anyone tell me how to login? Is another password available for release 19.07.2 ?
Or can anyone tell me how to reinstall OpenWRT?
I am not able to login now, so logfiles I cannot get from the router.

I see a lot of technical logs, but my Unix knowledge is limited and I cannot handle this.
Can one of you tell me in plain English what I should do now?
If more logging is needed, can you explain how I can provide this extra logging?

Welcome to the commmunity Wietse.

It looks like you're not the first bumping into this (maybe the manufacturer is using a modified OpenWrt?):

Which instructions did you follow? Did you install a vanilla build from OpenWrt itself or some community build? What commands did you run to install OpenWrt? If it was sysupgrade of some kind you should pass -n so it does not keep configs.

1 Like

Your router is a rarity, as it apparently uses modified OpenWrt sysupgrade for its own sysupgrading (and flashing OpenWrt???), so some of its settings survive.

Here is a link to forum search:
https://forum.openwrt.org/search?q=u35wf%20order%3Alatest

Based on those, the router apparently disables root login via SSH.
See here: Blueendless Kimax BS-U35-WF

The reason why this happens is that the OEM GUI flash method preserves the unix user configuration in the /etc/passwd and /etc/shadow files from the Kimax firmware and copies them over to OpenWrt.

/etc/passwd:

admin:x:0:0:root:/root:/bin/false
guest:x:0:0:root:/root:/bin/false
#root:x:0:0:root:/root:/bin/false

You might need to use the account and password you used with Kimax firmware?
"admin" ????

You might need to revert to failsafe mode, edit the /etc/passwd there, so that root is again allowed with the normal ash:

 OpenWrt 19.07-SNAPSHOT, r11047-81f3f6540e
 -----------------------------------------------------
root@router1:~# cat /etc/passwd
root:x:0:0:root:/root:/bin/ash
1 Like

Resetting it to OpenWrt defaults (firstboot) should be the next step, once you've gained access.

1 Like

UN: admin
PW: kimax